Bug 119316 - kernel panic
kernel panic
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel (Show other bugs)
2.1
athlon Linux
high Severity high
: ---
: ---
Assigned To: Jason Baron
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-29 07:49 EST by Mathieu Bernier
Modified: 2013-03-06 00:56 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-11 12:02:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Kernel panic on Apache restart (820.53 KB, image/jpeg)
2004-03-29 08:08 EST, Mathieu Bernier
no flags Details

  None (edit)
Description Mathieu Bernier 2004-03-29 07:49:22 EST
Description of problem:

kernel panic while restarting Apache

Version-Release number of selected component (if applicable):

kernel-2.4.9-e.38
apache-1.3.27-6.ent

How reproducible:

very often on this system.


Steps to Reproduce:
1.Restart Apache service
  
Actual results:

Kernel panic, see picture
Comment 1 Mathieu Bernier 2004-03-29 08:08:24 EST
Created attachment 98922 [details]
Kernel panic on Apache restart

Screen appears when restarting the Apache server
Comment 2 Suzanne Hillman 2004-04-01 14:52:00 EST
This is specific to a machine? Is it reproducable on any other machines?
Comment 3 Jason Baron 2004-04-01 16:37:25 EST
hmm, i really appreciate the screen shot, but its missing the
beginning of the panic, which has very valuable info. is it in the
/var/log/messages file? Any other information would be helpful, i
don't have much to go on at this point. thanks.
Comment 4 Mathieu Bernier 2004-04-02 02:13:30 EST
Unfortunately, the server on which we had the kernel panic is one of
the most used in our company. So, we didn't let it out a long time.
That's why we don't have any other informations. But we'll look at
other screenshots (we did many) and if we get the informations you
asked I'll send you.
Comment 5 Mathieu Bernier 2004-04-02 02:40:36 EST
Here is  a list of peripherals of the two systems on which we had the
kernel panic :

First : Athlon/Duron 1.2 Ghz with 1,5 Go SD-RAM and 120 Go RAID IDE
HARDDRIVE.
00:00.0 Host bridge: VIA Technologies, Inc. VT8363/8365 [KT133/KM133]
(rev 03)
00:01.0 PCI bridge: VIA Technologies, Inc. VT8363/8365 [KT133/KM133 AGP]
00:07.0 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super
South] (rev 40)
00:07.1 IDE interface: VIA Technologies, Inc. Bus Master IDE (rev 06)
00:07.4 Host bridge: VIA Technologies, Inc. VT82C686 [Apollo Super
ACPI] (rev 40)
00:08.0 SCSI storage controller: Adaptec 7892A (rev 02)
00:0d.0 Ethernet controller: 3Com Corporation 3c905C-TX [Fast
Etherlink] (rev 78)
01:00.0 VGA compatible controller: ATI Technologies Inc Rage 128 RF


Second : Compaq Proliant ML350 G2 with 2 Go of RAM
00:00.0 Host bridge: ServerWorks CNB20LE Host Bridge (rev 06)
00:00.1 Host bridge: ServerWorks CNB20LE Host Bridge (rev 06)
00:02.0 SCSI storage controller: Adaptec 7899A (rev 01)
00:02.1 SCSI storage controller: Adaptec 7899A (rev 01)
00:04.0 Ethernet controller: Intel Corporation 82557 [Ethernet Pro
100] (rev 08)
00:05.0 VGA compatible controller: ATI Technologies Inc Rage XL (rev 27)
00:06.0 System peripheral: Compaq Computer Corporation Advanced System
Management Controller
00:0f.0 ISA bridge: ServerWorks CSB5 South Bridge (rev 92)
00:0f.1 IDE interface: ServerWorks CSB5 IDE Controller (rev 92)
00:0f.2 USB Controller: ServerWorks OSB4/CSB5 OHCI USB Controller (rev 05)
00:0f.3 Host bridge: ServerWorks: Unknown device 0230
02:05.0 RAID bus controller: Compaq Computer Corporation Smart Array
5i/532 (rev 01)

We'll try to reproduce the kernel panic today and get more
informations on a screenshot.
Comment 6 Mathieu Bernier 2004-04-08 04:40:37 EDT
We're always trying to get more debug messages from the kernel panic.
We can now reproduce the panic during a test. We use those softwares:

- Oracle Database 9i 9.2.0.4
- Oracle iAS 9.0.3
- Oracle iFS 9.0.3.9

There is a Tomcat server on the system which is running our web
application.

We can reproduce the panic while running one of our application JSP
which is sending many requests to the iFS server.

All those servers are running on the same machine.

Now we are trying to get more messages from the kernel panic itself.
Comment 7 Mathieu Bernier 2004-04-09 06:23:14 EDT
Now we're still working on the bug.

We wanted to know if there is a way to have a console larger than
80x25 in order to get more informations on the screen when the kernel
panic appears ?

Thanks
Comment 8 Jason Baron 2004-04-09 07:23:37 EDT
i'm not sure-perhaps you can set up serial console to capture the full
panic text? 
Comment 9 Mathieu Bernier 2004-04-09 10:54:12 EDT
Well, no. I found the way to configure the console with a larger
resolution (1024x768).

I hope this will be enough to get all the message.

Currently, I'm trying to reproduce the Oops with this new configuration.
Comment 10 Jason Baron 2004-05-13 18:09:39 EDT
Any updates on this one? how many times have you seen the panic? Is it
still present on the latest updated kernel, e.40?
Comment 11 Jason Baron 2004-06-01 11:13:58 EDT
I'm really interested in the status of this bug. Any additional
updates or information? thanks.
Comment 12 Mathieu Bernier 2004-06-02 05:41:32 EDT
We don't have any additional updates because we upgraded our servers
to the e40 kernel. But another bug is open for this one at :

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=121327

Thanks
Comment 13 Suzanne Hillman 2005-04-11 12:02:29 EDT
Closing due to lack of additional information.
Comment 14 Suzanne Hillman 2005-04-11 12:03:14 EDT
Ehem. Lack of additional information due to upgrade, I mean.

Note You need to log in before you can comment on or make changes to this bug.