Due to a recent update on Javascript code a full page refresh on your browser might be needed.
Bug 1193160 - tnef not in EPEL5
Summary: tnef not in EPEL5
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: tnef
Version: el5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: David Timms
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-16 17:30 UTC by Paul Sand
Modified: 2015-05-01 19:41 UTC (History)
3 users (show)

Fixed In Version: tnef-1.4.12-2.el5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-01 19:40:35 UTC
Type: Bug


Attachments (Terms of Use)

Description Paul Sand 2015-02-16 17:30:59 UTC
Description of problem:

Although 
https://admin.fedoraproject.org/pkgdb/package/tnef/
shows that the tnef RPM should be available in EPEL5, it does not appear when querying on a Red Hat 5 system with EPEL enabled.

Version-Release number of selected component (if applicable):
1.49

How reproducible:
Run as root on a RH5 system:
yum list available | grep tnef

Steps to Reproduce:
1. Run yum list available | grep tnef
2.
3.

Actual results:                    

No tnef package seen in output

Expected results:
Something like:

tnef.x86_64                      1.4.9-1.el5       epel     


Additional info:

The MailScanner developers (http://mailscanner.info/) would like to see it in EPEL-7 too, although that's a separate issue.

Comment 1 David Timms 2015-02-18 11:39:33 UTC
It's past my memory, but:
http://koji.fedoraproject.org/koji/packageinfo?packageID=12262
shows to attempted builds for EPEL-5 which failed.

I'm struggling to remember the cause, but it may have been not compiling on PPC.

I plan to take a look on the weekend...

Comment 2 David Timms 2015-02-18 21:34:07 UTC
mock result:
---
DEBUG util.py:389:  gcc-c++-4.1.2-55.el5.x86_64
DEBUG util.py:500:  Child return code was: 0
DEBUG util.py:519:  child environment: None
DEBUG util.py:453:  Executing command: ['/bin/rpm', '-Uvh', '--nodeps', '/builddir/build/originals/tnef-1.4.12-1.fc20.src.rpm'] with env {'LANG': 'en_AU.UTF-8', 'TERM': 'vt100', 'SHELL': '/bin/bash', 'CCACHE_DIR': '/tmp/ccache', 'HOSTNAME': 'mock', 'PROMPT_COMMAND': 'printf "\x1b]0;<mock-chroot>\x07<mock-chroot>"', 'HOME': '/builddir', 'PATH': '/usr/bin:/bin:/usr/sbin:/sbin', 'CCACHE_UMASK': '002'} and shell False
DEBUG util.py:389:  tnef                        warning: user davidt does not exist - using root
DEBUG util.py:389:  warning: group davidt does not exist - using root
DEBUG util.py:389:  ##################################################
DEBUG util.py:389:  error: unpacking of archive failed on file /builddir/build/SOURCES/tnef-1.4.12.tar.gz;54e4fa4c: cpio: MD5 sum mismatch
DEBUG util.py:500:  Child return code was: 1
DEBUG util.py:184:  kill orphans
---
Maybe:
http://www.redhat.com/archives/rhl-list/2009-July/msg02954.html
or:
https://lists.fedoraproject.org/pipermail/devel/2011-September/156484.html
or:... I've been here before...
https://bugzilla.redhat.com/show_bug.cgi?id=1005480

Comment 3 David Timms 2015-02-18 21:40:43 UTC
time rpmbuild -bs --define "_source_filedigest_algorithm md5" tnef.spec 
----
DEBUG util.py:389:  Getting requirements for tnef-1.4.12-1.el5.centos.src
DEBUG util.py:389:   --> automake-1.9.6-3.el5.noarch
DEBUG util.py:389:   --> autoconf-2.59-12.noarch
DEBUG util.py:389:   --> desktop-file-utils-0.10-7.x86_64
DEBUG util.py:389:  Error: No Package found for kde-filesystem
DEBUG util.py:500:  Child return code was: 1
DEBUG util.py:184:  kill orphans
DEBUG util.py:519:  child environment: None
----
Missing some requires on epel-5. Can you remember which Fedora version EL5 was based on ?

Comment 5 Nerijus Baliūnas 2015-02-21 12:58:04 UTC
The same for epel 7. The package is not available.

Comment 6 David Timms 2015-02-21 13:10:10 UTC
I've made a modification to the spec so that it desn't try to build the tnef-dolphin package on EL5. This seems OK, but will need to be tested by some EPEL5 users.

Comment 7 Fedora Update System 2015-02-21 13:20:39 UTC
tnef-1.4.12-2.el7 has been submitted as an update for Fedora EPEL 7.
https://admin.fedoraproject.org/updates/tnef-1.4.12-2.el7

Comment 8 Fedora Update System 2015-02-21 13:21:47 UTC
tnef-1.4.12-2.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/tnef-1.4.12-2.el5

Comment 9 Nerijus Baliūnas 2015-02-21 13:34:24 UTC
EPEL 6 has 1.4.9, so you may want to push update to it too.

Comment 10 Fedora Update System 2015-02-21 21:47:13 UTC
tnef-1.4.12-2.el7 has been pushed to the Fedora EPEL 7 testing repository.

Comment 11 David Timms 2015-04-25 02:39:53 UTC
Dear Paul Sand and Nerijus Baliūnas:
Would you find a few moments to try out the above builds on your systems. I don't have any EL systems, so pushing without your QA results would be pure guess work as to whether the package even runs.

You can use the https://admin.fedoraproject.org/updates/ links above to assign Karma for good/bad, and add a comment.

Comment 12 Nerijus Baliūnas 2015-04-25 10:13:58 UTC
tnef --version
tnef 1.4.11

on all 3 - el-5, el-6 and epel-7, otherwise works good.

Comment 13 Paul Sand 2015-04-25 14:55:41 UTC
(In reply to David Timms from comment #11)
> Dear Paul Sand and Nerijus Baliūnas:
> Would you find a few moments to try out the above builds on your systems. I
> don't have any EL systems, so pushing without your QA results would be pure
> guess work as to whether the package even runs.
> 
> You can use the https://admin.fedoraproject.org/updates/ links above to
> assign Karma for good/bad, and add a comment.

Works fine in RHEL 7, as near as I can tell. Thanks very much, David.

Comment 14 David Timms 2015-04-27 13:21:01 UTC
Thanks tnef users; I found that the version I have on Fedora 20 also is packaged as 1.4.12 but indicates 1.4.11  with --version. I'm going to hold off on the push to make sure the uploaded 1.4.12 source matches the upstream website, and ask if there was any changes to the .tar.gz since I initially downloaded it.

Comment 15 David Timms 2015-05-01 13:07:21 UTC
I've confirmed the source tarball md5sum matches the .src.rpm. It appears that configure.ac in the source wasn't updated to reflect the new release number. I considered patching, but have decided against it. The real source tarball is what has been packaged. I've hit the push to stable switch, so these will be available shortly for EL.

Comment 16 Fedora Update System 2015-05-01 19:40:35 UTC
tnef-1.4.12-2.el7 has been pushed to the Fedora EPEL 7 stable repository.

Comment 17 Fedora Update System 2015-05-01 19:41:08 UTC
tnef-1.4.12-2.el5 has been pushed to the Fedora EPEL 5 stable repository.


Note You need to log in before you can comment on or make changes to this bug.