Bug 1193183 - SCVMM - Unclustered hosts missing from relationship tree when a cluster is present
Summary: SCVMM - Unclustered hosts missing from relationship tree when a cluster is pr...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Insight
Version: 5.4.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: GA
: 5.4.0
Assignee: Bronagh Sorota
QA Contact: Milan Falešník
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-16 19:23 UTC by Bronagh Sorota
Modified: 2015-06-16 12:50 UTC (History)
4 users (show)

Fixed In Version: 5.4.0.0.11
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-16 12:50:52 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1100 0 normal SHIPPED_LIVE CFME 5.4.0 bug fixes, and enhancement update 2015-06-16 16:28:42 UTC

Description Bronagh Sorota 2015-02-16 19:23:51 UTC
Description of problem:

When a SCVMM provider has both clustered and unclustered hosts the unclustered hosts are omitted from the relationship tree.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:
see above


Expected results:

unclustered hosts should sit alongside the clusters in the relationship tree


Additional info:

Comment 2 CFME Bot 2015-02-16 22:20:58 UTC
New commit detected on manageiq/master:
https://github.com/ManageIQ/manageiq/commit/ec89e6fcef29991836a6e33f8e60ccf0dd15c65f

commit ec89e6fcef29991836a6e33f8e60ccf0dd15c65f
Author:     Bronagh Sorota <bsorota@redhat.com>
AuthorDate: Mon Feb 16 13:30:06 2015 -0500
Commit:     Bronagh Sorota <bsorota@redhat.com>
CommitDate: Mon Feb 16 14:27:26 2015 -0500

    Unclustered hosts are missing from relationship tree when a cluster is present
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1193183

 vmdb/app/models/ems_refresh/parsers/scvmm.rb               | 14 +++++++++-----
 .../models/ems_refresh/refreshers/scvmm_refresher_spec.rb  |  5 +++--
 2 files changed, 12 insertions(+), 7 deletions(-)

Comment 7 Bronagh Sorota 2015-05-13 14:36:21 UTC
Hi Milan,

I think screenshot #2 tells you which hosts are part of a cluster and which are stand alone. You can also go to:

- Open the Provider view of an SCVMM provider
- On the top right corner click on Host & Clusters (Under 'relationships')
- Make sure the correct hosts are grouped under the cluster they belong to and make sure any standalone hosts are shown outside the clusters.

Comment 8 Milan Falešník 2015-05-13 15:08:02 UTC
Verified (5.4.0.0.26)

Comment 10 errata-xmlrpc 2015-06-16 12:50:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1100.html


Note You need to log in before you can comment on or make changes to this bug.