Bug 119328 - add ~ "-noprobehdd" switch for syslinux to be passed to loader
add ~ "-noprobehdd" switch for syslinux to be passed to loader
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-29 10:55 EST by James Martin
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-22 10:41:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Martin 2004-03-29 10:55:04 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040207 Firefox/0.8

Description of problem:
I am installing RHEL3 on completely unconfigured HP DL series (560 G2
& 380 G3's) with CCISS h/w raid cards.  I would like to configure
these devices in %pre with the command line utility that HP provides;
however, I run into 2 obstacles that prevent an un-interrupted
installation (I will open the other obstacle in a seperate RFE):

Before anaconda is launched, loader tells me:

"No hard drives have been found.  You probably need                  
     to manually choose device drivers for the installation to
succeed.  Would you like to select drivers now?"

This is part of the checkForHardDrives function in loader.c. 
Obviously no hard drives have been found because none have been
configured yet.  How about a parameter that can be passed to
isolinux/syslinux/etc, such as "noprobehdd", so this message can be
avoided?

Version-Release number of selected component (if applicable):
anaconda-9.1.1-7.RHEL

How reproducible:
Always

Steps to Reproduce:
1. Build a HP server with an unconfigured CCISS array
2. Start the RHEL installer.
3. Watch the error.
Comment 1 Suzanne Hillman 2004-04-01 14:56:41 EST
Internal RFE bug #119721 entered; will be considered for future releases.
Comment 2 Suzanne Hillman 2004-04-22 10:41:17 EDT
Thank you for the suggestion. It was passed along to product
management, but not committed for a future release.

Note You need to log in before you can comment on or make changes to this bug.