Bug 119329 - re-probe hard drives after %pre is executed
re-probe hard drives after %pre is executed
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-29 11:09 EST by James Martin
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-21 14:46:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Martin 2004-03-29 11:09:14 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040207 Firefox/0.8

Description of problem:
This bug is related to #119328.  I would like to create CCISS logical
arrays using the cpqacuxe utility that HP provides.  This is a command
line utility that I have succesfully run in %pre.  The problem is that
anaconda must do some hdd checks when it is first run, and not after
%pre is run, because it always tells me:

The message is:

"An error has occurred - no valid devices were                       
   found on which to create new file systems. Please check your
hardware for the cause of this problem."

This is part of partedUtils.py in the checkNoDisks function.


It would be great if there was an option to re-probe suitable hdd's
for installation after %pre is run.  It works flawlessly if I run the
utility to configured the logical drives before anaconda is launched.



Version-Release number of selected component (if applicable):
anaconda-9.1.1-7.RHEL

How reproducible:
Always

Steps to Reproduce:
1.  Run the cpqacuxe utilty in %pre to configure CCISS logical drives
2.  Watch anaconda whine about "No valid devices.."

    

Additional info:
Comment 1 Suzanne Hillman 2004-04-01 14:58:43 EST
Internal RFE bug #119722 entered; will be considered for future releases.
Comment 2 Suzanne Hillman 2004-04-22 10:41:48 EDT
Thank you for the suggestion. It was passed along to product
management, but not committed for a future release.

Note You need to log in before you can comment on or make changes to this bug.