Bug 1193307 - tomcat: do not provide javax.el:el-api
Summary: tomcat: do not provide javax.el:el-api
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: tomcat
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ivan Afonichev
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-17 06:52 UTC by Michal Srb
Modified: 2016-04-08 16:48 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-04-08 16:48:25 UTC
Type: Bug


Attachments (Terms of Use)
proposed patch (1.64 KB, patch)
2015-02-17 06:53 UTC, Michal Srb
no flags Details | Diff

Description Michal Srb 2015-02-17 06:52:23 UTC
Description of problem:

tomcat currently provides, among others, mvn(javax.el:el-api). The problem is that the glassfish-el-api provides it as well. This causes other packages fail to build, if both tomcat and glassfish-el-api happen to be in the buildroot. I think that glassfish-el-api should be the one providing javax.el:el-api, as it is a reference implementation of EL.

Java packaging guidelines should be updated as well.

Version-Release number of selected component (if applicable):
tomcat-8.0.18-1.fc23

Comment 1 Michal Srb 2015-02-17 06:53:39 UTC
Created attachment 992495 [details]
proposed patch


Note You need to log in before you can comment on or make changes to this bug.