Bug 1193310 - Impossible to see / clear root password from hostgroup
Summary: Impossible to see / clear root password from hostgroup
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hosts
Version: 6.0.7
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Ohad Levy
QA Contact: Corey Welton
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-17 07:15 UTC by Fred van Zwieten
Modified: 2019-04-01 20:26 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:48:30 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC
Foreman Issue Tracker 2943 None None None 2016-04-22 15:08:46 UTC

Description Fred van Zwieten 2015-02-17 07:15:15 UTC
Description of problem:
It is not possible to either see if a hostgroup holds a root password or to clear a root password. I have come several times in a situation where people could not log in using the root password and then it is next to impossible to troubleshoot this problem because it is not clear nor known what host groups hold root passwords.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Set a root password on a hostgroup
2. Try to determine from the UI is a root password is set on the hostgroup
3. Try to clear the root password in the UI

Actual results:
Not possible to detect if a root password is present on a hostgroup
Not possible to clear a root password on a hostgroup

Expected results:
Possibility to detect if a root password is present on a hostgroup
Possibility to clear a root password on a hostgroup


Additional info:

Comment 1 RHEL Product and Program Management 2015-02-17 15:45:33 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Bryan Kearney 2015-02-17 17:28:28 UTC
Created redmine issue http://projects.theforeman.org/issues/9417 from this bug

Comment 4 Bryan Kearney 2015-02-18 12:58:51 UTC
Connecting redmine issue http://projects.theforeman.org/issues/2943 from this bug

Comment 5 Bryan Kearney 2015-08-25 18:33:59 UTC
Upstream bug component is Provisioning

Comment 6 Bryan Kearney 2015-08-26 19:20:02 UTC
Upstream bug component is Provisioning

Comment 7 Bryan Kearney 2015-09-22 13:10:53 UTC
Upstream bug component is Hosts

Comment 8 Bryan Kearney 2015-09-22 13:10:55 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/2943 has been closed
-------------
Amir Fefer
Applied in changeset commit:2348fc8ea209f5359f3df9350adeb197ca4842c8.

Comment 11 Tazim Kolhar 2016-04-04 13:47:10 UTC
VERIFIED:
# rpm -qa foreman
foreman-1.11.0.9-1.el7sat.noarch


Steps:
1. Set a root password on a hostgroup
2. Try to determine from the UI is a root password is set on the hostgroup
3. Try to clear the root password in the UI

There is field `Change the password` which allows to clear 
password in UI

Moving it to Verified

Comment 14 errata-xmlrpc 2016-07-27 08:48:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.