Bug 1193387 - Unable to enable nfs.service on boot
Summary: Unable to enable nfs.service on boot
Keywords:
Status: CLOSED DUPLICATE of bug 1159308
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: nfs-utils
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Steve Dickson
QA Contact: Yongcheng Yang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-17 09:55 UTC by Tytus Kurek
Modified: 2019-08-15 04:16 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-18 08:55:00 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Tytus Kurek 2015-02-17 09:55:55 UTC
Description of problem:

I am unable to enable nfs.service on boot using the "systemctl" tool.

Version-Release number of selected component (if applicable):

[root@scloudnfs01 ~]# rpm -qa | grep nfs
libnfsidmap-0.25-9.el7.x86_64
nfs-utils-1.3.0-0.el7.x86_64
[root@scloudnfs01 ~]# uname -a
Linux scloudnfs01.cam.ppc.pega.com 3.10.0-123.20.1.el7.x86_64 #1 SMP Wed Jan 21 09:45:55 EST 2015 x86_64 x86_64 x86_64 GNU/Linux
How reproducible:

Easily reproducible (100%)

Steps to Reproduce:
1. Install RHEL 7 64-bit
2. Install nfs-utils package
3. Attempt to enable nfs.service on boot

Actual results:

[root@scloudnfs01 ~]# systemctl enable nfs
Failed to issue method call: No such file or directory
[root@scloudnfs01 ~]# systemctl is-enabled nfs
disabled

Expected results:

[root@scloudnfs01 ~]# systemctl enable nfs
[root@scloudnfs01 ~]# systemctl is-enabled nfs
enabled

Additional info:

Can provide at any time.

Comment 2 Steve Dickson 2015-06-25 14:46:44 UTC
This problem is because of this bug in systemd
   https://bugzilla.redhat.com/show_bug.cgi?id=1159308

Waiting on movement on that.

Comment 3 Steve Dickson 2015-06-25 14:48:45 UTC
The workaround is to enable/disable nfs-server


Note You need to log in before you can comment on or make changes to this bug.