Bug 1193513 - Wrong memory detection in the discovery ramdisk
Summary: Wrong memory detection in the discovery ramdisk
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: instack-undercloud
Version: 6.0 (Juno)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ga
: Director
Assignee: James Slagle
QA Contact: Alexander Chuzhoy
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-17 13:55 UTC by Dmitry Tantsur
Modified: 2015-08-05 13:50 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-05 13:50:27 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description Dmitry Tantsur 2015-02-17 13:55:43 UTC
Description of problem:
Discovery ramdisk detects _possible_ amount of RAM, not actual one. It was fixed in Git master by commit https://github.com/rdo-management/instack-undercloud/commit/9327553ecbbb7cc20bf32dd940bb32d02edb5b94 and in DIB ramdisk by patch https://review.openstack.org/#/c/156173/.

How reproducible:
on bare metal machines with RAM != maximum RAM

Steps to Reproduce:
1. go through discovery on such a machine
2. Node.extra[memory_mb] in Ironic will be updated with wrong value

Comment 3 Dmitry Tantsur 2015-02-20 14:23:38 UTC
Fixed in stable/juno branch of instack-undercloud as commit https://github.com/rdo-management/instack-undercloud/commit/02853ff37851736d0aecdda3d30afe94db35b782

Comment 6 Alexander Chuzhoy 2015-06-18 14:58:04 UTC
Verified:

Environment:
openstack-ironic-common-2015.1.0-4.el7ost.noarch
openstack-ironic-discoverd-1.1.0-3.el7ost.noarch
python-ironic-discoverd-1.1.0-3.el7ost.noarch
python-ironicclient-0.5.1-5.el7ost.noarch
openstack-ironic-conductor-2015.1.0-4.el7ost.noarch
openstack-ironic-api-2015.1.0-4.el7ost.noarch
instack-undercloud-2.1.2-1.el7ost.noarch


The machine has 48GB of ram.
After the discovery, running "ironic node-show <id>":
{u'memory_mb': u'49152'

Comment 8 errata-xmlrpc 2015-08-05 13:50:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.