Bug 1193527 - eclipse unable to read repositories
Summary: eclipse unable to read repositories
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse
Version: 22
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Alexander Kurtakov
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-17 14:40 UTC by lejeczek
Modified: 2015-06-23 10:19 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-19 08:17:43 UTC


Attachments (Terms of Use)
log (579.73 KB, text/plain)
2015-02-17 14:40 UTC, lejeczek
no flags Details
new logs (232.63 KB, text/plain)
2015-06-22 12:31 UTC, lejeczek
no flags Details

Description lejeczek 2015-02-17 14:40:08 UTC
Created attachment 992726 [details]
log

Description of problem:


Version-Release number of selected component (if applicable):

eclipse-platform-4.4.1-17.fc22.x86_64
eclipse-emf-core-2.10.1-3.fc22.x86_64
eclipse-jdt-4.4.1-17.fc22.x86_64
eclipse-equinox-osgi-4.4.1-17.fc22.x86_64
eclipse-filesystem-1.0-3.fc22.x86_64
eclipse-swt-4.4.1-17.fc22.x86_64
eclipse-pde-4.4.1-17.fc22.x86_64
eclipse-ecf-core-3.9.2-1.fc22.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Alexander Kurtakov 2015-02-17 15:11:25 UTC
Would you please explain what you were trying to do and what broke for you in detail?

Comment 2 lejeczek 2015-02-17 15:30:57 UTC
eg. go to Help -> Update Software
and eclipe's log is attached.

Comment 3 Roland Grunberg 2015-02-17 16:32:28 UTC
This appears to be a problem in httpcomponents-httpclient. Specifically "default" is no longer considered a valid cookie spec as of 4.4 beta 1 :

http://tiemensfamily.com/TimOnCS/2014/09/30/amazon-sdk-broken-dependencies/
http://stackoverflow.com/questions/26187341/httpget-get-new-httpgeturl-giving-exceptions

Do any plugins shipped in Fedora make use of httpclient in such a way ? I noticed a lot of custom plugins within the log so perhaps these are making use of the API in that manner.

Comment 4 Roland Grunberg 2015-02-18 18:38:39 UTC
I'm able to reproduce this in a docker container of fedora:rawhide with fresh workspace, no .eclipse.

[me@d4db0bcf5d18 ~]$ eclipse -nosplash -debug -consolelog -application org.eclipse.equinox.p2.director -repository http://download.eclipse.org/releases/luna -l
Unable to init server: Could not connect: Connection refused
Eclipse: Cannot open display: 
Eclipse:
GTK+ Version Check
Start VM: /bin/java
-Xms128m
-Xmx1024m
-Dorg.eclipse.swt.browser.UseWebKitGTK=true
-Dhelp.lucene.tokenizer=standard
-XX:CompileCommand=exclude,org/eclipse/core/internal/dtree/DataTreeNode,forwardDeltaWith
-XX:CompileCommand=exclude,org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding,<init>
-XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates,instantiateTemplate
-XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage,addBinding
-XX:CompileCommand=exclude,org/python/pydev/editor/codecompletion/revisited/PythonPathHelper,isValidSourceFile
-XX:CompileCommand=exclude,org/eclipse/tycho/core/osgitools/EquinoxResolver,newState
-Dorg.eclipse.equinox.p2.reconciler.dropins.directory=/usr/share/eclipse/dropins
-Declipse.p2.skipMovedInstallDetection=true
-jar /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.3.0.v20150213-1103.jar
-os linux
-ws gtk
-arch x86_64
-launcher /usr/lib64/eclipse/eclipse
-name Eclipse
--launcher.library /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.200.v20150213-1103/eclipse_1608.so
-startup /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.3.0.v20150213-1103.jar
--launcher.appendVmargs
-exitdata 70001
-protect master
-debug
-consolelog
-application org.eclipse.equinox.p2.director
-repository http://download.eclipse.org/releases/luna
-l
-vm /bin/java
-vmargs
-Xms128m
-Xmx1024m
-Dorg.eclipse.swt.browser.UseWebKitGTK=true
-Dhelp.lucene.tokenizer=standard
-XX:CompileCommand=exclude,org/eclipse/core/internal/dtree/DataTreeNode,forwardDeltaWith
-XX:CompileCommand=exclude,org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding,<init>
-XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates,instantiateTemplate
-XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage,addBinding
-XX:CompileCommand=exclude,org/python/pydev/editor/codecompletion/revisited/PythonPathHelper,isValidSourceFile
-XX:CompileCommand=exclude,org/eclipse/tycho/core/osgitools/EquinoxResolver,newState
-Dorg.eclipse.equinox.p2.reconciler.dropins.directory=/usr/share/eclipse/dropins
-Declipse.p2.skipMovedInstallDetection=true
-jar /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.3.0.v20150213-1103.jar 
CompilerOracle: exclude org/eclipse/core/internal/dtree/DataTreeNode.forwardDeltaWith
CompilerOracle: exclude org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding.<init>
CompilerOracle: exclude org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates.instantiateTemplate
CompilerOracle: exclude org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage.addBinding
CompilerOracle: exclude org/python/pydev/editor/codecompletion/revisited/PythonPathHelper.isValidSourceFile
CompilerOracle: exclude org/eclipse/tycho/core/osgitools/EquinoxResolver.newState
Install location:
    file:/usr/lib64/eclipse/
Configuration file:
    file:/usr/lib64/eclipse/configuration/config.ini loaded
Configuration location:
    file:/home/me/.eclipse/org.eclipse.platform_793567567_linux_gtk_x86_64/configuration
Configuration file:
    file:/home/me/.eclipse/org.eclipse.platform_793567567_linux_gtk_x86_64/config.ini not found or not read
Loading timestamp file from:
	 file:/home/me/.eclipse/org.eclipse.platform_793567567_linux_gtk_x86_64/configuration   .baseConfigIniTimestamp
	No timestamp file found
Timestamps found: 
	 config.ini in the base: 1423826977000
	 remembered -1
Shared configuration location:
    file:/usr/lib64/eclipse/configuration/
Framework located:
    file:/usr/lib64/eclipse/plugins/org.eclipse.osgi_3.10.100.v20150213-1103.jar
Loading extension: reference:file:org.eclipse.osgi.compatibility.state_1.0.100.v20150213-1103.jar
	eclipse.properties not found
Framework classpath:
    file:/usr/lib64/eclipse/plugins/org.eclipse.osgi_3.10.100.v20150213-1103.jar
    file:/usr/lib64/eclipse/plugins/
    file:/usr/lib64/eclipse/plugins/org.eclipse.osgi.compatibility.state_1.0.100.v20150213-1103.jar
Debug options:
    file:/home/me/.options not found
Time to load bundles: 27
!SESSION 2015-02-18 18:36:08.861 -----------------------------------------------
eclipse.buildId=4.5.0.Z20150213-1102
java.version=1.8.0_40
java.vendor=Oracle Corporation
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
Framework arguments:  -application org.eclipse.equinox.p2.director -repository http://download.eclipse.org/releases/luna -l
Command-line arguments:  -os linux -ws gtk -arch x86_64 -debug -consolelog -application org.eclipse.equinox.p2.director -repository http://download.eclipse.org/releases/luna -l

!ENTRY org.eclipse.equinox.p2.publisher.eclipse 4 0 2015-02-18 18:36:10.304
!MESSAGE Unable to acquire PluginConverter service during generation for: /usr/lib64/eclipse/dropins/jdt.

!ENTRY org.eclipse.equinox.p2.publisher.eclipse 4 0 2015-02-18 18:36:10.485
!MESSAGE Unable to acquire PluginConverter service during generation for: /usr/lib64/eclipse/dropins/sdk.

!ENTRY org.eclipse.equinox.p2.publisher.eclipse 4 0 2015-02-18 18:36:10.881
!MESSAGE Unable to acquire PluginConverter service during generation for: /usr/lib64/eclipse/dropins/cvs.
Starting application: 3903

!ENTRY org.eclipse.equinox.p2.transport.ecf 4 1002 2015-02-18 18:36:14.273
!MESSAGE Unable to read repository at http://download.eclipse.org/releases/luna/artifacts.xml.
!STACK 0
java.lang.IllegalStateException: Unsupported cookie spec: default
	at org.apache.http.cookie.CookieSpecRegistry.getCookieSpec(CookieSpecRegistry.java:110)
	at org.apache.http.cookie.CookieSpecRegistry$1.create(CookieSpecRegistry.java:163)
	at org.apache.http.client.protocol.RequestAddCookies.process(RequestAddCookies.java:157)
	at org.apache.http.protocol.ImmutableHttpProcessor.process(ImmutableHttpProcessor.java:132)
	at org.apache.http.protocol.HttpRequestExecutor.preProcess(HttpRequestExecutor.java:166)
	at org.apache.http.impl.client.DefaultRequestDirector.execute(DefaultRequestDirector.java:485)
	at org.apache.http.impl.client.AbstractHttpClient.doExecute(AbstractHttpClient.java:879)
	at org.apache.http.impl.client.CloseableHttpClient.execute(CloseableHttpClient.java:84)
	at org.eclipse.ecf.provider.filetransfer.httpclient4.HttpClientFileSystemBrowser.runRequest(HttpClientFileSystemBrowser.java:259)
	at org.eclipse.ecf.provider.filetransfer.browse.AbstractFileSystemBrowser$DirectoryJob.run(AbstractFileSystemBrowser.java:69)
	at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)

!ENTRY org.eclipse.equinox.p2.transport.ecf 4 1002 2015-02-18 18:36:15.261
!MESSAGE Unable to read repository at http://download.eclipse.org/releases/luna/content.xml.
!STACK 0
java.lang.IllegalStateException: Unsupported cookie spec: default
	at org.apache.http.cookie.CookieSpecRegistry.getCookieSpec(CookieSpecRegistry.java:110)
	at org.apache.http.cookie.CookieSpecRegistry$1.create(CookieSpecRegistry.java:163)
	at org.apache.http.client.protocol.RequestAddCookies.process(RequestAddCookies.java:157)
	at org.apache.http.protocol.ImmutableHttpProcessor.process(ImmutableHttpProcessor.java:132)
	at org.apache.http.protocol.HttpRequestExecutor.preProcess(HttpRequestExecutor.java:166)
	at org.apache.http.impl.client.DefaultRequestDirector.execute(DefaultRequestDirector.java:485)
	at org.apache.http.impl.client.AbstractHttpClient.doExecute(AbstractHttpClient.java:879)
	at org.apache.http.impl.client.CloseableHttpClient.execute(CloseableHttpClient.java:84)
	at org.eclipse.ecf.provider.filetransfer.httpclient4.HttpClientFileSystemBrowser.runRequest(HttpClientFileSystemBrowser.java:259)
	at org.eclipse.ecf.provider.filetransfer.browse.AbstractFileSystemBrowser$DirectoryJob.run(AbstractFileSystemBrowser.java:69)
	at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
Installation failed.
Unable to load repositories.
Application failed, log file location: /home/me/.eclipse/org.eclipse.platform_793567567_linux_gtk_x86_64/configuration/1424284568916.log

!ENTRY org.eclipse.equinox.p2.core 4 0 2015-02-18 18:36:15.264
!MESSAGE Unable to load repositories.

Comment 5 Roland Grunberg 2015-02-18 20:36:33 UTC
This seems to be bug https://issues.apache.org/jira/browse/HTTPCLIENT-1556 ( https://github.com/apache/httpclient/commit/526a8c51fcfa0abcd5596e37600ac22796d00db2 ) which was reported against RC1 and fixed in RC2. Updating httpcomponents-client should resolve this (once a newer version gets built).

Comment 6 Mikolaj Izdebski 2015-02-18 20:45:16 UTC
I've just built httpcomponents-client for F22 and F23.

http://koji.fedoraproject.org/koji/taskinfo?taskID=8985527
http://koji.fedoraproject.org/koji/taskinfo?taskID=8985520

Comment 7 lejeczek 2015-02-19 08:03:34 UTC
these new builds for f22 do fix the problem. dzięki

Comment 8 Alexander Kurtakov 2015-02-19 08:17:43 UTC
Closing as per reporter comment as fixed.
Thanks for the investigation Roland and for the quick rebuild Mikolaj.

Comment 9 lejeczek 2015-06-22 12:30:36 UTC
and again, after some updates I installed today.

ome sites could not be found.  See the error log for more detail.
Error while reading from repository: http://download.walware.de/eclipse-4.4/site.xml.
Error while reading from repository: http://community.polarion.com/projects/subversive/download/eclipse/4.0/luna-site/site.xml.
Error while reading from repository: http://download.eclipse.org/releases/luna/site.xml.
Error while reading from repository: https://raw.github.com/guari/eclipse-ui-theme/master/com.github.eclipseuitheme.themes.updatesite/site.xml.
Error while reading from repository: http://directory.apache.org/studio/update/site.xml.
Error while reading from repository: http://download.eclipse.org/eclipse/updates/4.4/site.xml.
Error while reading from repository: http://eclipse.jeeeyul.net/update/site.xml.

Comment 10 lejeczek 2015-06-22 12:31:01 UTC
Created attachment 1041808 [details]
new logs

Comment 11 Roland Grunberg 2015-06-22 13:43:10 UTC
The error log shows a different error that the one initially reported, but the result is the same.

Looking around I found this : http://www.compiletimeerror.com/2015/03/java-error-exception-in-thread-main.html#.VYgPZLxziV4 , which basically points to using incompatible versions of httpcore/httpclient , or duplicate versions.

Can you confirm the version of httpcore/httpclient you have are the same (rpm -q httpcomponents-client httpcomponents-core), and no additional versions on your system ? I don't see any strange incompatible updates having been pushed for f22.

Comment 12 lejeczek 2015-06-22 14:08:38 UTC
httpcomponents-client-4.4-1.fc22.noarch
httpcomponents-core-4.4-1.fc22.noarch

among those updates today:

eclipse-egit-3.7.1-1.fc22.noarch
eclipse-jgit-3.7.1-2.fc22.noarch 

java-1.8.0-openjdk-1.8.0.45-40.b14.fc22.x86_64
java-1.8.0-openjdk-devel-1.8.0.45-40.b14.fc22.x86_64
java-1.8.0-openjdk-headless-1.8.0.45-40.b14.fc22.x86_64
jetty-continuation-9.2.9-2.fc22.noarch
jetty-http-9.2.9-2.fc22.noarch
jetty-io-9.2.9-2.fc22.noarch
jetty-jmx-9.2.9-2.fc22.noarch
jetty-security-9.2.9-2.fc22.noarch
jetty-server-9.2.9-2.fc22.noarch
jetty-servlet-9.2.9-2.fc22.noarch
jetty-util-9.2.9-2.fc22.noarch
jgit-3.7.1-2.fc22.noarch

some other bits but I did not think were relevant

Comment 13 Roland Grunberg 2015-06-22 16:25:35 UTC
I'm not really sure what could be causing this as I'm unable to reproduce this error on an up to date F22 VM. Have you tried launching Eclipse with the -clean flag from the commandline to see if it helps ? If not, could you try creating a '.options' file in your home folder with the following content :
org.eclipse.equinox.p2.core/debug=true
org.eclipse.equinox.p2.core/reconciler=true

Then launch Eclipse from the home folder as 'eclipse -clean -debug -consolelog 1>log.txt' and see if the problem still occurs. You can cancel the workspace prompt and just attach the contents of the log.txt file as they might have some hints.

Comment 14 lejeczek 2015-06-23 10:19:53 UTC
was weird, but makes me happy, -clean seemed has fixed it.
thanks.


Note You need to log in before you can comment on or make changes to this bug.