Bug 119362 - problem running up2date with lilo involved
problem running up2date with lilo involved
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: up2date (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks: up2date-rhel3-u2 up2date-rhel3-u3
  Show dependency treegraph
 
Reported: 2004-03-29 16:20 EST by Narsi Subramanian
Modified: 2015-03-03 17:38 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-25 17:12:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Narsi Subramanian 2004-03-29 16:20:04 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031027

Description of problem:
We are consistently seeing this error message when running up2date on
Linux v3 systems. We are using lilo: 
 
Installing /var/spool/up2date/oprofile-devel-0.5.4-13.i386.rpm... 
New Up2date available 
Traceback (most recent call last): 
  File "/usr/sbin/up2date", line 1165, in ? 
    # we're fine up to this point... 
  File "/usr/sbin/up2date", line 745, in main 
    else: 
  File "/usr/sbin/up2date", line 1028, in batchRun 
  File "up2dateBatch.py", line 82, in run 
  File "up2dateBatch.py", line 153, in __installPackages 
  File "up2date.py", line 613, in installPackages 
  File "up2date.py", line 662, in runPkgSpecialCases 
  File "up2date.py", line 753, in installBootLoader 
  File "up2date.py", line 768, in __install_lilo 
  File "lilocfg.py", line 376, in installNewImages 
up2date_client.lilocfg.LiloConfError: Error installing lilo.conf  The
message was: test install of lilo failed 

lilo.conf
prompt
timeout=50
default=linux
boot=/dev/cciss/c0d0
map=/boot/map
install=/boot/boot.b
message=/boot/message
linear
                                                                     
          
image=/boot/vmlinuz-2.4.21-9.EL
        label=2.4.21-9.EL
        initrd=/boot/initrd-2.4.21-9.EL.img
        read-only
        append="root=LABEL=/"
                                                                     
          
image=/boot/vmlinuz-2.4.21-9.ELsmp
        label=2.4.21-9.ELsmp
        initrd=/boot/initrd-2.4.21-9.ELsmp.img
        read-only
        append="root=LABEL=/"
                                                                     
          
image=/boot/vmlinuz-2.4.21-4.0.1.ELsmp
        label=2.4.21-4.0.1.E1
        initrd=/boot/initrd-2.4.21-4.0.1.ELsmp.img
        read-only
        append="root=LABEL=/"
                                                                     
          
image=/boot/vmlinuz-2.4.21-4.0.1.EL
        label=2.4.21-4.0.1.EL
        initrd=/boot/initrd-2.4.21-4.0.1.EL.img
        read-only
        append="root=LABEL=/"
                                                                     
          
image=/boot/vmlinuz-2.4.21-4.ELsmp
        label=linux
        initrd=/boot/initrd-2.4.21-4.ELsmp.img
        read-only
        append="root=LABEL=/"
                                                                     
          
image=/boot/vmlinuz-2.4.21-4.EL
        label=linux-up
        initrd=/boot/initrd-2.4.21-4.EL.img
        read-only
        append="root=LABEL=/"

[root@joy etc]# uname -a 
Linux joy 2.4.21-4.ELsmp #1 SMP Fri Oct 3 17:52:56 EDT 2003 i686 i686
i386 GNU/Linux 

Since the complain is about the config file we verfied that the
attached lilo did work (aka, are all these kernels actually installed)

It seems to me that they are all there. These are the kernels listed
in /etc/lilo.conf 
 
[root@joy etc]# grep vmlinuz lilo.conf 
image=/boot/vmlinuz-2.4.21-9.EL 
image=/boot/vmlinuz-2.4.21-9.ELsmp 
image=/boot/vmlinuz-2.4.21-4.0.1.ELsmp 
image=/boot/vmlinuz-2.4.21-4.0.1.EL 
image=/boot/vmlinuz-2.4.21-4.ELsmp 
image=/boot/vmlinuz-2.4.21-4.EL 
 
These are the kernels on my machine: 
 
[root@joy etc]# ls /boot/vmlinu* 
/boot/vmlinux-2.4.21-4.0.1.EL     /boot/vmlinux-2.4.21-9.EL         
/boot/vmlinuz-2.4.21-4.EL 
/boot/vmlinux-2.4.21-4.0.1.ELsmp  /boot/vmlinux-2.4.21-9.ELsmp      
/boot/vmlinuz-2.4.21-4.ELsmp 
/boot/vmlinux-2.4.21-4.EL         /boot/vmlinuz-2.4.21-4.0.1.EL     
/boot/vmlinuz-2.4.21-9.EL 
/boot/vmlinux-2.4.21-4.ELsmp      /boot/vmlinuz-2.4.21-4.0.1.ELsmp  
/boot/vmlinuz-2.4.21-9.ELsmp 



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. See above.
2.
3.
    

Additional info:
Comment 1 Adrian Likins 2004-04-07 12:26:49 EDT
whats the output of `/sbin/lilo -v -t` on
that box with its current lilo.conf?

Comment 2 Narsi Subramanian 2004-04-08 13:55:18 EDT
I tried "lilo -vt" and "lilo -vvt" as you suggested and both gave an
error.  Here is the output from "lilo -v" 
 
[root@gander root]# lilo -v 
LILO version 21.4-4, Copyright (C) 1992-1998 Werner Almesberger 
'lba32' extensions Copyright (C) 1999,2000 John Coffman 
 
Reading boot sector from /dev/sda 
Merging with /boot/boot.b 
Mapping message file /boot/message 
Boot image: /boot/vmlinuz-2.4.21-9.EL 
Mapping RAM disk /boot/initrd-2.4.21-9.EL.img 
Added 2.4.21-9.EL 
Boot image: /boot/vmlinuz-2.4.21-4.0.2.EL 
Mapping RAM disk /boot/initrd-2.4.21-4.0.2.EL.img 
Added 2.4.21-4.0.2.EL 
Boot image: /boot/vmlinuz-2.4.21-4.EL 
Mapping RAM disk /boot/initrd-2.4.21-4.EL.img 
Added linux * 
/boot/boot.0800 exists - no backup copy made. 
Writing boot sector. 


However, we cannot use grub on these Proliant boxes where we are using
lilo.  I think its the ethernet card, but I can't remember. It was
somebody at  RedHat support that told us a year ago we should switch
from grub to lilo and that would take care of our problems. And it did
take care of our problems. But that was with ES 2.1 not ES3. 
 
-- dean
Comment 3 Narsi Subramanian 2004-05-04 16:58:16 EDT
Is there any update on this issue?. 
Comment 4 Adrian Likins 2004-05-06 11:55:12 EDT
If its the problem I think it is, the version slated for U2 should
include a fix (problem with lilo labels getting too long)

try 4.2.14 
Comment 5 Adrian Likins 2004-08-25 17:12:21 EDT
rhel2.1-u5 and rhel3.0-u6 versions should include
fixes for all the lilo cases I've been able to reproduce

Note You need to log in before you can comment on or make changes to this bug.