Bug 1193658 - (JSON::ParserError) 203: unexpected token at 'NaN,"progress_weight":10}'
Summary: (JSON::ParserError) 203: unexpected token at 'NaN,"progress_weight":10}'
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Container Management
Version: Nightly
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: David Davis
QA Contact: Corey Welton
URL:
Whiteboard:
Depends On:
Blocks: 1190289
TreeView+ depends on / blocked
 
Reported: 2015-02-17 20:28 UTC by Og Maciel
Modified: 2019-09-25 20:50 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:13:23 UTC
Target Upstream Version:


Attachments (Terms of Use)
log from steps (28.15 KB, text/plain)
2015-02-17 20:28 UTC, Og Maciel
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC

Description Og Maciel 2015-02-17 20:28:56 UTC
Created attachment 992877 [details]
log from steps

Description of problem:

While testing deleting and editing a docker repository, I came across an error that shows up rather briefly in the task status panel of a repository while synchronizing:

(JSON::ParserError) 203: unexpected token at 'NaN,"progress_weight":10}'

This goes away and the sync process seems to eventually succeed.


Version-Release number of selected component (if applicable):

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.9.42-1.el6.noarch
* candlepin-common-1.0.21-1.el6.noarch
* candlepin-selinux-0.9.42-1.el6.noarch
* candlepin-tomcat6-0.9.42-1.el6.noarch
* elasticsearch-0.90.10-7.el6.noarch
* foreman-1.8.0-0.develop.201502121510git9edf91b.el6.noarch
* foreman-compute-1.8.0-0.develop.201502121510git9edf91b.el6.noarch
* foreman-debug-1.8.0-0.develop.201502121510git9edf91b.el6.noarch
* foreman-gce-1.8.0-0.develop.201502121510git9edf91b.el6.noarch
* foreman-libvirt-1.8.0-0.develop.201502121510git9edf91b.el6.noarch
* foreman-ovirt-1.8.0-0.develop.201502121510git9edf91b.el6.noarch
* foreman-postgresql-1.8.0-0.develop.201502121510git9edf91b.el6.noarch
* foreman-proxy-1.8.0-0.develop.201502121459git0207401.el6.noarch
* foreman-release-1.8.0-0.develop.201502121510git9edf91b.el6.noarch
* foreman-selinux-1.8.0-0.develop.201412151103gite2863e4.el6.noarch
* foreman-vmware-1.8.0-0.develop.201502121510git9edf91b.el6.noarch
* katello-2.2.0-1.201502171650git5cf9de7.el6.noarch
* katello-certs-tools-2.0.1-1.el6.noarch
* katello-common-2.2.0-1.201502171650git5cf9de7.el6.noarch
* katello-default-ca-1.0-1.noarch
* katello-installer-2.2.0-1.201502160627gite8ff373.el6.noarch
* katello-installer-base-2.2.0-1.201502160627gite8ff373.el6.noarch
* katello-repos-2.1.1-1.el6.noarch
* katello-server-ca-1.0-1.noarch
* openldap-2.4.39-8.el6.x86_64
* pulp-docker-plugins-0.2.2-1.el6.noarch
* pulp-katello-0.3-3.el6.noarch
* pulp-nodes-common-2.6.0-0.7.beta.el6.noarch
* pulp-nodes-parent-2.6.0-0.7.beta.el6.noarch
* pulp-puppet-plugins-2.6.0-0.7.beta.el6.noarch
* pulp-puppet-tools-2.6.0-0.7.beta.el6.noarch
* pulp-rpm-plugins-2.6.0-0.7.beta.el6.noarch
* pulp-selinux-2.6.0-0.7.beta.el6.noarch
* pulp-server-2.6.0-0.7.beta.el6.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.3.3-1.el6.noarch
* ruby193-rubygem-net-ldap-0.10.0-1.el6.noarch
* ruby193-rubygem-runcible-1.3.1-1.el6.noarch
* rubygem-hammer_cli-0.1.4-1.201502121207git0ab2866.el6.noarch
* rubygem-hammer_cli_foreman-0.1.4-1.201501221305git706b057.el6.noarch
* rubygem-hammer_cli_foreman_bootdisk-0.1.2-1.el6.noarch
* rubygem-hammer_cli_foreman_tasks-0.0.3-2.201409091410gitc96619d.git.0.37f3704.el6.noarch
* rubygem-hammer_cli_gutterball-0.0.1-1.201501072024git01fe139.git.0.06e884f.el6.noarch
* rubygem-hammer_cli_import-0.10.4-1.el6.noarch
* rubygem-hammer_cli_katello-0.0.7-1.201502061831git68a34d6.git.0.9c4412d.el6.noarch
* sssd-ldap-1.11.6-30.el6.x86_64

How reproducible:


Steps to Reproduce:
1. Create a custom product
2. Create a custom docker-based repo for fedora/ssh and delete it
3. Repeat the same create/delete step 2-4 more times in a sequence
4. Create a custom docker-based repo for fedora/ssh and this time edit it to change the Upstream name to ubuntu and sync it from the repos page

Actual results:

You should see very briefly the error mentioned in the subject of this issue, which will go away and the sync should proceed to completion.

Expected results:


Additional info:

Comment 2 Mike McCune 2015-02-19 05:42:07 UTC
I saw this as well, definitely happens ..

Comment 3 David Davis 2016-03-04 14:42:50 UTC
I tested this out against 6.2 and did not see the error from comment0. It looks like it's since been fixed perhaps.

Comment 6 Tazim Kolhar 2016-04-04 08:32:25 UTC
VERIFIED:
# rpm -q foreman
foreman-1.11.0.9-1.el7sat.noarch


Steps:
1. Create a custom product
2. Create a custom docker-based repo for fedora/ssh and delete it
3. Repeat the same create/delete step 2-4 more times in a sequence
4. Create a custom docker-based repo for fedora/ssh and this time edit it to change the Upstream name to ubuntu and sync it from the repos page
https://registry-1.docker.io/

Task Succeeded
https://cisco-b200m1-03.rhts.eng.bos.redhat.com/products/2/tasks/6d29d8e5-c0bb-45f8-b50d-091d41ec9c51

Some log contents:

2016-04-04 04:29:33 [app] [I] Completed 200 OK in 93ms (Views: 74.6ms | ActiveRecord: 10.5ms)
2016-04-04 04:29:33 [app] [D] With body:   {"content_type":"docker","docker_upstream_name":"ubuntu","mirror_on_sync":true,"unprotected":true,"full_path":"cisco-b200m1-03.rhts.eng.bos.redhat.com:5000/default_organization-test_prod-docker_repo","checksum_type":null,"container_repository_name":"default_organization-test_prod-docker_repo","download_policy":null,"url":"https://registry-1.docker.io/","relative_path":"default_organization-test_prod-docker_repo","major":null,"minor":null,"gpg_key_id":null,"content_id":"1459757709970","content_view_version_id":1,"library_instance_id":null,"product_type":"custom","promoted":false,"ostree_branches":[],"organization":{"name":"Default Organization","label":"Default_Organization","id":1},"created_at":"2016-04-04 13:45:09 +0530","updated_at":"2016-04-04 13:45:10 +0530","id":2,"name":"docker_repo","label":"docker_repo","product":{"id":2,"cp_id":"1459757679149","name":"test_prod","sync_plan":["name","description","sync_date","interval","next_sync"]},"last_sync":{"id":"d446e32a-c47b-45af-adda-ec7eb67c3f10","username":"admin","started_at":"2016-04-04 13:45:45 +0530","ended_at":"2016-04-04 13:59:13 +0530","state":"stopped","result":"success","progress":1.0},"content_counts":{"ostree_branch":0,"docker_manifest":113,"docker_tag":113,"rpm":0,"package":0,"package_group":0,"erratum":0,"puppet_module":0},"last_sync_words":"less than a minute","gpg_key":null,"environment":{"id":1},"permissions":{"deletable":true}}


Marking it as Verified

Comment 9 errata-xmlrpc 2016-07-27 09:13:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.