Bug 119366 - Syslog is not able to log to remote server under SELinux.
Syslog is not able to log to remote server under SELinux.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: policy (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
triage|leonardjo|closed|rawhide
:
Depends On:
Blocks: 122683
  Show dependency treegraph
 
Reported: 2004-03-29 16:55 EST by Konstantin Ryabitsev
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.11.3-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-10 13:45:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Konstantin Ryabitsev 2004-03-29 16:55:02 EST
Description of problem:
SELinux enforcement disables remote server logging for syslog,
creating the following entries in messages:

Mar 29 13:25:56 hagrid kernel: audit(1080584756.667:0): avc:  denied 
{ name_bind } for  pid=3162 exe=/sbin/syslogd src=832
scontext=root:system_r:syslogd_t tcontext=system_u:object_r:port_t
tclass=udp_socket

It looks like the default policy should allow this, as remote logging
is used quite often.

Version-Release number of selected component (if applicable):
sysklogd-1.4.1-14
Comment 1 Konstantin Ryabitsev 2004-03-30 15:36:18 EST
Adding the following to
/etc/security/selinux/src/policy/domains/program/syslogd.te fixes the
issue and allows both sending logs to remote server and accepting
remote logs.

# Allow name_bind for remote logging
allow syslogd_t port_t:{ tcp_socket udp_socket } name_bind;

tcp_socket can be used by syslog_ng, afair.
Comment 2 Daniel Walsh 2004-05-06 13:50:15 EDT
Fixed in policy-1.11.3-2.src.rpm

Note You need to log in before you can comment on or make changes to this bug.