Bug 1193674 - raised unexpected: IOError('NOT FOUND',) when synchronizing non-existing docker image
Summary: raised unexpected: IOError('NOT FOUND',) when synchronizing non-existing dock...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Pulp
Version: 6.0.0
Hardware: Unspecified
OS: Unspecified
medium
high vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Lukas Pramuk
URL:
Whiteboard:
Depends On:
Blocks: sat6-pulp-blocker 1193663
TreeView+ depends on / blocked
 
Reported: 2015-02-17 21:05 UTC by David Davis
Modified: 2019-09-26 14:46 UTC (History)
12 users (show)

Fixed In Version: pulp-2.8.7.1-1 pulp-docker-2.0.3-1 pulp-rpm-2.8.7.2-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-26 12:25:15 UTC
Target Upstream Version:


Attachments (Terms of Use)
Log in txt format (8.48 KB, text/plain)
2015-02-17 21:07 UTC, David Davis
no flags Details


Links
System ID Priority Status Summary Last Updated
Pulp Redmine 702 Normal CLOSED - CURRENTRELEASE raised unexpected: IOError('NOT FOUND',) when synchronizing non-existing docker image 2016-05-27 17:31:24 UTC
Pulp Redmine 1831 High CLOSED - CURRENTRELEASE sync of non-existing repo does not report an error 2016-06-27 17:01:26 UTC
Red Hat Product Errata RHBA-2016:2108 normal SHIPPED_LIVE Satellite 6.2.3 Async Bug Release 2016-10-26 16:21:52 UTC

Description David Davis 2015-02-17 21:05:26 UTC
Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1193663.

Description of problem:

Synchronizing a Docker-based repository for a non-existing image generates a scary looking stacktrace in the backend. I feel that the stacktrace could be handled a bit better and that maybe we should handle this a bit differently and in a way that it is more useful to the end user?


Version-Release number of selected component (if applicable):

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.9.42-1.el6.noarch
* candlepin-common-1.0.21-1.el6.noarch
* candlepin-selinux-0.9.42-1.el6.noarch
* candlepin-tomcat6-0.9.42-1.el6.noarch
* elasticsearch-0.90.10-7.el6.noarch
* foreman-1.8.0-0.develop.201502121510git9edf91b.el6.noarch
* foreman-compute-1.8.0-0.develop.201502121510git9edf91b.el6.noarch
* foreman-debug-1.8.0-0.develop.201502121510git9edf91b.el6.noarch
* foreman-gce-1.8.0-0.develop.201502121510git9edf91b.el6.noarch
* foreman-libvirt-1.8.0-0.develop.201502121510git9edf91b.el6.noarch
* foreman-ovirt-1.8.0-0.develop.201502121510git9edf91b.el6.noarch
* foreman-postgresql-1.8.0-0.develop.201502121510git9edf91b.el6.noarch
* foreman-proxy-1.8.0-0.develop.201502121459git0207401.el6.noarch
* foreman-release-1.8.0-0.develop.201502121510git9edf91b.el6.noarch
* foreman-selinux-1.8.0-0.develop.201412151103gite2863e4.el6.noarch
* foreman-vmware-1.8.0-0.develop.201502121510git9edf91b.el6.noarch
* katello-2.2.0-1.201502171650git5cf9de7.el6.noarch
* katello-certs-tools-2.0.1-1.el6.noarch
* katello-common-2.2.0-1.201502171650git5cf9de7.el6.noarch
* katello-default-ca-1.0-1.noarch
* katello-installer-2.2.0-1.201502160627gite8ff373.el6.noarch
* katello-installer-base-2.2.0-1.201502160627gite8ff373.el6.noarch
* katello-repos-2.1.1-1.el6.noarch
* katello-server-ca-1.0-1.noarch
* openldap-2.4.39-8.el6.x86_64
* pulp-docker-plugins-0.2.2-1.el6.noarch
* pulp-katello-0.3-3.el6.noarch
* pulp-nodes-common-2.6.0-0.7.beta.el6.noarch
* pulp-nodes-parent-2.6.0-0.7.beta.el6.noarch
* pulp-puppet-plugins-2.6.0-0.7.beta.el6.noarch
* pulp-puppet-tools-2.6.0-0.7.beta.el6.noarch
* pulp-rpm-plugins-2.6.0-0.7.beta.el6.noarch
* pulp-selinux-2.6.0-0.7.beta.el6.noarch
* pulp-server-2.6.0-0.7.beta.el6.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.3.3-1.el6.noarch
* ruby193-rubygem-net-ldap-0.10.0-1.el6.noarch
* ruby193-rubygem-runcible-1.3.1-1.el6.noarch
* rubygem-hammer_cli-0.1.4-1.201502121207git0ab2866.el6.noarch
* rubygem-hammer_cli_foreman-0.1.4-1.201501221305git706b057.el6.noarch
* rubygem-hammer_cli_foreman_bootdisk-0.1.2-1.el6.noarch
* rubygem-hammer_cli_foreman_tasks-0.0.3-2.201409091410gitc96619d.git.0.37f3704.el6.noarch
* rubygem-hammer_cli_gutterball-0.0.1-1.201501072024git01fe139.git.0.06e884f.el6.noarch
* rubygem-hammer_cli_import-0.10.4-1.el6.noarch
* rubygem-hammer_cli_katello-0.0.7-1.201502061831git68a34d6.git.0.9c4412d.el6.noarch
* sssd-ldap-1.11.6-30.el6.x86_64


How reproducible:


Steps to Reproduce:
2. Create a custom docker-based repository for mongodb (the upstream name should be mongodb and you should point to https://registry.hub.docker.com)
3. Sync it

Actual results:

Stacktrace shows up in /var/log/messages

Expected results:


Additional info:

Comment 1 David Davis 2015-02-17 21:05:51 UTC
Relevant part of the log:

Feb 17 15:24:48 cloud-qe-18 pulp: pulp.server.managers.repo.sync:ERROR: (13829-86432) Exception caught from plugin during sync for repo [default_organization-foo-foo]
Feb 17 15:24:48 cloud-qe-18 pulp: pulp.server.managers.repo.sync:ERROR: (13829-86432) Traceback (most recent call last):
Feb 17 15:24:48 cloud-qe-18 pulp: pulp.server.managers.repo.sync:ERROR: (13829-86432)   File "/usr/lib/python2.6/site-packages/pulp/server/managers/repo/sync.py", line 164, in _do_sync
Feb 17 15:24:48 cloud-qe-18 pulp: pulp.server.managers.repo.sync:ERROR: (13829-86432)     sync_report = sync_repo(transfer_repo, conduit, call_config)
Feb 17 15:24:48 cloud-qe-18 pulp: pulp.server.managers.repo.sync:ERROR: (13829-86432)   File "/usr/lib/python2.6/site-packages/pulp/server/async/tasks.py", line 483, in wrap_f
Feb 17 15:24:48 cloud-qe-18 pulp: pulp.server.managers.repo.sync:ERROR: (13829-86432)     return f(*args, **kwargs)
Feb 17 15:24:48 cloud-qe-18 pulp: pulp.server.managers.repo.sync:ERROR: (13829-86432)   File "/usr/lib/python2.6/site-packages/pulp_docker/plugins/importers/importer.py", line 85, in sync_repo
Feb 17 15:24:48 cloud-qe-18 pulp: pulp.server.managers.repo.sync:ERROR: (13829-86432)     return self.sync_step.sync()
Feb 17 15:24:48 cloud-qe-18 pulp: pulp.server.managers.repo.sync:ERROR: (13829-86432)   File "/usr/lib/python2.6/site-packages/pulp_docker/plugins/importers/sync.py", line 99, in sync
Feb 17 15:24:48 cloud-qe-18 pulp: pulp.server.managers.repo.sync:ERROR: (13829-86432)     self.process_lifecycle()
Feb 17 15:24:48 cloud-qe-18 pulp: pulp.server.managers.repo.sync:ERROR: (13829-86432)   File "/usr/lib/python2.6/site-packages/pulp/plugins/util/publish_step.py", line 503, in process_lifecycle
Feb 17 15:24:48 cloud-qe-18 pulp: pulp.server.managers.repo.sync:ERROR: (13829-86432)     super(PluginStep, self).process_lifecycle()
Feb 17 15:24:48 cloud-qe-18 pulp: pulp.server.managers.repo.sync:ERROR: (13829-86432)   File "/usr/lib/python2.6/site-packages/pulp/plugins/util/publish_step.py", line 127, in process_lifecycle
Feb 17 15:24:48 cloud-qe-18 pulp: pulp.server.managers.repo.sync:ERROR: (13829-86432)     step.process()
Feb 17 15:24:48 cloud-qe-18 pulp: pulp.server.managers.repo.sync:ERROR: (13829-86432)   File "/usr/lib/python2.6/site-packages/pulp/plugins/util/publish_step.py", line 204, in process
Feb 17 15:24:48 cloud-qe-18 pulp: pulp.server.managers.repo.sync:ERROR: (13829-86432)     self._process_block()
Feb 17 15:24:48 cloud-qe-18 pulp: pulp.server.managers.repo.sync:ERROR: (13829-86432)   File "/usr/lib/python2.6/site-packages/pulp/plugins/util/publish_step.py", line 246, in _process_block
Feb 17 15:24:48 cloud-qe-18 pulp: pulp.server.managers.repo.sync:ERROR: (13829-86432)     self.process_main()
Feb 17 15:24:48 cloud-qe-18 pulp: pulp.server.managers.repo.sync:ERROR: (13829-86432)   File "/usr/lib/python2.6/site-packages/pulp_docker/plugins/importers/sync.py", line 132, in process_main
Feb 17 15:24:48 cloud-qe-18 pulp: pulp.server.managers.repo.sync:ERROR: (13829-86432)     available_images = self.parent.index_repository.get_image_ids()
Feb 17 15:24:48 cloud-qe-18 pulp: pulp.server.managers.repo.sync:ERROR: (13829-86432)   File "/usr/lib/python2.6/site-packages/pulp_docker/plugins/registry.py", line 100, in get_image_ids
Feb 17 15:24:48 cloud-qe-18 pulp: pulp.server.managers.repo.sync:ERROR: (13829-86432)     raw_data = self._get_single_path(path)
Feb 17 15:24:48 cloud-qe-18 pulp: pulp.server.managers.repo.sync:ERROR: (13829-86432)   File "/usr/lib/python2.6/site-packages/pulp_docker/plugins/registry.py", line 67, in _get_single_path
Feb 17 15:24:48 cloud-qe-18 pulp: pulp.server.managers.repo.sync:ERROR: (13829-86432)     raise IOError(report.error_msg)
Feb 17 15:24:48 cloud-qe-18 pulp: pulp.server.managers.repo.sync:ERROR: (13829-86432) IOError: NOT FOUND
Feb 17 15:24:48 cloud-qe-18 pulp: celery.worker.job:ERROR: (13786-86432) Task pulp.server.managers.repo.sync.sync[7ef0bfb2-ad43-42d5-959e-9278934f59b4] raised unexpected: IOError('NOT FOUND',)
Feb 17 15:24:48 cloud-qe-18 pulp: celery.worker.job:ERROR: (13786-86432) Traceback (most recent call last):
Feb 17 15:24:48 cloud-qe-18 pulp: celery.worker.job:ERROR: (13786-86432)   File "/usr/lib/python2.6/site-packages/celery/app/trace.py", line 240, in trace_task
Feb 17 15:24:48 cloud-qe-18 pulp: celery.worker.job:ERROR: (13786-86432)     R = retval = fun(*args, **kwargs)
Feb 17 15:24:48 cloud-qe-18 pulp: celery.worker.job:ERROR: (13786-86432)   File "/usr/lib/python2.6/site-packages/pulp/server/async/tasks.py", line 328, in __call__
Feb 17 15:24:48 cloud-qe-18 pulp: celery.worker.job:ERROR: (13786-86432)     return super(Task, self).__call__(*args, **kwargs)
Feb 17 15:24:48 cloud-qe-18 pulp: celery.worker.job:ERROR: (13786-86432)   File "/usr/lib/python2.6/site-packages/celery/app/trace.py", line 437, in __protected_call__
Feb 17 15:24:48 cloud-qe-18 pulp: celery.worker.job:ERROR: (13786-86432)     return self.run(*args, **kwargs)
Feb 17 15:24:48 cloud-qe-18 pulp: celery.worker.job:ERROR: (13786-86432)   File "/usr/lib/python2.6/site-packages/pulp/server/managers/repo/sync.py", line 110, in sync
Feb 17 15:24:48 cloud-qe-18 pulp: celery.worker.job:ERROR: (13786-86432)     call_config)
Feb 17 15:24:48 cloud-qe-18 pulp: celery.worker.job:ERROR: (13786-86432)   File "/usr/lib/python2.6/site-packages/pulp/server/managers/repo/sync.py", line 164, in _do_sync
Feb 17 15:24:48 cloud-qe-18 pulp: celery.worker.job:ERROR: (13786-86432)     sync_report = sync_repo(transfer_repo, conduit, call_config)
Feb 17 15:24:48 cloud-qe-18 pulp: celery.worker.job:ERROR: (13786-86432)   File "/usr/lib/python2.6/site-packages/pulp/server/async/tasks.py", line 483, in wrap_f
Feb 17 15:24:48 cloud-qe-18 pulp: celery.worker.job:ERROR: (13786-86432)     return f(*args, **kwargs)
Feb 17 15:24:48 cloud-qe-18 pulp: celery.worker.job:ERROR: (13786-86432)   File "/usr/lib/python2.6/site-packages/pulp_docker/plugins/importers/importer.py", line 85, in sync_repo
Feb 17 15:24:48 cloud-qe-18 pulp: celery.worker.job:ERROR: (13786-86432)     return self.sync_step.sync()
Feb 17 15:24:48 cloud-qe-18 pulp: celery.worker.job:ERROR: (13786-86432)   File "/usr/lib/python2.6/site-packages/pulp_docker/plugins/importers/sync.py", line 99, in sync
Feb 17 15:24:48 cloud-qe-18 pulp: celery.worker.job:ERROR: (13786-86432)     self.process_lifecycle()
Feb 17 15:24:48 cloud-qe-18 pulp: celery.worker.job:ERROR: (13786-86432)   File "/usr/lib/python2.6/site-packages/pulp/plugins/util/publish_step.py", line 503, in process_lifecycle
Feb 17 15:24:48 cloud-qe-18 pulp: celery.worker.job:ERROR: (13786-86432)     super(PluginStep, self).process_lifecycle()
Feb 17 15:24:48 cloud-qe-18 pulp: celery.worker.job:ERROR: (13786-86432)   File "/usr/lib/python2.6/site-packages/pulp/plugins/util/publish_step.py", line 127, in process_lifecycle
Feb 17 15:24:48 cloud-qe-18 pulp: celery.worker.job:ERROR: (13786-86432)     step.process()
Feb 17 15:24:48 cloud-qe-18 pulp: celery.worker.job:ERROR: (13786-86432)   File "/usr/lib/python2.6/site-packages/pulp/plugins/util/publish_step.py", line 204, in process
Feb 17 15:24:48 cloud-qe-18 pulp: celery.worker.job:ERROR: (13786-86432)     self._process_block()
Feb 17 15:24:48 cloud-qe-18 pulp: celery.worker.job:ERROR: (13786-86432)   File "/usr/lib/python2.6/site-packages/pulp/plugins/util/publish_step.py", line 246, in _process_block
Feb 17 15:24:48 cloud-qe-18 pulp: celery.worker.job:ERROR: (13786-86432)     self.process_main()
Feb 17 15:24:48 cloud-qe-18 pulp: celery.worker.job:ERROR: (13786-86432)   File "/usr/lib/python2.6/site-packages/pulp_docker/plugins/importers/sync.py", line 132, in process_main
Feb 17 15:24:48 cloud-qe-18 pulp: celery.worker.job:ERROR: (13786-86432)     available_images = self.parent.index_repository.get_image_ids()
Feb 17 15:24:48 cloud-qe-18 pulp: celery.worker.job:ERROR: (13786-86432)   File "/usr/lib/python2.6/site-packages/pulp_docker/plugins/registry.py", line 100, in get_image_ids
Feb 17 15:24:48 cloud-qe-18 pulp: celery.worker.job:ERROR: (13786-86432)     raw_data = self._get_single_path(path)
Feb 17 15:24:48 cloud-qe-18 pulp: celery.worker.job:ERROR: (13786-86432)   File "/usr/lib/python2.6/site-packages/pulp_docker/plugins/registry.py", line 67, in _get_single_path
Feb 17 15:24:48 cloud-qe-18 pulp: celery.worker.job:ERROR: (13786-86432)     raise IOError(report.error_msg)
Feb 17 15:24:48 cloud-qe-18 pulp: celery.worker.job:ERROR: (13786-86432) IOError: NOT FOUND
Feb 17 15:24:48 cloud-qe-18 pulp: celery.worker.job:INFO: Task pulp.server.async.tasks._release_resource[9f4560e1-5207-488b-9826-e2599480f2a8] succeeded in 0.00897213400003s: None

Comment 2 David Davis 2015-02-17 21:07:02 UTC
Created attachment 992893 [details]
Log in txt format

Here's the log in txt format as well which may be easier to read.

Comment 3 Brian Bouterse 2015-02-28 23:24:26 UTC
Moved to https://pulp.plan.io/issues/702

Comment 4 RHEL Program Management 2015-03-03 20:19:25 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 6 pulp-infra@redhat.com 2015-03-30 21:30:24 UTC
The Pulp upstream bug status is at ASSIGNED. Updating the external tracker on this bug.

Comment 7 pulp-infra@redhat.com 2015-04-08 17:00:21 UTC
The Pulp upstream bug status is at POST. Updating the external tracker on this bug.

Comment 8 pulp-infra@redhat.com 2015-04-22 14:30:26 UTC
The Pulp upstream bug status is at MODIFIED. Updating the external tracker on this bug.

Comment 10 pulp-infra@redhat.com 2016-02-11 20:30:56 UTC
The Pulp upstream bug status is at ON_QA. Updating the external tracker on this bug.

Comment 13 Tazim Kolhar 2016-04-07 07:13:18 UTC
FAILEDQA:
# rpm -qa foreman
foreman-1.11.0.9-1.el7sat.noarch


Steps:
2. Create a custom docker-based repository for mongodb (the upstream name should be mongodb and you should point to https://registry.hub.docker.com)
3. Sync it

/var/log/messages

Apr  7 02:55:03 hp-nehalem-02 pulp: requests.packages.urllib3.connectionpool:INFO: Starting new HTTPS connection (1): registry.hub.docker.com
Apr  7 02:55:03 hp-nehalem-02 pulp: requests.packages.urllib3.connectionpool:INFO: Starting new HTTPS connection (1): auth.docker.io
Apr  7 02:55:04 hp-nehalem-02 pulp: requests.packages.urllib3.connectionpool:INFO: Starting new HTTPS connection (2): registry.hub.docker.com
Apr  7 02:55:04 hp-nehalem-02 pulp: pulp_docker.plugins.importers.sync:INFO: Could not get tags through v2 API
Apr  7 02:55:04 hp-nehalem-02 pulp: pulp.server.event.http:INFO: (61519-73312) {"call_report": {"exception": null, "task_type": "pulp.server.managers.repo.sync.sync", "_href": "/pulp/api/v2/tasks/3190e120-536d-4150-8f13-33c397314006/", "task_id": "3190e120-536d-4150-8f13-33c397314006", "tags": ["pulp:repository:default_organization-docker_product-docker_repo", "pulp:action:sync"], "finish_time": null, "_ns": "task_status", "start_time": "2016-04-07T06:55:03Z", "traceback": null, "spawned_tasks": [], "progress_report": {"docker_importer": [{"num_success": 1, "description": "Downloading manifests", "step_type": "sync_step_metadata", "items_total": 1, "state": "FINISHED", "error_details": [], "details": "", "num_failures": 0, "step_id": "62dd0d2b-0757-4358-bbe7-07dbc0326304", "num_processed": 1}, {"num_success": 1, "description": "Copying units already in pulp", "step_type": "get_local", "items_total": 1, "state": "FINISHED", "error_details": [], "details": "", "num_failures": 0, "step_id": "618e4b5f-5ef4-4155-9852-25ead25be3a6", "num_processed": 1}, {"num_success": 1, "description": "Copying units already in pulp", "step_type": "get_local", "items_total": 1, "state": "FINISHED", "error_details": [], "details": "", "num_failures": 0, "step_id": "a89b69b4-fb7c-46bf-a2d1-ff60c8581b44", "num_processed": 1}, {"num_success": 0, "description": "Downloading remote files", "step_type": "sync_step_download", "items_total": 0, "state": "FINISHED", "error_details": [], "details": "", "num_failures": 0, "step_id": "6de86a2d-fb24-42a2-b840-6636d645debd", "num_processed": 0}, {"num_success": 0, "description": "Saving Manifests and Blobs", "step_type": "sync_step_save", "items_total": 1, "state": "FINISHED", "error_details": [], "details": "", "num_failures": 0, "step_id": "d7b95715-5f9a-44a8-b430-b53e32915fd1", "num_processed": 0}, {"num_success": 1, "description": "Saving Tags", "step_type": "sync_step_save", "items_total": 0, "state": "FINISHED", "error_details": [], "details": "", "num_failures": 0, "step_id": "f34aa548-6c4c-49dd-b842-dff192fa116a",
Apr  7 02:55:04 hp-nehalem-02 pulp: pulp.server.event.http:INFO: (61519-73312)  "num_processed": 1}]}, "state": "running", "worker_name": "reserved_resource_worker-5@hp-nehalem-02.rhts.eng.bos.redhat.com", "result": null, "error": null, "_id": {"$oid": "5706044764476fa7196ed08c"}, "id": "5706044764476fa7196ed08c"}, "event_type": "repo.sync.finish", "payload": {"importer_id": "docker_importer", "exception": null, "repo_id": "default_organization-docker_product-docker_repo", "traceback": null, "started": "2016-04-07T06:55:03Z", "_ns": "repo_sync_results", "completed": "2016-04-07T06:55:04Z", "importer_type_id": "docker_importer", "error_message": null, "summary": {"sync_step_metadata": "FINISHED", "sync_step_save": "FINISHED", "get_local": "FINISHED", "sync_step_download": "FINISHED"}, "added_count": 0, "result": "success", "updated_count": 0, "details": [{"num_processed": 1, "items_total": 1, "state": "FINISHED", "num_success": 1, "error_details": [], "description": "Downloading manifests", "num_failures": 0, "step_id": "62dd0d2b-0757-4358-bbe7-07dbc0326304", "step_type": "sync_step_metadata", "details": ""}, {"num_processed": 1, "items_total": 1, "state": "FINISHED", "num_success": 1, "error_details": [], "description": "Copying units already in pulp", "num_failures": 0, "step_id": "618e4b5f-5ef4-4155-9852-25ead25be3a6", "step_type": "get_local", "details": ""}, {"num_processed": 1, "items_total": 1, "state": "FINISHED", "num_success": 1, "error_details": [], "description": "Copying units already in pulp", "num_failures": 0, "step_id": "a89b69b4-fb7c-46bf-a2d1-ff60c8581b44", "step_type": "get_local", "details": ""}, {"num_processed": 0, "items_total": 0, "state": "FINISHED", "num_success": 0, "error_details": [], "description": "Downloading remote files", "num_failures": 0, "step_id": "6de86a2d-fb24-42a2-b840-6636d645debd", "step_type": "sync_step_download", "details": ""}, {"num_processed": 0, "items_total": 1, "state": "FINISHED", "num_success": 0, "error_details": [], "description": "Saving Manifests and Blobs", "num_failures": 0, "
Apr  7 02:55:04 hp-nehalem-02 pulp: pulp.server.event.http:INFO: (61519-73312) step_id": "d7b95715-5f9a-44a8-b430-b53e32915fd1", "step_type": "sync_step_save", "details": ""}, {"num_processed": 1, "items_total": 0, "state": "FINISHED", "num_success": 1, "error_details": [], "description": "Saving Tags", "num_failures": 0, "step_id": "f34aa548-6c4c-49dd-b842-dff192fa116a", "step_type": "sync_step_save", "details": ""}], "id": "57060448846db1f04fd849d6", "removed_count": 0}}
Apr  7 02:55:04 hp-nehalem-02 pulp: requests.packages.urllib3.connectionpool:INFO: Starting new HTTPS connection (1): hp-nehalem-02.rhts.eng.bos.redhat.com
Apr  7 02:55:04 hp-nehalem-02 pulp: celery.worker.strategy:INFO: Received task: pulp.server.async.tasks._queue_reserved_task[1b0db241-2659-4d9e-b2ec-86fa3124893c]
Apr  7 02:55:04 hp-nehalem-02 pulp: celery.worker.job:INFO: Task pulp.server.managers.repo.sync.sync[3190e120-536d-4150-8f13-33c397314006] succeeded in 1.55053360801s: <pulp.server.async.tasks.TaskResult object at 0x43fd4d0>
Apr  7 02:55:04 hp-nehalem-02 pulp: celery.worker.job:INFO: Task pulp.server.async.tasks._release_resource[a3839be7-3f4a-404d-aa53-d1ebaa103922] succeeded in 0.0124474469922s: None
Apr  7 02:55:04 hp-nehalem-02 pulp: celery.worker.strategy:INFO: Received task: pulp.server.managers.repo.publish.publish[fe347151-16c4-49ca-9e5a-b059f0aa792b]
Apr  7 02:55:04 hp-nehalem-02 pulp: celery.worker.job:INFO: Task pulp.server.async.tasks._queue_reserved_task[1b0db241-2659-4d9e-b2ec-86fa3124893c] succeeded in 0.0347234979854s: None
Apr  7 02:55:04 hp-nehalem-02 pulp: celery.worker.strategy:INFO: Received task: pulp.server.async.tasks._release_resource[cfb0a800-3343-4115-b2ed-4ebd5f5580c7]
Apr  7 02:55:04 hp-nehalem-02 pulp: celery.worker.job:INFO: Task pulp.server.managers.repo.publish.publish[fe347151-16c4-49ca-9e5a-b059f0aa792b] succeeded in 0.215970680001s: {'exception': None, 'repo_id': u'default_organization-docker_product-docker_repo', 'traceback': None, 'started':...
Apr  7 02:55:04 hp-nehalem-02 pulp: celery.worker.job:INFO: Task pulp.server.async.tasks._release_resource[cfb0a800-3343-4115-b2ed-4ebd5f5580c7] succeeded in 0.00839505897602s: None

I am failing this ON_QA becoz:

Although Synchronizing a Docker-based repository for a non-existing image does not generates a scary message this time
it however, misguides the user that the sync was successful with
no Docker Manifests being synced
This again puts a question mark on whether the image was existing or not

Instead, it should generate proper error that the image is non-existing.

Comment 14 Michael Hrivnak 2016-04-07 14:57:25 UTC
What version of pulp was being tested?

I'll look into this more and see what's going on. The behavior as described does seem unintuitive.

Comment 15 Michael Hrivnak 2016-04-08 19:31:42 UTC
Pulp needs to do better at reporting why no content was found. That said, there are two steps that will make this use case successful:

1) use https://registry-1.docker.io as the feed for docker v2 content. This is what our upstream docs recommend [0].
2) there is no repository called "mongodb" on docker hub. There is one called simply "mongo"

When I create a repo with that feed and upstream name, I am able to sync it.

[0] http://pulp-docker.readthedocs.org/en/latest/user-guide/recipes.html#sync

Comment 16 pulp-infra@redhat.com 2016-04-08 20:03:36 UTC
The Pulp upstream bug status is at NEW. Updating the external tracker on this bug.

Comment 17 pulp-infra@redhat.com 2016-04-08 20:03:39 UTC
The Pulp upstream bug priority is at Normal. Updating the external tracker on this bug.

Comment 18 pulp-infra@redhat.com 2016-04-15 20:33:38 UTC
The Pulp upstream bug status is at ASSIGNED. Updating the external tracker on this bug.

Comment 19 pulp-infra@redhat.com 2016-04-15 20:33:42 UTC
The Pulp upstream bug priority is at High. Updating the external tracker on this bug.

Comment 20 pulp-infra@redhat.com 2016-04-18 19:03:41 UTC
The Pulp upstream bug status is at POST. Updating the external tracker on this bug.

Comment 22 pulp-infra@redhat.com 2016-05-03 20:30:41 UTC
The Pulp upstream bug status is at MODIFIED. Updating the external tracker on this bug.

Comment 24 pulp-infra@redhat.com 2016-05-26 20:31:12 UTC
The Pulp upstream bug status is at ON_QA. Updating the external tracker on this bug.

Comment 25 pulp-infra@redhat.com 2016-05-27 17:31:25 UTC
The Pulp upstream bug status is at CLOSED - CURRENTRELEASE. Updating the external tracker on this bug.

Comment 28 pulp-infra@redhat.com 2016-05-31 17:31:00 UTC
The Pulp upstream bug status is at MODIFIED. Updating the external tracker on this bug.

Comment 29 Corey Welton 2016-05-31 21:46:19 UTC
Michael,

To answer your needinfo above, I'm estimating that this was tested on a build using pulp-server-2.8.1.1-1.el7sat.noarch.rpm

Comment 30 pulp-infra@redhat.com 2016-06-17 17:31:07 UTC
The Pulp upstream bug status is at ON_QA. Updating the external tracker on this bug.

Comment 31 pulp-infra@redhat.com 2016-06-27 17:01:27 UTC
The Pulp upstream bug status is at CLOSED - CURRENTRELEASE. Updating the external tracker on this bug.

Comment 32 Brad Buckingham 2016-07-25 13:20:47 UTC
Moving to POST as upstream fix is available.

Comment 33 Lukas Pramuk 2016-10-13 12:44:15 UTC
VERIFIED.

@satellite-6.2.3-1.0.el7sat.noarch
pulp-server-2.8.7.1-2.el7sat.noarch
pulp-rpm-plugins-2.8.7.2-1.el7sat.noarch
python-pulp-docker-common-2.0.3-1.el7sat.noarch

by manual reproducer:

1. Create docker repository with non-existing upstream name
URL: https://registry-1.docker.io/ 
Upstream Name: sdjhflkjdshf

2. Sync this docker repository

3. Sync task fails with reasonable error:
DKR1007: Could not fetch repository library/sdjhflkjdshf from registry https://registry-1.docker.io/ - Unauthorized or Not Found

4. No tracebacks in pulp log:
...
Oct 13 08:31:42 <FQDN> pulp: pulp.server.async.tasks:INFO: Task failed : [a4f2b547-879e-460b-b9d9-7fa8fd5175d6] : Could not fetch repository library/sdjhflkjdshf from registry https://registry-1.docker.io/ - Unauthorized or Not Found
Oct 13 08:31:42 <FQDN> pulp: celery.worker.job:INFO: Task pulp.server.managers.repo.sync.sync[a4f2b547-879e-460b-b9d9-7fa8fd5175d6] raised expected: PulpCodedException()
...

Comment 35 errata-xmlrpc 2016-10-26 12:25:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:2108


Note You need to log in before you can comment on or make changes to this bug.