Bug 1193685 - Cannot change the docker upstream name for a repository that doesn't have a sync url
Summary: Cannot change the docker upstream name for a repository that doesn't have a s...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Brad Buckingham
QA Contact: Lukas Pramuk
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On: 1193669
Blocks: 1190289
TreeView+ depends on / blocked
 
Reported: 2015-02-17 21:36 UTC by David Davis
Modified: 2019-09-26 14:46 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:13:28 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC
Foreman Issue Tracker 14111 None None None 2016-04-22 15:41:05 UTC

Description David Davis 2015-02-17 21:36:07 UTC
Description of problem:

When I try to set the repository upstream name for a repo that never had one, nothing happens. I see no error, etc.


Version-Release number of selected component (if applicable):

6.1.0


How reproducible:

Always


Steps to Reproduce:
1. Create a docker repo with no upstream name and no sync url
2. Edit the docker repo's upstream name or url


Actual results:

Nothing happens. The upstream name is not changed and I don't see an error.


Expected results:

An error or success.
Additional info:

Comment 1 RHEL Product and Program Management 2015-02-18 05:58:25 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Brad Buckingham 2016-03-08 21:06:36 UTC
The current behavior is different than the bug description; however, the current behavior is also not correct.

Current behavior,
1. user can create a docker repo without specifying url and upstream-name
2. if the user did not url and upstream-name during creation, they will receive an error, if they attempt edit the repository to add them.  The reason being, the UI will only add 1 at a time; however, both are required, if at least one is provided.

With docker v2, Satellite no longer support the ability to upload a docker image (now referred to as a manifest).   As a result, in order to address this bugzilla, we are going to make url and upstream-name required on repository creation.  If in the future, Satellite is able to support upload again, this can be revisited.

Comment 4 Brad Buckingham 2016-03-09 00:02:30 UTC
Created redmine issue http://projects.theforeman.org/issues/14111 from this bug

Comment 5 Brad Buckingham 2016-03-09 00:26:32 UTC
Upstream Katello PR: https://github.com/Katello/katello/pull/5859

Comment 6 Bryan Kearney 2016-03-09 01:13:02 UTC
Upstream bug component is Content Management

Comment 8 Lukas Pramuk 2016-05-10 16:39:29 UTC
VERIFIED.

@Sat6.2.0-Beta
tfm-rubygem-katello-3.0.0.26-1.el7sat.noarch

Tested both CLI/UI that upon docker repository creation an upstream name and Registry URL are always required. 
On updating docker repository the same check is applied.

# hammer repository create --name empty --product "Custom Product" --organization-id 1 --content-type docker
Could not create the repository:
  Validation failed: Repository URL or Upstream Name is empty. Both are required for syncing from the upstream.

# hammer repository create --name empty --product "Custom Product" --organization-id 1 --content-type docker --url https://registry-1.docker.io/
Could not create the repository:
  Validation failed: Repository URL or Upstream Name is empty. Both are required for syncing from the upstream.

# hammer repository create --name empty --product "Custom Product" --organization-id 1 --content-type docker --url https://registry-1.docker.io/ --docker-upstream-name o
Could not create the repository:
  Validation failed: Docker upstream name must be a valid docker name

# hammer repository create --name empty --product "Custom Product" --organization-id 1 --content-type docker --url https://registry-1.docker.io/ --docker-upstream-name busybox
Repository created

Comment 10 errata-xmlrpc 2016-07-27 09:13:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.