Bug 119370 - Error when searching c/c++ object file
Error when searching c/c++ object file
Status: CLOSED CURRENTRELEASE
Product: Red Hat Developer Suite
Classification: Retired
Component: CDT (Show other bugs)
1.0
All Linux
low Severity medium
: ---
: ---
Assigned To: Tom Tromey
eclipse-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-29 17:06 EST by Keith Seitz
Modified: 2014-08-11 01:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-03 18:40:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Keith Seitz 2004-03-29 17:06:25 EST
Description of problem:
When using the search feature, clicking on a non-text file causes
errors to be spewed to the console.

Version-Release number of selected component (if applicable):
20040329 nightly

How reproducible:
Every time

Steps to Reproduce:
1. Create/import a project with a string in it. (Need executable!)
2. Open Search dialog and enter the string from above
3. Double-click on the search result that is an object file.
(For example, import the "pi" project and look for the string "pi".
Double-click on "pi.o" or "pi2.o".)
  
Actual results:
Opens editor and spews a bunch of errors to console:
** (<unknown>:1926): WARNING **: Invalid UTF8 string passed to
pango_layout_set_text()


Expected results:
Open editor and no errors

Additional info:
Probably need some sort of binary file "editor" a la hexl-mode.
Comment 1 Keith Seitz 2004-08-03 18:40:28 EDT
This, too, seems to be "fixed". The 3.0 search facilities does not
search binary files any more. Instead it gives errors about not being
able to read a binary file ("could not read file during search"). No
more errors on the terminal. I think this is satisfactory behavior.

Note You need to log in before you can comment on or make changes to this bug.