Bug 1193776 - [ovirt][setup] engine.p12 isn't created and fails pki/ssh.py
Summary: [ovirt][setup] engine.p12 isn't created and fails pki/ssh.py
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-installer
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Sandro Bonazzola
QA Contact: Pavel Stehlik
URL:
Whiteboard: infra
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-18 08:13 UTC by Roy Golan
Modified: 2015-02-23 07:49 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-23 07:49:56 UTC
oVirt Team: ---


Attachments (Terms of Use)
failed setup log (89.23 KB, application/x-gzip)
2015-02-22 11:46 UTC, Roy Golan
no flags Details

Description Roy Golan 2015-02-18 08:13:03 UTC
Description of problem:

created a fresh devloper build on F21 and setup fails with and error on pkcs12-extract.sh and share/ovirt-engine/setup/bin/../plugins/ovirt-engine-setup/ovirt-engine/pki/ssh.py because there was no engine.p12 key created under etc/pki/ovirt-engine


Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. make clean install-dev on F21
2. run bin/engine-setup
3.

Comment 1 Roy Golan 2015-02-18 08:14:36 UTC
openssl-libs-1.0.1k-1.fc21.x86_64
openssh-6.6.1p1-11.1.fc21.x86_64
openssh-askpass-6.6.1p1-11.1.fc21.x86_64
openssh-clients-6.6.1p1-11.1.fc21.x86_64
openssh-server-6.6.1p1-11.1.fc21.x86_64
openssl-libs-1.0.1k-1.fc21.i686
openssl-1.0.1k-1.fc21.x86_64

Comment 2 Yedidyah Bar David 2015-02-18 09:24:01 UTC
Please attach setup logs. Thanks.

Comment 3 Roy Golan 2015-02-22 11:46:15 UTC
Created attachment 994225 [details]
failed setup log

Comment 4 Yedidyah Bar David 2015-02-22 12:59:47 UTC
(In reply to Roy Golan from comment #3)
> Created attachment 994225 [details]
> failed setup log

This log seems like an upgrade, not a fresh setup.

Comment 5 Roy Golan 2015-02-23 07:49:56 UTC
this doesn't happen upstream any more. probably something have been fixed somewhere.


Note You need to log in before you can comment on or make changes to this bug.