Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1193789 - Deployment units do not exist after restart
Summary: Deployment units do not exist after restart
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: JBoss BPMS Platform 6
Classification: Retired
Component: Business Central
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: ---
Assignee: Maciej Swiderski
QA Contact: Ivo Bek
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-18 08:32 UTC by Ivo Bek
Modified: 2015-02-19 10:17 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-19 10:17:19 UTC
Type: Bug


Attachments (Terms of Use)

Description Ivo Bek 2015-02-18 08:32:05 UTC
Description of problem:

First, I build and deploy any project which will create a deployment unit. However, when I shutdown the application server and start it over, the deployment unit is not in the list of deployment units.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Build and deploy any example project (repository1/project1)
2. See the deployment unit is really created
3. Restart the application server
4. See the deployment unit is missing in Deploy/Process Deployments

Actual results:


Expected results:


Additional info:

Comment 2 Maciej Swiderski 2015-02-18 12:33:51 UTC
Ivo,

most likely it's because you run with in memory db and that's why it's gone with all its data including information about deployments. Previously deployments were stored in system git repo though it causes complexity when it comes to handling cluster etc so db storage was taken as the preferred one.

So either run on db that will preserve its state between server restarts or set 'org.kie.git.deployments.enabled' system property to true to store them in system git repo as well. 

Could you please get back to me if above is correct?

Comment 3 Ivo Bek 2015-02-18 16:15:41 UTC
Hi Maciej,

you are absolutely right. It is caused by the in memory h2 database and when I use the system property the git repository is used instead as it used to be. 

Do we have any BZ for the requirement to move the deployments from git repository to database? I believe this change should be documented.

Comment 4 Maciej Swiderski 2015-02-18 16:23:16 UTC
thanks for confirmation.

there is no direct bz about that change but it was introduced as part of EJB/services work as without db storage it would require always to be setup with zookeeper and helix which complicates the runtime architecture especially that it does sync only system.git as for runtime there won't be anything else.

So as you can see it was not removed but was disabled by default to rely on db by default. And can be enabled any time, same db storage can be disabled.

+1 for documenting that although it is backward compatible meaning first time it will run on new setup it will read up from system.git and deploy into runtime which will result in db store. At the same time it will remove it from system git to clean it up completely.

Hope it makes sense...

Comment 5 Ivo Bek 2015-02-19 10:17:19 UTC
Maciej, thank you for the detail explanation. It makes sense and so I filed BZ 1194191 to document this change.

I close this BZ since deployment units work as expected.


Note You need to log in before you can comment on or make changes to this bug.