Bug 1193817 - scsi generic module is not loaded by default
Summary: scsi generic module is not loaded by default
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: systemd
Version: 7.1
Hardware: All
OS: Linux
unspecified
low
Target Milestone: rc
: ---
Assignee: systemd-maint
QA Contact: Branislav Blaškovič
URL:
Whiteboard:
Depends On: 1186462
Blocks: 1133060
TreeView+ depends on / blocked
 
Reported: 2015-02-18 10:25 UTC by Vishnu Kumar
Modified: 2019-07-11 08:40 UTC (History)
12 users (show)

Fixed In Version: systemd-219-3.el7
Doc Type: Bug Fix
Doc Text:
Cause: Previously the module was load automatically by some other package. Consequence: They have removed that. Fix: Now we load the sg driver, when there is a scsi device. Result:
Clone Of:
Environment:
Last Closed: 2015-11-19 15:06:04 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 1474203 None None None Never
Red Hat Product Errata RHBA-2015:2092 normal SHIPPED_LIVE systemd bug fix and enhancement update 2015-11-19 12:13:57 UTC

Description Vishnu Kumar 2015-02-18 10:25:46 UTC
Description of problem:
sg module is not loaded by default

Version-Release number of selected component (if applicable):
3.5.36

How reproducible:
100%

Steps to Reproduce:
1. Install RH 7.1 RC1
2. Grep for the sg module 


Actual results:
sg module is not loaded

Expected results:
sg module should be loaded by default

Additional info:
[root@RH71-RC1 ~]# lsmod | grep -i sg
ipmi_msghandler        45603  2 ipmi_devintf,ipmi_si
[root@RH71-RC1 ~]# modprobe sg
[root@RH71-RC1 ~]# lsmod | grep -i sg
sg                     40721  0
ipmi_msghandler        45603  2 ipmi_devintf,ipmi_si
[root@RH71-RC1 ~]# clear

Comment 2 George Yameen 2015-02-28 01:24:32 UTC
Hi,

Will this be fixed when this GA's?

Thanks!
George

Comment 3 Lukas Herbolt 2015-03-17 09:52:43 UTC
Same issue in GA.
sg module is not loaded after update from 7.0 to 7.1.

Comment 5 George Yameen 2015-05-20 17:54:54 UTC
Hi,

Is there any update for this?

Thanks!
George

Comment 6 David Sommerseth 2015-05-20 18:23:47 UTC
Sorry for the lack of updates - we've been working on this one, but this issue has been tracked a few other places as well.

Yes, there is a solution on the way.  The issue is related to a udev rule which was removed from systemd (hence the change from sg3_utils to systemd) which was responsible for loading the sg module automatically.  The current plan is to re-introduce this rule for RHEL7.

Comment 9 George Yameen 2015-06-25 23:50:21 UTC
Hi David,

Thank you for the update, can you give us a date for this solution?

Thanks!
George

Comment 10 Branislav Blaškovič 2015-08-31 13:15:57 UTC
$ cat 0180-rules-load-sg-module.patch
From 50a7827f7376d31d2af2dc563fc51d8ad71f48dc Mon Sep 17 00:00:00 2001
From: Lukas Nykryn <lnykryn@redhat.com>
Date: Wed, 20 May 2015 12:34:18 +0200
Subject: [PATCH] rules: load sg module

Revert of 09637f743414e2c36d6c5b032d77d76dbeb86b31
RHEL-only

Resolves: #1186462
---
 rules/40-redhat.rules | 3 +++
 1 file changed, 3 insertions(+)

diff --git a/rules/40-redhat.rules b/rules/40-redhat.rules
index 556a3a3..305e752 100644
--- a/rules/40-redhat.rules
+++ b/rules/40-redhat.rules
@@ -8,3 +8,6 @@ SUBSYSTEM=="memory", ACTION=="add", ATTR{state}=="offline", ATTR{state}="online"
 
 # reload sysctl.conf / sysctl.conf.d settings when the bridge module is loaded
 ACTION=="add", SUBSYSTEM=="module", KERNEL=="bridge", RUN+="/usr/lib/systemd/systemd-sysctl --prefix=/proc/sys/net/bridge"
+
+# load SCSI generic (sg) driver
+SUBSYSTEM=="scsi", ENV{DEVTYPE}=="scsi_device", TEST!="[module/sg]", RUN+="/sbin/modprobe -bv sg"

This patch will be released in RHEL7.2. Beta should be out soon.

Comment 11 Branislav Blaškovič 2015-10-02 14:36:28 UTC
Switching this to SanityOnly, patch is in current systemd build as I wrote before in comment 10.

Comment 12 errata-xmlrpc 2015-11-19 15:06:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2092.html


Note You need to log in before you can comment on or make changes to this bug.