Bug 119383 - kinput2 not working with some (gnome?) apps
kinput2 not working with some (gnome?) apps
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kinput2 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Akira TAGOH
Bill Huang
:
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-03-29 18:05 EST by P Jones
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-31 19:21:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description P Jones 2004-03-29 18:05:21 EST
Description of problem:
If I start up x in Japanese, I can input Japanese with xterm, vim in
xterm, emacs,  etc. but can not enter in gnome-terminal, gvim, etc,
Nor mozilla or firefly.
 
 
Version-Rvte-0.11.10-5.1
Canna-3.7p1-5
kinput2-canna-wnn6-v3.1-16
gnome-terminal-2.5.90-1.1
elease number of selected component (if applicable):
 
 
How reproducible:
very
Comment 1 P Jones 2004-03-29 18:06:53 EST
oh, and reproduction:
1. log in under japanese
2. start xterm and gnome-terminal
3. hit shift-space then A in each
     
What happens:
xterm produces hiragana for 'a" (as a square, but that's a font hing).
gnome-terminal produces a space, then a A, refusing to enter the
japanese mode.
 
What should happen:
Both to produce hiragana.
Comment 2 Akira TAGOH 2004-03-29 19:09:54 EST
Which version of xinitrc did you install on your machine?
Please make sure if your environment variable is set correctly.

$ echo $XMODIFIERS
XMODIFIERS=@im=kinput2
$ echo $GTK_IM_MODULE

$ ps auxw | grep kinput2
...
Comment 3 P Jones 2004-03-30 19:46:47 EST
$ echo $XMODIFIERS
@im=kinput2
$ echo $GTK_IM_MODULE
 
$ ps auxw | grep kinput2
mouse     4879  0.0  0.2  5820 2324 ?        S    Mar28   0:00 kinput2
-canna +kinput -xim
$ rpm -q xinitrc
xinitrc-3.37-1

Note: I fixed xinitrc's bug #119284 on this version... I'll try again
in 3.38 in a minute
Comment 4 P Jones 2004-03-30 19:53:31 EST
xinitrc-3.38-1 fails as well.
Comment 5 Akira TAGOH 2004-03-30 21:26:48 EST
According to your report, it should works. and I can't reproduce your
problem with your step. kinput2 seems to be running correctly and the
GNOME applications should be running with proper XMODIFIERS. your
locale should be no problem because you can use kinput2 on non-GNOME
applications.
Though GTK_IM_MODULE seems to not set, but please make sure your GNOME
applications choose XIM-- on gnome-terminal say, Input Methods->X
Input Method from the popup menu which is realized by the right click.
Otherwise probably you should get any error messages in
~/.xsession-errors.
Comment 6 P Jones 2004-03-30 23:01:22 EST
I *only* have default listed under input methods... 
No errors in ~/.xsession-errors
Comment 7 Akira TAGOH 2004-03-31 05:32:25 EST
It looks like you failed the installation of the gtk2 package...
Please make sure:
- what version of gtk2 are you using? -- rpm -q gtk2
- whether you have the immodules installed? -- ls
/usr/lib/gtk-2.0/*/immodules/
- whether such immodules are registered to /etc/gtk-2.0/gtk.immodules
properly
Comment 8 P Jones 2004-03-31 08:32:32 EST
rpm -q gtk2
gtk2-2.4.0-1
(rpm verifies this package ok)
that ls has a bunch of stuff...
/etc/gtk-2.0/gtk.immodules is empty... Hrms... that doesn't match my
FC1 box...
Comment 9 P Jones 2004-03-31 08:37:40 EST
Ok. so, I manualy added xim to gtk.immodules, and things worked
fine... so it's not being generated (BTW, by empty I do mean 0 byte).
What generates that file?  I'll take a look and see if I can find a
reason it wasn't...
Comment 10 Akira TAGOH 2004-03-31 19:21:49 EST
I'm not sure what happened there, and gtk2's scriptlet should
generates it properly:
$ rpm  -q --scripts gtk2
postinstall scriptlet (using /bin/sh):
/sbin/ldconfig
umask 022
/usr/bin/gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules
/usr/bin/gdk-pixbuf-query-loaders > /etc/gtk-2.0/gdk-pixbuf.loaders

So now you can generate it manually as well, and closing this then.
Comment 11 P Jones 2004-03-31 21:57:34 EST
At least it'll be googleable now :) Thanks!
Comment 12 Eido Inoue 2004-05-03 23:31:09 EDT
Is this bug still applicable to FC1 test 1? If its for later versions,
please update.

Note You need to log in before you can comment on or make changes to this bug.