Bug 1193835 - when manifest is uploaded via hammer, you do not see all the products available
Summary: when manifest is uploaded via hammer, you do not see all the products available
Keywords:
Status: CLOSED DUPLICATE of bug 1193803
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Candlepin
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Barnaby Court
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-18 11:22 UTC by Jan Hutař
Modified: 2016-03-04 18:21 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-04 18:21:13 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jan Hutař 2015-02-18 11:22:13 UTC
Description of problem:
When manifest is uploaded via hammer, you do not see all the products available (again, via hammer).


Version-Release number of selected component (if applicable):
Satellite-6.1.0-RHEL-6-20150217.0-x86_64


How reproducible:
always


Steps to Reproduce:
1. Upload the manifest:
   # hammer --username <user> --password <pass> subscription upload \
     --organization-id 3 --file manifest.zip
2. List products:
   # hammer --username <user> --password <pass> product list \
     --organization-id 3 --per-page 100
3. Refresh manifest:
   # hammer --username <user> --password <pass> subscription refresh-manifest --organization-id 3
4. List products again:
   # hammer --username <user> --password <pass> product list \
     --organization-id 3 --per-page 100


Actual results:
In step 2 I see only few products listed:

# hammer --username admin --password changeme product list --organization-id 3 --per-page 100
/usr/lib/ruby/gems/1.8/gems/hammer_cli-0.1.4/lib/hammer_cli/./apipie/../abstract.rb:68: warning: already initialized constant DEFAULT_LABEL_INDENT
----|------------------------------------------------------------|-------------|--------------|--------------|-----------
ID  | NAME                                                       | DESCRIPTION | ORGANIZATION | REPOSITORIES | SYNC STATE
----|------------------------------------------------------------|-------------|--------------|--------------|-----------
114 | Oracle Java for RHEL Server                                |             | satellite-qa | 0            | not_synced
112 | Red Hat Beta                                               |             | satellite-qa | 0            | not_synced
113 | Red Hat Enterprise Linux 7 Public Beta                     |             | satellite-qa | 0            | not_synced
115 | Red Hat Enterprise Linux High Availability for RHEL Server |             | satellite-qa | 0            | not_synced
117 | Red Hat Enterprise Linux Load Balancer for RHEL Server     |             | satellite-qa | 0            | not_synced
119 | Red Hat Enterprise Linux Resilient Storage for RHEL Server |             | satellite-qa | 0            | not_synced
116 | Red Hat Enterprise Linux Server                            |             | satellite-qa | 0            | not_synced
120 | Red Hat Enterprise Linux Workstation                       |             | satellite-qa | 0            | not_synced
----|------------------------------------------------------------|-------------|--------------|--------------|-----------

and in step 4 all seems fine:

# hammer --username admin --password changeme product list --organization-id 3 --per-page 1000 | wc -l
/usr/lib/ruby/gems/1.8/gems/hammer_cli-0.1.4/lib/hammer_cli/./apipie/../abstract.rb:68: warning: already initialized constant DEFAULT_LABEL_INDENT
114


Expected results:
I should be able to see all products in step 2 of the reproducer as well.

Comment 2 RHEL Program Management 2015-02-18 20:06:30 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 4 Jan Hutař 2015-02-20 08:10:35 UTC
Ok, so looks like refreshing manifest is not enough.

Also tested via webUI that most of products are missing.

There is probably some background process running which makes this quite non-deterministic.

Comment 5 Jan Hutař 2015-04-06 05:15:20 UTC
This might be a duplicate of bug 1193803.

Comment 6 Devan Goodwin 2015-08-13 12:19:35 UTC
We need to verify if this is still an issue once candlepin 2.0 lands for Sat 6.2.

Comment 8 Barnaby Court 2016-03-04 18:21:13 UTC
There is very definitely a timeout issue. This has already been opened in 1193803.

*** This bug has been marked as a duplicate of bug 1193803 ***


Note You need to log in before you can comment on or make changes to this bug.