Bug 1193863 - Getting Network Error 404 while accessing the apidocs on sat6 server
Summary: Getting Network Error 404 while accessing the apidocs on sat6 server
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: API
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: jcallaha
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-18 12:46 UTC by Sachin Ghai
Modified: 2019-09-25 21:15 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:48:34 UTC
Target Upstream Version:


Attachments (Terms of Use)
Network Error 404 while accessing the apidocs on sat6 server (109.87 KB, image/png)
2015-02-18 12:46 UTC, Sachin Ghai
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Sachin Ghai 2015-02-18 12:46:48 UTC
Created attachment 993079 [details]
Network Error 404 while accessing the apidocs on sat6 server

Description of problem:
I'm getting so many failures while accessing https://<sat61_hostname>/apidoc on sat6 server itself.

--
Processing by Apipie::ApipiesController#index as HTML
  Parameters: {"version"=>"stylesheets", "resource"=>"bundled", "method"=>"bootstrap.min.css"}
API doc cache not found for '/apidoc/stylesheets/bundled/bootstrap.min.css.html'. Perhaps you have forgot to run `rake apipie:cache`
Completed 404 Not Found in 1ms (ActiveRecord: 0.0ms)
Processing by Apipie::ApipiesController#index as HTML
  Parameters: {"version"=>"stylesheets", "resource"=>"bundled", "method"=>"prettify.css"}
API doc cache not found for '/apidoc/stylesheets/bundled/prettify.css.html'. Perhaps you have forgot to run `rake apipie:cache`
Completed 404 Not Found in 1ms (ActiveRecord: 0.0ms)
Processing by Apipie::ApipiesController#index as HTML
  Parameters: {"version"=>"stylesheets", "resource"=>"application.css"}
API doc cache not found for '/apidoc/stylesheets/application.css.html'. Perhaps you have forgot to run `rake apipie:cache`
Completed 404 Not Found in 1ms (ActiveRecord: 0.0ms)
Processing by Apipie::ApipiesController#index as HTML
  Parameters: {"version"=>"stylesheets", "resource"=>"bundled", "method"=>"bootstrap-responsive.min.css"}
Completed 400 Bad Request in 1ms (ActiveRecord: 0.0ms)
Processing by Apipie::ApipiesController#index as */*
  Parameters: {"version"=>"javascripts", "resource"=>"bundled", "method"=>"bootstrap-collapse.js"}
Completed 400 Bad Request in 1ms (ActiveRecord: 0.0ms)
Processing by Apipie::ApipiesController#index as */*
  Parameters: {"version"=>"javascripts", "resource"=>"bundled", "method"=>"prettify.js"}
API doc cache not found for '/apidoc/javascripts/bundled/prettify.js.html'. Perhaps you have forgot to run `rake apipie:cache`
Completed 404 Not Found in 1ms (ActiveRecord: 0.0ms)
Processing by Apipie::ApipiesController#index as */*
  Parameters: {"version"=>"javascripts", "resource"=>"apipie.js"}
API doc cache not found for '/apidoc/javascripts/apipie.js.html'. Perhaps you have forgot to run `rake apipie:cache`
Completed 404 Not Found in 1ms (ActiveRecord: 0.0ms)
--

Version-Release number of selected component (if applicable):
sat6.1 beta snap3
Satellite-6.1.0-RHEL-6-20150217.0

How reproducible:
always

Steps to Reproduce:
1. access sat6 URL: https://<sat61_hostname>/apidoc
2.
3.

Actual results:
lotz of Network_error 404

Expected results:
no error

Additional info:

Comment 2 Ohad Levy 2016-03-07 13:22:24 UTC
not reproducible with 6.2 builds, setting on qe

Comment 4 jcallaha 2016-04-05 19:34:58 UTC
Verified in Satellite 6.2 Beta Snap 6 Compose 1.

Comment 6 errata-xmlrpc 2016-07-27 08:48:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.