Bug 1193990 - Review Request: opencity - Full 3D city simulator game project
Summary: Review Request: opencity - Full 3D city simulator game project
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: František Dvořák
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1243379
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-18 17:11 UTC by Alexandre Moine
Modified: 2015-08-19 08:27 UTC (History)
4 users (show)

Fixed In Version: opencity-0.0.6.5-3.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-15 02:09:29 UTC
Type: ---
valtri: fedora-review+
gwync: fedora-cvs+


Attachments (Terms of Use)

Description Alexandre Moine 2015-02-18 17:11:22 UTC
Hi, I just finished packaging up opencity, a little game, I will be pleased if anyone want to review it :)

Spec URL: https://www.dropbox.com/s/enxbhfrvt2o1sg1/opencity.spec
SRPM URL: https://www.dropbox.com/s/3xrp4rta3hazevc/opencity-0.0.6.4-1.fc21.src.rpm

Description: 
This is just another city simulation.
The idea is simple: you have to build a city with 3 types of "zones":
Residential, Commercial and Industrial.
They depend on each other during their development.
Try to give them what they need and watch your city growing up.

Fedora Account System Username: nobrakal

Scratch build in koji: http://koji.fedoraproject.org/koji/taskinfo?taskID=8982333

rpmlint with the spec: 0 packages and 1 specfiles checked; 0 errors, 0 warnings.
rpmlint with the rpm:
opencity.x86_64: W: non-conffile-in-etc /etc/opencity/config/graphism.conf
opencity.x86_64: W: non-conffile-in-etc /etc/opencity/config/graphism.xml
opencity.x86_64: W: non-conffile-in-etc /etc/opencity/config/opencity.xml
1 packages and 0 specfiles checked; 0 errors, 3 warnings.

Tinyxml and tinyxpath seems to be bundled libraries, but there is nothing about it in readme, copying or authors files... I don't know what to do.

Comment 1 František Dvořák 2015-02-21 17:03:19 UTC
(In reply to nobrakal from comment #0)
> 
> Tinyxml and tinyxpath seems to be bundled libraries, but there is nothing
> about it in readme, copying or authors files... I don't know what to do.

There is some info inside the source files:

binreloc: the official homepage not valid anymore, although there are many copies; it is not needed for Fedora, maybe it could be patched out? (from configure.ac, and using stubs for br_find_* function in zen.cpp and main.cpp files?)

tinyxml: http://sourceforge.net/projects/tinyxml/
 - this is already packaged in Fedora

tinyxpath: http://sourceforge.net/projects/tinyxpath/
 - needs to be packaged

Btw. they have also different licenses, but it will be solved by unbundling.


More comments to the packaging:

1) it is better to not using dropbox:

http://fedoraproject.org/wiki/Join_the_package_collection_maintainers#Upload_Your_Package


2) license file is missing in the package (COPYING file)


3) what does the empty '%doc'?


4) it could be added '%config(noreplace)' to '%{_sysconfdir}/%{name}'


5) man pages should be installed uncomplessed and leave to the build system thier compression (http://fedoraproject.org/wiki/Packaging:Guidelines#Manpages)


6) details:
- it may be easier to remove INSTALL* files or using %exclude instead of patching, but using patch is OK
- the commented out 'Requires:' line can be removed
- you can consider noarch subpackage (opencity-data?) for /usr/share/opencity

Comment 2 Alexandre Moine 2015-07-15 15:36:16 UTC
Spec URL: https://nobrakal.fedorapeople.org/opencity.spec
SRPM URL: https://nobrakal.fedorapeople.org/opencity-0.0.6.5-1.fc22.src.rpm

Hi,

It took time, but know, a new version, with many improvements:

- Update to a new upstream (0.0.6.5)

- Create a data subpackage

- Unbundle tinyxml and tinyxpath (I submited a review request for the last one at BGZ#1243379 (and it also had a bundled version of tinyxml haha)). I added the bug as a blocker for this one.

- Unbundle BinReloc, by patched configure.ac, and use of a preprocessor condition (I want to work a little bit more on the patch and send it to upstream, that's why I not do a basic path).

- Create a .appdata.xml file

- Remove unnecessary fields

The package build just fine with mock -r fedora-22-x86_64

Thank you for your help !

Comment 3 František Dvořák 2015-07-31 14:36:56 UTC
Taking the review.

Issues found:

1) I had problem with build and autotools on Fedora 24/rawhide (it complains about libtool version changes)

It was working when used the upstream way instead of autoreconf:

# https://sourceforge.net/p/opencity/code/HEAD/tree/trunk/opencity/autogen.sh
aclocal
libtoolize -c
autoconf
autoheader
automake -a -c

This way, Makefile.in will be regenerated from Makefile.am, so the patch 'opencity.remove_install_files.patch' would need to be updated to patch the Makefile.am instead (but the patch maybe won't be needed? as suggested in 10)?).


2) fedora-review: Obsoleted m4s macros found

AC_PROG_LIBTOOL found in: opencity-0.0.6.5stable/configure.ac:30

See: https://fedorahosted.org/FedoraReview/wiki/AutoTools


3) build fails on appdata check

It should be used "appstream-util validate-relax --nonet ...".

Also there is probably misplaced </p> tag (funny is the validator doesn't complain about it).

See: http://fedoraproject.org/wiki/Packaging:AppData


4) rpmlint: opencity-debuginfo.x86_64: E: debuginfo-without-sources

There is a problem with build flags - they are overwritten in %build. It can be fixed by adding also %{optflags} to CXXFLAGS.


5) configure: WARNING: unrecognized options: --disable-binreloc, --disable-binreloc-threads

These parameters are not needed. (Not important, just small simplification.)


6) -data subpackage: better to have it as noarch package: "BuildArch: noarch"


7) tinyxml and tinyxpath runtime requires not needed: it is better to handle library runtime dependencies automatically


8) rpmlint: opencity-data.x86_64: W: summary-ended-with-dot C Data files for opencity.


9) rpmlint: opencity.src:54: W: mixed-use-of-spaces-and-tabs (spaces: line 1, tab: line 54)

Not important. It is possible to replace tabs in the sed commands by '\s' and '\t'.


10) fedora-review complains about license files in /usr/share/doc (they are already in /usr/share/license)

It could be used something like that?:

% install
# documentation handled by %%doc
rm -fv %{buildroot}%{_defaultdocdir}/%{name}

%files
%doc AUTHORS README doc/FAQ* doc/README*

(another way could be removing only the copyright files in the %install, but it is better not to combine absolute and relative paths in %doc/%license macros)

Comment 4 Alexandre Moine 2015-07-31 20:12:32 UTC
Re Hi ;)

Spec URL: https://nobrakal.fedorapeople.org/opencity.spec
SRPM URL: https://nobrakal.fedorapeople.org/opencity-0.0.6.5-2.fc22.src.rpm

1) Corrected, all work fine 
I removed the opencity.remove_install_files.patch, no longer necessary

2) Corrected, I replaced AC_PROG_LIBTOOL by LT_INIT with a sed

3) Corrected, I did it to quickly :p

4) Done

5) Removed unnecessary options

6) opencity-data is now a noarch package

7) Corrected

8) Corrected

9) Corrected

10) Corrected, all work fine :)

Thank you again

Comment 5 František Dvořák 2015-08-01 10:03:31 UTC
More checks:

10) documentation is duplicated in opencity and opencity-devel after the change, "%{_defaultdocdir}/%{name}/" could be removed from the data subpackage (if to keep the documentation in the base package?)

Also the configuration could be moved to the base package.


11) opencity.x86_64: E: incorrect-fsf-address /usr/share/licenses/opencity/COPYING

Upstream should be asked to update the FSF address (or replace the license file by the newer version from http://www.gnu.org/licenses/gpl2.txt).


12) the option "--include %{_includedir}/tinyxml.h" can be removed from the CXXFLAGS

Comment 6 Alexandre Moine 2015-08-01 12:00:44 UTC
Hi,

Spec URL: https://nobrakal.fedorapeople.org/opencity.spec
SRPM URL: https://nobrakal.fedorapeople.org/opencity-0.0.6.5-3.fc22.src.rpm

10) Corrected, doc kept in base package

11) Reported: https://sourceforge.net/p/opencity/bugs/52/

12) Removed

Thank you :D

Comment 7 František Dvořák 2015-08-01 12:55:52 UTC
Package Review
==============

Legend:
[x] = Pass, [!] = Fail, [-] = Not applicable, [?] = Not evaluated



===== MUST items =====

C/C++:
[x]: Package does not contain kernel modules.
[x]: Package contains no static executables.
[x]: Package does not contain any libtool archives (.la)
[x]: Rpath absent or only used for internal libs.

Generic:
[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[x]: License field in the package spec file matches the actual license.
     Note: Checking patched sources after %prep for licenses. Licenses
     found: "GPL (v2 or later)", "Unknown or generated". 1 files have
     unknown license.
[!]: License file installed when any subpackage combination is installed.
[x]: %build honors applicable compiler flags or justifies otherwise.
[x]: Package contains no bundled libraries without FPC exception.
[x]: Changelog in prescribed format.
[x]: Sources contain only permissible code or content.
[-]: Development files must be in a -devel package
[x]: Package uses nothing in %doc for runtime.
[x]: Package consistently uses macros (instead of hard-coded directory
     names).
[x]: Package is named according to the Package Naming Guidelines.
[x]: Package does not generate any conflict.
[x]: Package obeys FHS, except libexecdir and /usr/target.
[-]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[x]: Requires correct, justified where necessary.
[x]: Spec file is legible and written in American English.
[-]: Package contains systemd file(s) if in need.
[x]: Useful -debuginfo package or justification otherwise.
[x]: Package is not known to require an ExcludeArch tag.
[-]: Large documentation must go in a -doc subpackage. Large could be size
     (~1MB) or number of files.
     Note: Documentation size is 51200 bytes in 6 files.
[x]: Package complies to the Packaging Guidelines
[x]: Package successfully compiles and builds into binary rpms on at least
     one supported primary architecture.
[x]: Package installs properly.
[x]: Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see attachment).
[x]: If (and only if) the source package includes the text of the
     license(s) in its own file, then that file, containing the text of the
     license(s) for the package is included in %license.
[x]: Package requires other packages for directories it uses.
[x]: Package must own all directories that it creates.
[x]: Package does not own files or directories owned by other packages.
[x]: All build dependencies are listed in BuildRequires, except for any
     that are listed in the exceptions section of Packaging Guidelines.
[x]: Package uses either %{buildroot} or $RPM_BUILD_ROOT
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: %config files are marked noreplace or the reason is justified.
[x]: Macros in Summary, %description expandable at SRPM build time.
[x]: Package contains desktop file if it is a GUI application.
[x]: Package installs a %{name}.desktop using desktop-file-install or
     desktop-file-validate if there is such a file.
[x]: Dist tag is present.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Package use %makeinstall only when make install DESTDIR=... doesn't
     work.
[x]: Package is named using only allowed ASCII characters.
[x]: No %config files under /usr.
[x]: Package does not use a name that already exists.
[x]: Package is not relocatable.
[x]: Sources used to build the package match the upstream source, as
     provided in the spec URL.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[x]: File names are valid UTF-8.
[x]: Packages must not store files under /srv, /opt or /usr/local

===== SHOULD items =====

Generic:
[-]: If the source package does not include license text(s) as a separate
     file from upstream, the packager SHOULD query upstream to include it.
[x]: Final provides and requires are sane (see attachments).
[-]: Fully versioned dependency in subpackages if applicable.
     Note: No Requires: %{name}%{?_isa} = %{version}-%{release} in
     opencity-data
[x]: Package functions as described.
     Works OK: built a nice city :-)
[x]: Latest version is packaged.
[x]: Package does not include license text files separate from upstream.
[x]: Patches link to upstream bugs/comments/lists or are otherwise
     justified.
[-]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[x]: Package should compile and build into binary rpms on all supported
     architectures.
[-]: %check is present and all tests pass.
[x]: Packages should try to preserve timestamps of original installed
     files.
[x]: Packager, Vendor, PreReq, Copyright tags should not be in spec file
[x]: Sources can be downloaded from URI in Source: tag
[x]: Reviewer should test that the package builds in mock.
[x]: Buildroot is not present
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: Uses parallel make %{?_smp_mflags} macro.
[x]: SourceX is a working URL.
[x]: Spec use %global instead of %define unless justified.

===== EXTRA items =====

Generic:
[x]: Rpmlint is run on debuginfo package(s).
     Note: No rpmlint messages.
[x]: Rpmlint is run on all installed packages.
     Note: There are rpmlint messages (see attachment).
[x]: Large data in /usr/share should live in a noarch subpackage if package
     is arched.
[x]: Package should not use obsolete m4 macros
[x]: Spec file according to URL is the same as in SRPM.


Rpmlint
-------
Checking: opencity-0.0.6.5-3.fc24.x86_64.rpm
          opencity-data-0.0.6.5-3.fc24.noarch.rpm
          opencity-0.0.6.5-3.fc24.src.rpm
opencity.x86_64: E: incorrect-fsf-address /usr/share/licenses/opencity/COPYING
opencity-data.noarch: W: no-documentation
3 packages and 0 specfiles checked; 1 errors, 1 warnings.




Rpmlint (debuginfo)
-------------------
Checking: opencity-debuginfo-0.0.6.5-3.fc24.x86_64.rpm
1 packages and 0 specfiles checked; 0 errors, 0 warnings.





Rpmlint (installed packages)
----------------------------
opencity.x86_64: E: incorrect-fsf-address /usr/share/licenses/opencity/COPYING
opencity-data.noarch: W: no-documentation
3 packages and 0 specfiles checked; 1 errors, 1 warnings.



Requires
--------
opencity (rpmlib, GLIBC filtered):
    config(opencity)
    libGL.so.1()(64bit)
    libGLU.so.1()(64bit)
    libSDL-1.2.so.0()(64bit)
    libSDL_image-1.2.so.0()(64bit)
    libSDL_mixer-1.2.so.0()(64bit)
    libSDL_net-1.2.so.0()(64bit)
    libc.so.6()(64bit)
    libgcc_s.so.1()(64bit)
    libgcc_s.so.1(GCC_3.0)(64bit)
    libm.so.6()(64bit)
    libpng16.so.16()(64bit)
    libpthread.so.0()(64bit)
    libstdc++.so.6()(64bit)
    libstdc++.so.6(CXXABI_1.3)(64bit)
    libtinyxml.so.0()(64bit)
    libtinyxpath.so.0.1()(64bit)
    opencity-data
    rtld(GNU_HASH)

opencity-data (rpmlib, GLIBC filtered):



Provides
--------
opencity:
    appdata()
    appdata(opencity.appdata.xml)
    application()
    application(opencity.desktop)
    config(opencity)
    opencity
    opencity(x86-64)

opencity-data:
    opencity-data



Source checksums
----------------
http://downloads.sourceforge.net/opencity/opencity-0.0.6.5stable.tar.bz2 :
  CHECKSUM(SHA256) this package     : 7d7015bee0803f4b8257eefc5e1d7f437d581c6dcc0cd48628acf9896f0bc491
  CHECKSUM(SHA256) upstream package : 7d7015bee0803f4b8257eefc5e1d7f437d581c6dcc0cd48628acf9896f0bc491


Generated by fedora-review 0.5.3 (bcf15e3) last change: 2015-05-04
Command line :/usr/bin/fedora-review -m fedora-rawhide-x86_64 -n opencity -L /home/valtri/fedora2-scm/REVIEWS/opencity/repo-f23
Buildroot used: fedora-rawhide-x86_64
Active plugins: Generic, Shell-api, C/C++
Disabled plugins: Java, Python, fonts, SugarActivity, Ocaml, Perl, Haskell, R, PHP, Ruby
Disabled flags: EXARCH, DISTTAG, EPEL5, BATCH, EPEL6

Built with local dependencies:
    /home/valtri/fedora2-scm/REVIEWS/opencity/repo-f23/tinyxpath-1.3.1-2.fc24.x86_64.rpm
    /home/valtri/fedora2-scm/REVIEWS/opencity/repo-f23/tinyxpath-devel-1.3.1-2.fc24.x86_64.rpm

============

There is a problem with "License file installed when any subpackage combination is installed." (sorry, this is after my suggestions :-)). It can be solved:
- by adding "Requires: %{name} = %{version}-%{release}" to -data subpackage (so opencity and opencity-data will require each other)
- or the license files can be moved to -data subpackage ('%file data' section)

Btw. there is a typo in %changelog: "Remove bouble installation"

Both can be fixed post-review.
Package APPROVED!

Comment 8 Alexandre Moine 2015-08-01 17:07:15 UTC
Hi,

Both problems are fixed (I choose to move the license file into -data, because I think it will be a nonsense to have a subpackage that require the main and the main that require the subpackage). I have updated previous specs and srpm.

Thank you for your review!

Comment 9 Alexandre Moine 2015-08-01 17:10:22 UTC
New Package SCM Request
=======================
Package Name: opencity
Short Description: Full 3D city simulator game project
Upstream URL: http://www.opencity.info
Owners: nobrakal
Branches: f21 f22 f23
InitialCC:

Comment 10 Gwyn Ciesla 2015-08-04 13:05:31 UTC
Git done (by process-git-requests).

Comment 11 Fedora Update System 2015-08-06 08:46:04 UTC
opencity-0.0.6.5-3.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/opencity-0.0.6.5-3.fc22

Comment 12 Fedora Update System 2015-08-06 08:55:19 UTC
opencity-0.0.6.5-3.fc23 has been submitted as an update for Fedora 23.
https://admin.fedoraproject.org/updates/opencity-0.0.6.5-3.fc23

Comment 13 Fedora Update System 2015-08-06 09:20:14 UTC
opencity-0.0.6.5-3.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/opencity-0.0.6.5-3.fc21

Comment 14 Fedora Update System 2015-08-06 16:00:02 UTC
opencity-0.0.6.5-3.fc23 has been pushed to the Fedora 23 testing repository.

Comment 15 Fedora Update System 2015-08-15 02:09:29 UTC
opencity-0.0.6.5-3.fc23 has been pushed to the Fedora 23 stable repository.

Comment 16 Fedora Update System 2015-08-19 08:12:17 UTC
opencity-0.0.6.5-3.fc21 has been pushed to the Fedora 21 stable repository.

Comment 17 Fedora Update System 2015-08-19 08:27:10 UTC
opencity-0.0.6.5-3.fc22 has been pushed to the Fedora 22 stable repository.


Note You need to log in before you can comment on or make changes to this bug.