Bug 11940 - Tix install is wrong in Raw Hide tcltk package
Summary: Tix install is wrong in Raw Hide tcltk package
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: tcltk   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jens Petersen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-06-07 08:39 UTC by Jonathan Kamens
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-07 08:56:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Here's how I fixed this (531 bytes, patch)
2000-06-07 08:56 UTC, Jonathan Kamens
no flags Details | Diff

Description Jonathan Kamens 2000-06-07 08:39:11 UTC
I saw this error when building the tcltk RPM:

Installing
/usr/src/redhat/BUILD/tcltk-8.3.1/Tix4.1.0/library/pref/tixmkpref
/bin/sh: [: tk8.0/pkgIndex.tcl: binary operator expected
        No pkgIndex.tcl found in the target directories.
        pkgIndex.tcl installation skipped.

The problem is that since the spec file links the tk8.0 directory to tk8.2,
the command "if [ -f */pkgIndex.tcl ]; then" in the Tix unix/Makefile.in is
no longer valid because the wildcard matches to files.

The spec file should probably rename the directory instead of linking it.

Comment 1 Jonathan Kamens 2000-06-07 08:41:13 UTC
But it needs to rename the directory after applying the patches, or the patches
will fail :-).


Comment 2 Jonathan Kamens 2000-06-07 08:56:39 UTC
Created attachment 321 [details]
Here's how I fixed this

Comment 3 Jeff Johnson 2000-06-10 13:40:35 UTC
Fixed (as described) in tcltk-3.2.1-40. Thanks for the patch.

Comment 4 Need Real Name 2002-12-11 08:20:23 UTC
This "patch" should not be needed with tix 8.1.3 or 8.1.4.

Can you confirm for me that this is no longer in the tcltk package?

I have a new minor release ready to go but not yet announced.
Would you like to try it out and see if there are any problems
before I announce it. It's a bugfix release with no major changes
to the configure/make.

http://tix.sourceforge.net/dist/tix-8.1.4.tar.gz


Comment 5 Jens Petersen 2002-12-12 06:16:05 UTC
That is correct this patch is no longer in, and
hasn't been for a good while.

(In fact there is only one patch currently being applied
which is for itcl-3.2.1.)


Note You need to log in before you can comment on or make changes to this bug.