Bug 1194015 - No shell on VT2, other VTs missing
Summary: No shell on VT2, other VTs missing
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 22
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-18 18:58 UTC by Orion Poplawski
Modified: 2015-04-14 13:02 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-14 13:02:58 UTC
Type: Bug


Attachments (Terms of Use)

Description Orion Poplawski 2015-02-18 18:58:32 UTC
Description of problem:

Booted today's F22 PXE install image on a VM.  Cannot switch to VT2.  Only VT1 and VT4 appear to be active.

Version-Release number of selected component (if applicable):
22.20-1

How reproducible:
2 for 2 of the VM.

Comment 1 Orion Poplawski 2015-02-18 19:05:50 UTC
text mode kickstart install

Comment 2 Orion Poplawski 2015-02-18 19:08:57 UTC
Okay, this appears to be operator error - now with tmux apparently it is ctrl-b 2.  Would be nice if this was indicated on the screen.

Comment 3 David Shea 2015-02-24 22:19:11 UTC
There's supposed to be a shell on tty2, provided by systemd-logind, but for some reason logind isn't starting on F22 when you boot with inst.text. logind is running on tty2 in F21 when text mode is used.

The only changes to anaconda's systemd files since F21 have been to add anaconda-nm-config.service, which is used in both GUI and text installs, and to change the StandardInput parameter of anaconda-direct.service, which is only used in situations that don't apply here (inst.noshell, s390). I don't see anything obvious that would be causing a change in logind's behavior, so reassigning to systemd.

Comment 4 David Shea 2015-02-24 22:44:09 UTC
It's probably also worth noting that the installer environment uses ReserveVT=2 in /etc/systemd/logind.conf and symlinks a service that starts agetty to autovt@.service.

Comment 5 Jan Synacek 2015-04-14 09:06:59 UTC
systemd-logind is not started, because nothing requires it. Looking at the output of systemd-cgls, there is nothing that would actually need it or cause it to be loaded as a dependency.

To fix this "problem", add systemd-logind.service to the "Wants=" argument in the anaconda.service file.

Comment 6 Orion Poplawski 2015-04-14 13:02:58 UTC
Operator error


Note You need to log in before you can comment on or make changes to this bug.