Bug 1194042 - kernel 3.20 virtio networking is broken on kvm
Summary: kernel 3.20 virtio networking is broken on kvm
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 22
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F22AlphaFreezeException
TreeView+ depends on / blocked
 
Reported: 2015-02-18 20:29 UTC by Orion Poplawski
Modified: 2015-02-19 16:13 UTC (History)
7 users (show)

Fixed In Version: kernel-3.20.0-0.rc0.git9.1.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-19 16:13:41 UTC


Attachments (Terms of Use)

Description Orion Poplawski 2015-02-18 20:29:29 UTC
Description of problem:

Updating to 3.20 kernels on my virtio kvm guests breaks networking in strange ways.  System can get DHCP address fine and tshark shows some traffic, but almost everything else (DNS, ping, ssh) fails.

Version-Release number of selected component (if applicable):
3.20.0-0.rc0.git4.1.fc23
3.20.0-0.rc0.git7.3.fc23

How reproducible:
two kvm guests so far

Comment 1 Kevin Fenzi 2015-02-19 02:14:14 UTC
Perhaps someone could run dmesg on both 3.20 and 3.19 and diff the two for changes?

Comment 2 Jens Petersen 2015-02-19 02:19:36 UTC
Reproduced: with kernel-3.20 I cannot ping any hosts, unlike with 3.19.

ie kernel-3.19.0-0.rc7.git3.1.fc22 works fine but not
kernel-3.20.0-0.rc0.git*.fc22 apparently.

I really think this should be a no-brainer Alpha blocker
but I can't remember if kvm counts.

Comment 3 Jens Petersen 2015-02-19 02:21:20 UTC
(Maybe this is also the reason I can't get net working in F22 boot.iso
or in fresh F22 install under kvm.)

Comment 4 Jens Petersen 2015-02-19 02:28:07 UTC
The dmesg diff doesn't seem to contain anything useful.
Maybe journalctl output diff would be better?

Comment 5 Jens Petersen 2015-02-19 03:46:47 UTC
Eric Paris pointed out on #fedora-devel that kernel-3.20.0-0.rc0.git9.1.fc22
seems to fix this.

and git9.1 is working okay for me.

Comment 6 Orion Poplawski 2015-02-19 16:13:41 UTC
Confirmed fixed for me.


Note You need to log in before you can comment on or make changes to this bug.