Bug 119406 - GDMsetup asks root passwd, then doesn't launch
GDMsetup asks root passwd, then doesn't launch
Status: CLOSED DUPLICATE of bug 117499
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Depends On:
  Show dependency treegraph
Reported: 2004-03-30 01:34 EST by Benjamin Thompson
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:02:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Benjamin Thompson 2004-03-30 01:34:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
I have tried launching "Login Screen," or gdmsetup, from the menus via
GNOME as well as KDE and through Konsole. The prompt for the root
password appears every time, I put the password in every time, and the
prompt disappears and the app never launches--every time.

When I try launching via konsole, the following is shown in the
konsole after inputting the root password in the aforementioned query
Could not set exec context to user_u:sysadm_r:sysadm_t.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Boot FC2/t2 into KDE or GNOME with non-root user.
2. Launch gdmsetup through {main menu->system settings->login screen}
or via an xterm
3. Provide root password, hit OK.

Actual Results:  gdmsetup simply will not launch. If launched from
konsole, the error: "Could not set exec context to
user_u:sysadm_r:sysadm_t." is produced.

Expected Results:  gdmsetup ought to have launched normally. There
were no strange settings in my install that should have produced this.
Comment 1 Eugenia Loli-Queru 2004-03-30 02:26:51 EST
I concur. This happens here too. I can't load "Services" or "User and 
Groups" or *anything else* that requires authentication. It gives me 
the same stuff Ben said:
Could not set exec context to user_u:sysadm_r:sysadm_t.

When logged in as "root" it works fine, but when logged in 
as "eugenia" it just bails out.

Please note that this is an "Everything" installation, I installed 
all packages. I thought I will say this here just in case it has 
something to do with the problem (however my gut feeling says that it 
has something to do with SELinux).
Comment 2 Eugenia Loli-Queru 2004-03-30 02:54:05 EST
Please note that this is *not* a GDMSetup bug, it happens on ALL pref 
panels that require authentication. See bug #117499 too.
Comment 3 schiebe 2004-03-30 08:07:05 EST
The same here:
I think thats a problem with SELinux?! 
Comment 4 Bill Nottingham 2004-03-30 11:42:24 EST

*** This bug has been marked as a duplicate of 117499 ***
Comment 5 Walter Buehler 2004-08-12 04:15:17 EDT
I had this problem on a linux-ppc. I changed the su and gdmsetup 
files in /etc/pam.d/ and it worked at least for su. I'm still 
muddling with the gdmsetup entries there, but I suppose the problem 
is pam, not selinux. 
Comment 6 Red Hat Bugzilla 2006-02-21 14:02:14 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.