Bug 1194141 - AFR : failure in self-heald.t
Summary: AFR : failure in self-heald.t
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: replicate
Version: 3.6.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anuradha
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: glusterfs-3.6.3
TreeView+ depends on / blocked
 
Reported: 2015-02-19 05:59 UTC by Anuradha
Modified: 2016-09-20 02:00 UTC (History)
3 users (show)

Fixed In Version: glusterfs-v3.6.3
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-02-04 15:20:08 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Anuradha 2015-02-19 05:59:39 UTC
Description of problem:
testcase self-heald.t fails due to wrong calculation expression.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Anand Avati 2015-02-19 06:36:18 UTC
REVIEW: http://review.gluster.org/9692 (afr : Fix bad shell calculation in tests/basiv/afr/self-heald.t) posted (#1) for review on release-3.6 by Anuradha Talur (atalur@redhat.com)

Comment 2 Anand Avati 2015-02-19 06:37:27 UTC
REVIEW: http://review.gluster.org/9692 (afr : Fix bad shell calculation in tests/basiv/afr/self-heald.t) posted (#2) for review on release-3.6 by Anuradha Talur (atalur@redhat.com)

Comment 3 Anand Avati 2015-02-19 11:31:54 UTC
REVIEW: http://review.gluster.org/9692 (afr : Fix bad shell calculation in tests/basiv/afr/self-heald.t) posted (#3) for review on release-3.6 by Anuradha Talur (atalur@redhat.com)

Comment 4 Anand Avati 2015-03-04 11:58:10 UTC
REVIEW: http://review.gluster.org/9692 (afr : Fix bad shell calculation in tests/basic/afr/self-heald.t) posted (#4) for review on release-3.6 by Anuradha Talur (atalur@redhat.com)

Comment 5 Anand Avati 2015-03-13 18:25:44 UTC
REVIEW: http://review.gluster.org/9692 (afr : Fix bad shell calculation in tests/basic/afr/self-heald.t) posted (#5) for review on release-3.6 by Anuradha Talur (atalur@redhat.com)

Comment 6 Anand Avati 2015-03-14 10:14:32 UTC
COMMIT: http://review.gluster.org/9692 committed in release-3.6 by Raghavendra Bhat (raghavendra@redhat.com) 
------
commit c5f344e4c3724cd08d3a3f48084ef5da504f6628
Author: Emmanuel Dreyfus <manu@netbsd.org>
Date:   Thu Jan 8 06:22:17 2015 +0100

    afr : Fix bad shell calculation in tests/basic/afr/self-heald.t
    
            Backport of: http://review.gluster.org/#/c/9414/
    
    Original fix sent by Emmanuel Dreyfus.
    
    Change-Id: If086dd55849cf42eefc2a62ce5b994975357e38f
    BUG: 1194141
    Signed-off-by: Emmanuel Dreyfus <manu@netbsd.org>
    Reviewed-on: http://review.gluster.org/9414
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
    Signed-off-by: Anuradha <atalur@redhat.com>
    Reviewed-on: http://review.gluster.org/9692
    Reviewed-by: Ravishankar N <ravishankar@redhat.com>
    Reviewed-by: Raghavendra Bhat <raghavendra@redhat.com>

Comment 7 Kaushal 2016-02-04 15:20:08 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-v3.6.3, please open a new bug report.

glusterfs-v3.6.3 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2015-April/021669.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.