Bug 1194158 - libguestfs-tools-c depends on perl
Summary: libguestfs-tools-c depends on perl
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Virtualization Tools
Classification: Community
Component: libguestfs
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Richard W.M. Jones
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-19 08:32 UTC by Richard W.M. Jones
Modified: 2015-03-02 13:19 UTC (History)
2 users (show)

Fixed In Version: libguestfs-1.29.26-4.fc23
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-02 13:19:41 UTC


Attachments (Terms of Use)

Description Richard W.M. Jones 2015-02-19 08:32:30 UTC
Description of problem:

libguestfs-tools-c isn't supposed to depend on heavyweight
interpreters like Perl.

Unfortunately it does at the moment.  The main reason for this
appears to be 'icoutils'.

See also bug 761565, bug 1071675.

Version-Release number of selected component (if applicable):

libguestfs 1.29.26

How reproducible:

100%

Steps to Reproduce:
1. yum install libguestfs-tools-c

Actual results:

Note that Perl is pulled in, in particular 'perl-Business-ISBN'
(a dependency of perl-URI).

Comment 1 Richard W.M. Jones 2015-03-02 13:19:41 UTC
It turns out to be necessary to adjust both hivex and libguestfs.

The hivex change is to move hivexregedit into the perl-hivex
subpackage:
http://pkgs.fedoraproject.org/cgit/hivex.git/commit/

The libguestfs change is fairly complex:
http://pkgs.fedoraproject.org/cgit/libguestfs.git/commit/


Note You need to log in before you can comment on or make changes to this bug.