Bug 119418 - cups lpstat reports no timestamp after European daylight time change
Summary: cups lpstat reports no timestamp after European daylight time change
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: cups   
(Show other bugs)
Version: 3.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 116727
TreeView+ depends on / blocked
 
Reported: 2004-03-30 08:39 UTC by Alois Treindl
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-18 02:54:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cups-1.1.19-lpstat.patch (461 bytes, patch)
2004-03-30 11:46 UTC, Tim Waugh
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2004:228 normal SHIPPED_LIVE Updated CUPS packages fix several bugs 2004-09-01 04:00:00 UTC

Description Alois Treindl 2004-03-30 08:39:21 UTC
Description of problem:
lpstat command reports no date/time for jobs in the queue

Last Sunday (28 March) there was a daylight time begin in Europe.
Since then, my cups print queues fail to show timestamps for queued
jobs, when I list them with lpstat -o

Before the time zone change, the listing was correct.

I have no TZ environment variable set on RHEL 3.
The 'date' command works correct, it shows (just now)
Tue Mar 30 10:35:32 CEST 22004

I have also looked into the source code of cups::lpstat.c and see that
it uses 
jobdate = localtime(&jobtime);
strftime(date, sizeof(date), CUPS_STRFTIME_FORMAT, jobdate);
where CUPS_STRFTIME_FORMAT = "%c"

I wrote a little C sample program, making just the same calls
with current time, and get correct output
strftime Tue Mar 30 10:35:36 2004

I assume if I would recompile cups1.1.20 and replace the installed
redhat version with it, it would work again - I have not tried that
as I would prefer to stick with the redhat supported version of cups.



Version-Release number of selected component (if applicable):
cups-1.1.17-13.3.6


How reproducible:
always, on RHEL 3.0 and also on my home desktop, Redhat Linux 9 with
cups-1.1.17-13.3.0.3


Steps to Reproduce:
1. run a Redhat system in Central european time
2. submit jobs to a cups queue, with the queue disabled
3. list the jobs with lpstat -o
  
Actual results:
no timestamp is printed, some random characters appears instead.


Expected results:
a proper date/time for the job submission

Additional info:
After observing the problem, I tried restarting cupsd, and also
rebooting RHEL. It does not help.

The lsiting of job queues with the cups web interface shows correct
job timestamps. The problem is only with 'lpstat'

Comment 1 Alois Treindl 2004-03-30 08:46:31 UTC
PS: in /etc/syconfig/clock I have
ZONE="Europe/Zurich"
UTC=false
ARC=false


Comment 2 Tim Waugh 2004-03-30 11:10:11 UTC
A fix has been applied and I hope to get the updated package in Update 3.

Comment 3 Alois Treindl 2004-03-30 11:14:29 UTC
Good to hear.
Would you mind letting me know what the problem was, and what the fix
does?

Comment 4 Tim Waugh 2004-03-30 11:46:40 UTC
Created attachment 98959 [details]
cups-1.1.19-lpstat.patch

Here is the fix.

Comment 5 Jay Turner 2004-08-18 02:54:03 UTC
Fix confirmed with cups-1.1.17-13.3.12.  Closing out.

Comment 6 Jay Turner 2004-09-02 02:10:56 UTC
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-228.html



Note You need to log in before you can comment on or make changes to this bug.