Bug 11942 - Problems with transparent proxies
Summary: Problems with transparent proxies
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-06-07 09:17 UTC by h0e
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-07 09:17:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2000:138 high SHIPPED_LIVE New, enhanced Update Agent for Red Hat Linux 6.x, 7.0 available 2000-12-21 05:00:00 UTC

Description h0e 2000-06-07 09:17:44 UTC
When up2date is configured not to use proxies, but port 80 traffic is
transparently sent through a proxy at the isp, bad things can happen,
because up2date doesn't specify in the http traffic what host the request
is for (unless configured to use a manual proxy), and transparent proxies
(like my isp's) can think the request is for themselves, and will return a
404 not found error. Perhaps up2date should, instead of sending a "POST
/cgi-bin/server.cgi HTTP/1.0" request, send a "POST
http://priority.redhat.com/cgi-bin/server.cgi HTTP/1.0" (for example)
whether it is configured to use proxies or not?

Comment 1 Preston Brown 2000-11-27 21:01:59 UTC
the update agent from7.0 will shortly be released for 6.x, and it includes this
feature.

Comment 2 Jay Turner 2001-03-01 13:09:09 UTC
Up2date is now sending the following to the server:

"POST https://www.rhns.redhat.com/XMLRPC HTTP/1.0"

So that should take care of the problems related in this posting.

Closing out this issue.


Note You need to log in before you can comment on or make changes to this bug.