Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1194227 - RHEL7 Custom Plymouth theme
Summary: RHEL7 Custom Plymouth theme
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: plymouth
Version: 7.0
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Ray Strode [halfline]
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 1133060
TreeView+ depends on / blocked
 
Reported: 2015-02-19 11:24 UTC by jigar
Modified: 2019-08-15 04:16 UTC (History)
3 users (show)

Fixed In Version: plymouth-0.8.9-0.14.20140113.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-19 12:49:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2405 0 normal SHIPPED_LIVE plymouth bug fix and enhancement update 2015-11-19 11:13:25 UTC

Description jigar 2015-02-19 11:24:28 UTC
Description of problem: Unable to configure plymouth theme with custom logo. Steps given in the documentation below are followed: 

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/7/html/Desktop_Migration_and_Administration_Guide/plymouth.html


Version-Release number of selected component (if applicable):


How reproducible: Always


Steps to Reproduce:
1) cd /usr/share/plymouth/themes/

2) cp -Rvp charge/ test/

3) mv -v /usr/share/plymouth/themes/test/charge.plymouth /usr/share/plymouth/themes/test/test.plymouth

4) vim test.plymouth

[Plymouth Theme]
Name=Test
Description=A theme that features a spinner and subtle watermark.  The Red Hat Enterprise Linux default theme.
ModuleName=two-step

[two-step]
ImageDir=/usr/share/plymouth/themes/test
HorizontalAlignment=.5
VerticalAlignment=.75
WatermarkHorizontalAlignment=1.0
WatermarkVerticalAlignment=0.0
Transition=none
TransitionDuration=0.0
BackgroundStartColor=0x2e3436
BackgroundEndColor=0x2e3436


5) cp -vp /usr/share/pixmaps/fedora-gdm-logo.png /usr/share/plymouth/themes/test/logo.png

6) plymouth-set-default-theme --list

charge
details
test
text

7) plymouth-set-default-theme test

8) dracut -f

Actual results: Custom logo couldn't be set


Expected results: Plymouth should show custom logo

Additional Info: In step 5, logo.png should be header-image.png ( it is a bug in the documentation), still the custom logo couldn't se set.

Comment 4 Ladislav Kolacek 2015-05-07 12:38:31 UTC
Problem still persists in RHEL 7.1 

Adding versions of components: 
kernel-3.10.0-229.el7.x86_64
plymouth-0.8.9-0.13.20140113.el7.x86_64
gnome-shell-3.14.2-3.el7.x86_64

Comment 10 errata-xmlrpc 2015-11-19 12:49:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2405.html


Note You need to log in before you can comment on or make changes to this bug.