Bug 119423 - NFS oopses
NFS oopses
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Steve Dickson
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-30 07:21 EST by Neal Becker
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-07 14:18:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Neal Becker 2004-03-30 07:21:24 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.2; Linux) (KHTML, like Gecko)

Description of problem:
Mar 30 07:12:33 rpppc1 rpc.mountd: export request from 10.32.91.21
Mar 30 07:12:33 rpppc1 rpc.mountd: export request from 10.32.91.21
Mar 30 07:12:33 rpppc1 rpc.mountd: authenticated mount request from vlsisun21.md.hnsnet:764 for / (/)
Mar 30 07:14:35 rpppc1 rpc.mountd: authenticated mount request from adgcluster2.adg.labs.md.hnsnet:613 for /disk1/nbecker/FC2-test2-binary-i386 (/)
Mar 30 07:15:15 rpppc1 rpc.mountd: authenticated mount request from adgcluster2.adg.labs.md.hnsnet:615 for /disk1/nbecker/FC2-test2-binary-i386 (/)
Mar 30 07:19:30 rpppc1 kernel: Unable to handle kernel NULL pointer dereference at virtual address 00000000
Mar 30 07:19:30 rpppc1 kernel:  printing eip:
Mar 30 07:19:30 rpppc1 kernel: 0214f7ff
Mar 30 07:19:30 rpppc1 kernel: *pde = 00000000
Mar 30 07:19:30 rpppc1 kernel: Oops: 0000 [#1]
Mar 30 07:19:30 rpppc1 kernel: CPU:    0
Mar 30 07:19:30 rpppc1 kernel: EIP:    0060:[<0214f7ff>]    Not tainted
Mar 30 07:19:30 rpppc1 kernel: EFLAGS: 00010283   (2.6.4-1.281) 
Mar 30 07:19:30 rpppc1 kernel: EIP is at page_address+0x6/0x148
Mar 30 07:19:30 rpppc1 kernel: eax: 00000000   ebx: 00000000   ecx: 00000000   edx: 00000005
Mar 30 07:19:30 rpppc1 kernel: esi: 00000000   edi: 00000000   ebp: 00000000   esp: 35878e64
Mar 30 07:19:30 rpppc1 kernel: ds: 007b   es: 007b   ss: 0068
Mar 30 07:19:30 rpppc1 kernel: Process nfsd (pid: 2115, threadinfo=35878000 task=3586e6c0)
Mar 30 07:19:30 rpppc1 kernel: Stack: 00000000 00000008 00000000 00000000 02273940 27c5d308 35879000 00001000 
Mar 30 07:19:30 rpppc1 kernel:        00000000 00000000 35878e7c 00000001 00000000 00000000 00008000 00000000 
Mar 30 07:19:30 rpppc1 kernel:        00000000 289ee104 00000000 00000008 02297bf5 00000008 00000000 00000000 
Mar 30 07:19:30 rpppc1 kernel: Call Trace:
Mar 30 07:19:30 rpppc1 kernel:  [<02273940>] sock_no_sendpage+0x19/0x90
Mar 30 07:19:30 rpppc1 kernel:  [<02297bf5>] tcp_sendpage+0x31/0x5e
Mar 30 07:19:30 rpppc1 kernel:  [<4543f2f8>] svc_sendto+0x150/0x20e [sunrpc]
Mar 30 07:19:30 rpppc1 kernel:  [<4544017b>] svc_tcp_sendto+0x3f/0x85 [sunrpc]
Mar 30 07:19:30 rpppc1 kernel:  [<45440bd6>] svc_send+0xb3/0xe0 [sunrpc]
Mar 30 07:19:30 rpppc1 kernel:  [<4546392a>] nfs3svc_release_fhandle+0x0/0xe [nfsd]
Mar 30 07:19:30 rpppc1 kernel:  [<4543e7a8>] svc_process+0x37e/0x55e [sunrpc]
Mar 30 07:19:30 rpppc1 kernel:  [<45456683>] nfsd+0x3ae/0x68c [nfsd]
Mar 30 07:19:30 rpppc1 kernel:  [<454562d5>] nfsd+0x0/0x68c [nfsd]
Mar 30 07:19:30 rpppc1 kernel:  [<021071d9>] kernel_thread_helper+0x5/0xb
Mar 30 07:19:30 rpppc1 kernel: 
Mar 30 07:19:30 rpppc1 kernel: Code: 8b 00 f6 c4 01 75 25 2b 35 0c 15 3c 02 c1 fe 03 69 f6 cd cc 


Version-Release number of selected component (if applicable):
2.6.4-1.281

How reproducible:
Didn't try

Steps to Reproduce:
1. tried to nfs mount from this server
2.
3.
    

Additional info:
Comment 1 Neal Becker 2004-03-30 08:16:56 EST
This problem may have been fixed by removing overlapping exports. 
 
This seems to have caused the problem: 
/  139.85.0.0/16(rw,async) *.hns.com(rw,async) 10.100.20.0/16
(rw,async) *.adg.labs.md.hnsnet(rw,async) 10.100.21.0/8(rw,async) 
 
Changing the last /8 to /16 has possibly fixed it. 
Comment 2 Dave Jones 2004-12-07 00:29:48 EST
it still shouldn't have oopsed.  Can you reproduce this with a current 2.6.9
based errata kernel ?
Comment 3 Steve Dickson 2005-03-14 09:40:43 EST
Unable to reproduce this in more 
recent kernels. Changing state to Modified.
Comment 4 Matthew Miller 2006-07-07 14:18:05 EDT
Changing to "worksforme" as per comment #3.

Note You need to log in before you can comment on or make changes to this bug.