Bug 1194254 - Review Request: libOnix - A text based "graphics" library.
Summary: Review Request: libOnix - A text based "graphics" library.
Keywords:
Status: CLOSED INSUFFICIENT_DATA
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nobody's working on this, feel free to take it
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: NotReady
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-19 12:17 UTC by James Read
Modified: 2015-08-17 16:48 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-17 16:48:32 UTC
Type: ---


Attachments (Terms of Use)

Description James Read 2015-02-19 12:17:32 UTC
Spec URL: http://tydus.net/libOnix/rpm-fedora.spec
SRPM URL: http://tydus.net/libOnix/libOnix-1.0.0-1.fc21.src.rpm
Description: A text based "graphics" library. 
Fedora Account System Username: jread

Comment 1 James Read 2015-02-19 12:18:43 UTC
Note: Even though I'm a Red Hatter, this is an personal project.

Comment 2 Michael Schwendt 2015-03-11 12:09:33 UTC
A strange one so far. :-/


> %files
> %doc /usr/share/doc/libonix/README.md
> %{_libdir}/libonix.so

There is just the lib, no API yet!


> rpm-fedora.spec

https://fedoraproject.org/wiki/Packaging:NamingGuidelines#Spec_file_name

Even if it only says "should" there, be nice and adhere to such guidelines.


> Source0:	libOnix-%{version}-src.zip

https://fedoraproject.org/wiki/Packaging:SourceURL


> License:	GPLv2

Nothing at all in the source tarballs refers to the licensing.


> %build
> cmake .

http://fedoraproject.org/wiki/Packaging:Cmake


> $ rpm -qp --provides libOnix-1.0.0-1.fc21.x86_64.rpm|grep ^lib
> libOnix = 1.0.0-1.fc21
> libOnix(x86-64) = 1.0.0-1.fc21
> libonix.so()(64bit)

An unversioned SONAME. If anything used this lib already, the automatic dependency would be very weak.

Comment 3 Michael Schwendt 2015-03-11 12:12:22 UTC
Oh, and you're not in the packager group.

Please spend a few minutes on the documentation at the bottom of

  https://fedoraproject.org/wiki/Category:Package_Maintainers

especially the various HOWTOs that should be most interesting to you.

Comment 4 Michael Schwendt 2015-08-17 16:48:32 UTC
Given all the reoccurring fuss on devel@ list about the FE-NEEDSPONSOR queue, I consider it an insult that there hasn't been any response to my comments since 2015-03-11.

Closing and removing from the queue.


Note You need to log in before you can comment on or make changes to this bug.