Bug 119427 - floppy disk configuration key
floppy disk configuration key
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-30 07:58 EST by john Walsh
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-06 17:59:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description john Walsh 2004-03-30 07:58:39 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.2)
Gecko/20040308

Description of problem:
For those of us who never install/upgrade over a working system
(I use a second OS disk for a new installation, and have a seperate
data (/home) disk too), or who have had a disk crash :-

how about an option to save/restore the basic installation options
selected onto a floppy - such that when I do my next install, I can
click an option in Anaconda 'load config from floppy', and that will
contain all the basic selections I made last time, so I don't need
to go through the RPM list again (this take ages and mistakes can
easilly be made).

To create the config file (eg. anaconda_install.conf), first you
would need to save the config options (keyboard, time zone,
language, screen options...) from within the Anaconda installation
(at the end, like making the rescue boot floppy, or maybe it should
be kept in /etc ?).

Then you could also have a run-time application (or simple script)
that updates the list of RPM's installed - as a user may have
changed this since the original installation.

All this can be done to a local file, and then the user can copy
it to a floppy, ready for the next time they install.

In the next installation, at the start, there could be an option
to read the config file from the floppy... thus avoiding having
to spend a lot of time going through the exact configuration you
want (especially RPM's).

Of course, you should still go through all the config screens, but
the last config you used should be pre-selected...

If RPM's have changed, you could highlight them.

I currently have 720 RPM's installed, and having to go through
the list of all of them is a real pain, and then when the OS is
installed, double checking the list against my old list is another
real pain.

I really hope you can see the benefits of this for installing,
and what if someone is doing multiple machines, like in a lab ?

Thanks,
John.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install a new system


Actual Results:  I'm very fustrated

Expected Results:  I should have been relaxed and happy

Additional info:
Comment 1 Bill Nottingham 2004-03-30 16:21:14 EST
/root/anaconda-ks.cfg?
Comment 2 Jeremy Katz 2004-03-30 18:27:20 EST
Yes, this is the intended use of /root/anaconda-ks.cfg
Comment 3 john Walsh 2004-03-31 03:47:21 EST
OK, I see that now.

How whould I have known this, other than through this bug report ?

Could you add a screen/info in the install process to tell people
about this feature (maybe just a one liner, with a URL reference).

Thanks,
John.
Comment 4 john Walsh 2004-04-22 13:52:55 EDT
I have a complaint about kickstart / the install CD's for FC1.0:

After the help you gave me, I thought I try and take a look at
kickstart to get a feel for what it would do for my next installation.

So I made the kickstart file, coppied it to a floppy, and re-booted
from the FC1.0 ISO CD 1.

Into the install process I went, so through the option screens I went
to see what was pre-selected...

I got to the end of the option screen, to the one: we are ready to
install, if you continue your disks will be formatted...

but I exited the install process, ie. I did not do the install, I'd
just looked through the options.

But, on re-booting the machine, what did I find ?

The partition tables had been re-written and a new boot loader
installed.

Which ment that my machine was f**k'd (sorry for the language).

So my point is - I thought I was safe in going through the install
options pages, as long as I did not proceed with the installation,
but this was not the case.

Whatever options have been selected, either directly or through
kickstart - it should not have written to the disks until I went
through into the actual install process.

I hope you can change this.

Thanks,
John.

Note You need to log in before you can comment on or make changes to this bug.