Bug 119428 - (NFSD)nfs mounts hang forever
(NFSD)nfs mounts hang forever
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Steve Dickson
Brian Brock
:
Depends On:
Blocks: FC2Blocker FC3Target FC4Target
  Show dependency treegraph
 
Reported: 2004-03-30 08:09 EST by Neal Becker
Modified: 2014-01-21 17:49 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-07 11:11:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Neal Becker 2004-03-30 08:09:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.2; Linux) (KHTML, like Gecko)

Description of problem:
nfs mounts from this kernel's nfsd just hang forever.
cat /etc/exports
/  139.85.0.0/16(rw,async) *.hns.com(rw,async) 10.100.20.0/16(rw,async) *.adg.labs.md.hnsnet(rw,async) 10.100.21.0/16(rw,async)

No error messages, just hang.
In fact, no message at all, not even normal "mount request...".

Here is an example, I'm telnetting to a client which should automount my home (I've been using this same setup forever, there is nothing new except the nfs server kernel):
Red Hat Enterprise Linux WS release 3 (Taroon Update 1)
Kernel 2.4.21-9.0.1.ELsmp on an i686
login: nbecker
Password:

[... still hung forever..., no message at all on server log...]

Version-Release number of selected component (if applicable):
2.6.4-1.281

How reproducible:
Always

Steps to Reproduce:
1. attempt to mount
2.
3.
    

Additional info:
Comment 1 Neal Becker 2004-03-30 14:48:55 EST
Workaround: 
 
If I remove all overlapping entries from /etc/exports the problem is 
gone.  That is, in my previous exports, I had both IP address ranges 
and names that mapped to the same IPs.  I got rid of the names and 
kept only IP ranges, and now it's OK. 
 
IMHO, this fix is totally unacceptable.  It should work with this 
workaround. 
 
Comment 2 Seth Vidal 2004-05-07 12:16:52 EDT
Talk to the nfs-utils maintainer upstream. Parsing of the exports file
is kinda dicey.
Comment 3 Steve Dickson 2004-11-29 06:05:48 EST
would it be possible to post a AltSysRq-t backtrace of all the
the processes which would help tell me where the nfsds are hanging. 
Comment 4 Dave Jones 2004-12-07 01:33:56 EST
this still a problem with the 2.6.9 kernel ?
Comment 5 Neal Becker 2004-12-07 07:24:00 EST
No problem now. 

Note You need to log in before you can comment on or make changes to this bug.