Bug 11943 - libGLw is missing
libGLw is missing
Status: CLOSED RAWHIDE
Product: Red Hat Powertools
Classification: Retired
Component: glxMesa (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-07 08:22 EDT by Dimitri Papadopoulos
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-14 05:02:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dimitri Papadopoulos 2000-06-07 08:22:41 EDT
Hello,

We are porting our program from Solaris to Linux. We are using libGLw.
We had to compile of own version of libGLw.so using the Mesa source
distribution.

Why is libGLw missing from RedHat distributions? Shouldn't libGLw be
distributed with Mesa or glxMesa? Any license issues?

I've searched for the library in Mesa, Mesa-devel and glxMesa (6.2 and
rawhide). Couldn't find anything... Very few references to GLX (2) and
GLw (0!) on Bugzilla as well. Strange that no one needs this library!

Regards,
Dimitri
Comment 1 Bernhard Rosenkraenzer 2000-06-12 17:11:04 EDT
Sorry for my ignorance, but what is libGLw supposed to do?
Mesa by default only has GL, GLU and glut.
My first guess is that libGLw is not part of the OpenGL standard?
Comment 2 Dimitri Papadopoulos 2000-06-14 06:52:17 EDT
The libGLw library contains GL widgets:
- Xt widgets
  	<X11/GLw/GLwDrawA.h>
  	GLwDrawingAreaWidget
  	...
- Motif widgets
  	<X11/GLw/GLwMDrawA.h>
  	GLwMDrawingAreaWidget
  	GLwCreateMDrawingArea()
  	...

I think this library is pretty standard. For example, it can be found
on Solaris whether GLUT is not distributed with Solaris. I guess this
library is an extension of GLX. GLX contains basic functions for X11
integration. GLw adds widgets on top of it.

The GLw widgets are described in "OpenGL Programming for the X Window
System" by Mark J. Kilgard et al.:
	http://www2.awl.com/cseng/titles/0-201-48359-9/
See also:
	http://www.sgi.com/software/opengl/glandx/intro/intro.html
	http://www.sgi.com/software/opengl/glandx/xlib/xlib.html
	http://www.sgi.com/software/opengl/glandx/motif/motif.html

Again, GLw seems pretty standard. I don't know whether it is part of
the OpenGL standard, but then I am not sure GLX itself is part of the
OpenGL standard. Well, in fact GLX must be. I had a look at
	http://www.opengl.org/
and found phrases like "X server extension API (GLX)" while GLw is not
referenced on this web site.

Anyway that's not the point. GLw is the standard way of integrating Xt/Motif
with OpenGL and is handy for porting legacy programs from sgi or Solaris to
Linux.

There are two versions of GLw in Mesa 3.2. The "freeware" one and the "sgi"
one. Both are OpenSource. I am using the "sgi" one.
Comment 3 Dimitri Papadopoulos 2000-06-19 05:09:26 EDT
See also Mesa bug report 107534 on Sourceforge:
	http://sourceforge.net/bugs/?func=detailbug&bug_id=107534&group_id=3
about building GLw.
Comment 4 Bernhard Rosenkraenzer 2000-08-02 07:47:14 EDT
Since it requires Motif and we aren't shipping Motif, we can't include it.
Comment 5 Dimitri Papadopoulos 2000-08-07 04:39:58 EDT
It's true you do not distribute Motif right now. But isn't this going to change
with OpenMotif?
Anyway, this is not an issue:
1) One of the widgets does depend on Motif. The other is a plain Xt widget.
2) You do distribute LessTif with the PowerTools. Add GLw to the PowerTools,
    not to the RedHat base distribution.
3) GLw does not require Motif to be built or used, but not to be dsitributed.
    I mean, you may distribute it with OpenGL. It will be used by those who
    have LessTif or Motif.
Comment 6 Bernhard Rosenkraenzer 2000-08-08 07:48:48 EDT
No, OpenMotif isn't open source, so we don't ship it in the distribution.
We're including it in Powertools.

As for GLw, it's too late to add new packages to Powertools for 7.0, but I'll do
it for 7.1.
Comment 7 Mike A. Harris 2001-08-14 06:00:39 EDT
libGLw added to Mesa-3.4.2-5 epoch 3 for XFree86 4.1.0

Note You need to log in before you can comment on or make changes to this bug.