Bug 1194326 - [abrt] firewall-config: firewall-config:3662:onChangeService:AttributeError: 'NoneType' object has no attribute 'getSettings'
Summary: [abrt] firewall-config: firewall-config:3662:onChangeService:AttributeError: ...
Keywords:
Status: CLOSED DUPLICATE of bug 995760
Alias: None
Product: Fedora
Classification: Fedora
Component: firewalld
Version: 21
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:5eda7e8a6ce8bf6a24b0fd7dd51...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-19 14:52 UTC by ssabchew
Modified: 2015-07-27 21:58 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-09 16:15:07 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (555 bytes, text/plain)
2015-02-19 14:52 UTC, ssabchew
no flags Details
File: environ (2.20 KB, text/plain)
2015-02-19 14:53 UTC, ssabchew
no flags Details

Description ssabchew 2015-02-19 14:52:52 UTC
Description of problem:
Editing rules of firewalld wrom UI.

Version-Release number of selected component:
firewall-config-0.3.13-2.fc21

Additional info:
reporter:       libreport-2.3.0
cmdline:        /usr/bin/python -Es /usr/bin/firewall-config
executable:     /usr/bin/firewall-config
kernel:         3.18.5-201.fc21.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
firewall-config:3662:onChangeService:AttributeError: 'NoneType' object has no attribute 'getSettings'

Traceback (most recent call last):
  File "/usr/bin/firewall-config", line 3662, in onChangeService
    settings = service.getSettings()
AttributeError: 'NoneType' object has no attribute 'getSettings'

Local variables in innermost frame:
destination: {}
service: None
active_service: 'gre'
self: <__main__.FirewallConfig object at 0x7f394f61da50>
args: (<TreeSelection object at 0x7f394d24fd20 (GtkTreeSelection at 0x2ab3b00)>,)
modules: []
ports: []

Comment 1 ssabchew 2015-02-19 14:52:58 UTC
Created attachment 993652 [details]
File: backtrace

Comment 2 ssabchew 2015-02-19 14:53:01 UTC
Created attachment 993653 [details]
File: environ

Comment 3 Thomas Woerner 2015-06-09 16:15:07 UTC

*** This bug has been marked as a duplicate of bug 995760 ***


Note You need to log in before you can comment on or make changes to this bug.