Bug 1194352 - Stop truncating backtraces
Summary: Stop truncating backtraces
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Usability
Version: 6.0.8
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Ivan Necas
QA Contact: jcallaha
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-19 15:52 UTC by Jan Pazdziora
Modified: 2019-09-25 21:15 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:48:47 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 10713 None None None 2016-04-22 16:08:54 UTC
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Jan Pazdziora 2015-02-19 15:52:39 UTC
Description of problem:

In the rare case when an error happens in code which is not foreman's, WebUI only shows very few lines of backtrace, even if the problem is in katello or dynflow. The backtrace should not claim it shows "Full trace" if it does not.

Version-Release number of selected component (if applicable):

Satellite 6.0.8

How reproducible:

Deterministic.

Steps to Reproduce:
1. Have situation when application fails in katello.
2. Check the backtrace shown on the "Oops, we're sorry but something went wrong" page.

Actual results:

Just backtrace from foreman, it seems.

Expected results:

Complete backtrace.

Additional info:

Alternatively, the page should point the user to the whole backtrace to be found in /var/log/foreman/production.log.

Comment 1 RHEL Program Management 2015-02-20 00:59:56 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Ivan Necas 2015-06-05 10:12:08 UTC
Created redmine issue http://projects.theforeman.org/issues/10713 from this bug

Comment 4 Ivan Necas 2015-06-05 10:24:02 UTC
Proposed fix https://github.com/theforeman/foreman/pull/2438

Comment 5 Ivan Necas 2015-06-09 15:15:26 UTC
Merged in upstream, will be part of Foreman 1.9

Comment 8 Tazim Kolhar 2016-04-05 04:29:53 UTC
Hi,

   please provide verification steps for :
   1. Have situation when application fails in katello.
   (Can please give example here)
 
   2. Check the backtrace shown on the "Oops, we're sorry but something went    
   wrong" page.

Thanks and Regards,
Tazim

Comment 9 Ivan Necas 2016-04-05 11:21:47 UTC
1. configure the satellite to use external ldap authentication
2. simulate the satellite can't reach the ldap (as simply as upading the /etc/hosts on the machine to use some fake ip for the ldap server
3. try to login

The reqeust should fail, but one should be able to get the backtrace of the error in /var/log/foreman/production.log

Comment 11 jcallaha 2016-04-26 19:24:52 UTC
Verified in Satellite 6.2 Beta Snap 9 Compose 2.

A full backtrace is now provided in the Errors tab of tasks with errors.

Comment 13 errata-xmlrpc 2016-07-27 08:48:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.