Bug 1194397 - authconfig does not pass the password provided by --winbindjoin to net join
Summary: authconfig does not pass the password provided by --winbindjoin to net join
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: authconfig
Version: 6.6
Hardware: Unspecified
OS: Linux
unspecified
high
Target Milestone: rc
: ---
Assignee: Tomas Mraz
QA Contact: Dalibor Pospíšil
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-19 17:45 UTC by Marcel Kolaja
Modified: 2019-05-20 11:31 UTC (History)
7 users (show)

Fixed In Version: authconfig-6.1.12-22.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1225089 (view as bug list)
Environment:
Last Closed: 2015-03-31 07:05:41 UTC


Attachments (Terms of Use)
proposed patch for RHEL 6.6 (712 bytes, patch)
2015-02-19 17:53 UTC, Marcel Kolaja
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0760 normal SHIPPED_LIVE authconfig bug fix update 2015-03-31 11:05:15 UTC

Description Marcel Kolaja 2015-02-19 17:45:26 UTC
Description of problem:
When a password is provided by --winbindjoin, authconfig should pass it when it calls net join. This does not happen and the user is asked for a password.

Version-Release number of selected component (if applicable):
authconfig-6.1.12-19.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. provide a password with --winbindjoin

Actual results:
The user is asked for a password.

Expected results:
The user should not be asked for a password when authconfig calls net join and should the password should be automatically passed to net join.

Additional info:
authconfig-6.1.12-13.el6.x86_64.rpm does not exhibit the issue. This regression has been introduced by the fix of bug #1119797.

Comment 1 Marcel Kolaja 2015-02-19 17:53:13 UTC
Created attachment 993717 [details]
proposed patch for RHEL 6.6

The attached patch fixes the issue.

Comment 12 errata-xmlrpc 2015-03-31 07:05:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0760.html


Note You need to log in before you can comment on or make changes to this bug.