Bug 1194490 - Recent cloud builds fail to boot with kernel panic
Summary: Recent cloud builds fail to boot with kernel panic
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: distribution
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Václav Pavlín
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F22AlphaBlocker
TreeView+ depends on / blocked
 
Reported: 2015-02-20 00:00 UTC by Mike Ruckman
Modified: 2015-03-05 02:53 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-05 02:53:41 UTC


Attachments (Terms of Use)

Description Mike Ruckman 2015-02-20 00:00:51 UTC
Description of problem:
20140219 cloud builds fail to boot. Error reads:

---[ end Kernel panic - not syncing: No working init found. Try passing init= option to kernel. See Linux Documentation/init.txt for guidance.

Version-Release number of selected component (if applicable):
https://kojipkgs.fedoraproject.org//work/tasks/4826/8994826/Fedora-Cloud-Base-20150219-22.x86_64.qcow2

https://kojipkgs.fedoraproject.org//work/tasks/4827/8994827/Fedora-Cloud-Base-20150219-22.i386.qcow2

How reproducible:
Always

Steps to Reproduce:
1. Boot cloud image
2.
3.

Actual results:
Doesn't boot

Expected results:
Instance boots

Additional info:
Tested locally with testCloud as well as OpenStack

Comment 1 Fedora Blocker Bugs Application 2015-02-20 00:02:23 UTC
Proposed as a Blocker for 22-alpha by Fedora user roshi using the blocker tracking app because:

 This violates the "Release blocking images must boot" Alpha criterion: All release-blocking images must boot in their supported configurations.

Comment 2 Josh Boyer 2015-02-20 01:04:40 UTC
The kernel panics if it can't find a userspace init process to start.  This is normally an indication that either the initramfs didn't get loaded or the image compose is broken.  This isn't a kernel problem.

Comment 3 Dan Mossor [danofsatx] 2015-02-23 17:55:44 UTC
Discussed at today's blocker review meeting [1].

AcceptedBlocker Alpha - This violates the "Release blocking images must boot" Alpha criterion: All release-blocking images must boot in their supported configurations.

http://meetbot.fedoraproject.org/fedora-blocker-review/2015-02-23/

Comment 4 kushaldas@gmail.com 2015-03-04 16:32:39 UTC
I can confirm this bug. I am trying with Fedora 22 Alpha TC8 image. It can be downloaded from http://dl.fedoraproject.org/pub/alt/stage/22_Alpha_TC8/Cloud-Images/x86_64/Images/Fedora-Cloud-Base-22_Alpha_TC8-20150302.x86_64.qcow2

The host has 3.18.6-200.fc21.x86_64 kernel.

Comment 5 kushaldas@gmail.com 2015-03-04 17:13:17 UTC
Updated the host system with 3.18.7-200.fc21.x86_64 and after a reboot, the same TC8 image worked well. Strange!!!

Comment 6 Mike Ruckman 2015-03-04 18:07:35 UTC
Things seem to be resolved for the local boots with TC8 - but waiting to close this until we can determine what's causing images to not work on Openstack.

Comment 7 Mike Ruckman 2015-03-05 02:53:41 UTC
Images boot fine locally and in EC2. The openstack issue I was seeing seems to be caused by the host infra cloud runs. Our images are v3 qcow2 and qemu on el6 doesn't support v2 qcow images (which is what fed-cloud02 is running). Closing.


Note You need to log in before you can comment on or make changes to this bug.