Bug 11945 - Kickstart install reports "Exception Occured" when using --onpart option
Kickstart install reports "Exception Occured" when using --onpart option
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-07 09:33 EDT by Marc Schmitt
Modified: 2007-04-18 12:27 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-09 17:21:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Marc Schmitt 2000-06-07 09:33:36 EDT
We install PCs with RedHat 6.2. Kickstart works fine for blank harddrives.
On a multiboot system with a 4GB IDE drive , the following partitions
exist:

Primary DOS partition (FAT-16), size 300MB
Extended DOS partition (FAT-16), size 500MB
Primary QNY partition (XOSL dedicated partition), size 7MB
Primary Linux partition (ext2fs), size 3300MB

I set up the following partition information in ks.cfg:

clearpart --linux
part / --size 200 --onpart hda4
part swap --size 256 --onpart hda4
part /var --size 500 --onpart hda4
part /tmp --size 500 --onpart hda4
part /.afs_cache --size 100 --onpart hda4
part /usr --size 1000 --onpart hda4
part /local --size 100 --grow --maxsize 100000 --onpart hda4

I added the --onpart option because the kickstart installation stopped at
the partitioning/mounting point screen, allthough clearpart --linux was
given.

With --onpart, the kickstart install abandons with an exception message,
saying:

Traceback (innermost last):
  File "/usr/bin/anaconda", line
341, in ?
    extraModules = extraModules)
  File "usr/lib/anaconda/todo.py",
line 332, in __init__
    self.setClass(instClass)
  File "/usr/lib/anaconda/todo.py",
line 822, in setClass
    todo.addMount(dev, mntpoint,
fstype, reformat)
  File "/usr/lib/anaconda/todo.py"
line 395, in addMount
    self.mounts[location] = (device,
fsystem, reformat)
AttributeError: mounts


I used the updated boot floppy (bootnet-20000407.img). It seems --onpart is
not fully implemented yet.
Comment 1 Brock Organ 2000-06-09 17:21:19 EDT
a quick note about your use of --onpart above: --onpart does not create new
partitions, it applies to existing partitions at the time of install, and as
such may conflict with the "clearpart --linux" (if one of the partitions you
wanted to "use" via the onpart command was ext2)...

secondly, each onpart clause above uses hda4 as the destination drive, in effect
saying that you wanted /, swap, /var, /tmp, /.afs_cache, /usr, /local all on
/dev/hda4, was that what you intended?

Perhaps something like this helps: (?)

clearpart --linux
part / --size 200 
part swap --size 256 
part /var --size 500 
part /tmp --size 500 
part /.afs_cache --size 100 
part /usr --size 1000 
part /local --size 100 --grow --maxsize 100000 


Note You need to log in before you can comment on or make changes to this bug.