Bug 1194522 - [abrt] copr-cli: adapters.py:415:send:ConnectionError: ('Connection aborted.', error(110, 'Connection timed out'))
Summary: [abrt] copr-cli: adapters.py:415:send:ConnectionError: ('Connection aborted.'...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: copr-cli
Version: 21
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jakub Kadlčík
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:834f3b7ddb450be626f68059d68...
: 1236379 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-20 02:39 UTC by Mukundan Ragavan
Modified: 2015-07-27 23:10 UTC (History)
3 users (show)

Fixed In Version: python-copr-1.57-1.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-07-21 08:22:29 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (2.03 KB, text/plain)
2015-02-20 02:39 UTC, Mukundan Ragavan
no flags Details
File: dso_list (66 bytes, text/plain)
2015-02-20 02:39 UTC, Mukundan Ragavan
no flags Details
File: environ (2.85 KB, text/plain)
2015-02-20 02:39 UTC, Mukundan Ragavan
no flags Details

Description Mukundan Ragavan 2015-02-20 02:39:53 UTC
Description of problem:
Tried to build a package on my COPR repo.

copr-cli build xfce411 <package-link>

Version-Release number of selected component:
copr-cli-1.43-1.fc21

Additional info:
reporter:       libreport-2.3.0
cmdline:        /usr/bin/python2 /usr/bin/copr-cli build xfce411 https://nonamedotc.fedorapeople.org/copr/xfce411/Thunar-1.6.5-1.fc23.src.rpm
executable:     /usr/bin/copr-cli
kernel:         3.18.7-200.fc21.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
adapters.py:415:send:ConnectionError: ('Connection aborted.', error(110, 'Connection timed out'))

Traceback (most recent call last):
  File "/usr/bin/copr-cli", line 9, in <module>
    load_entry_point('copr-cli==0.3.0', 'console_scripts', 'copr-cli')()
  File "/usr/lib/python2.7/site-packages/copr_cli/main.py", line 415, in main
    getattr(commands, arg.func)(arg)
  File "/usr/lib/python2.7/site-packages/copr_cli/main.py", line 66, in wrapper
    return func(self, args)
  File "/usr/lib/python2.7/site-packages/copr_cli/main.py", line 175, in action_build
    self._watch_builds(result.builds_list)
  File "/usr/lib/python2.7/site-packages/copr_cli/main.py", line 111, in _watch_builds
    build_details = self.client.get_build_details(build_id)
  File "/usr/lib/python2.7/site-packages/copr/client/client.py", line 228, in get_build_details
    data = self._fetch(url, skip_auth=True)
  File "/usr/lib/python2.7/site-packages/copr/client/client.py", line 167, in _fetch
    **kwargs
  File "/usr/lib/python2.7/site-packages/requests/api.py", line 49, in request
    response = session.request(method=method, url=url, **kwargs)
  File "/usr/lib/python2.7/site-packages/requests/sessions.py", line 461, in request
    resp = self.send(prep, **send_kwargs)
  File "/usr/lib/python2.7/site-packages/requests/sessions.py", line 573, in send
    r = adapter.send(request, **kwargs)
  File "/usr/lib/python2.7/site-packages/requests/adapters.py", line 415, in send
    raise ConnectionError(err, request=request)
ConnectionError: ('Connection aborted.', error(110, 'Connection timed out'))

Local variables in innermost frame:
chunked: False
stream: False
err: ProtocolError('Connection aborted.', error(110, 'Connection timed out'))
url: '/api/coprs/build/78503/'
verify: True
self: <requests.adapters.HTTPAdapter object at 0x7f1f4603e310>
request: <PreparedRequest [GET]>
cert: None
timeout: <requests.packages.urllib3.util.timeout.Timeout object at 0x7f1f45757c50>
proxies: {}
conn: <requests.packages.urllib3.connectionpool.HTTPSConnectionPool object at 0x7f1f457577d0>

Comment 1 Mukundan Ragavan 2015-02-20 02:39:55 UTC
Created attachment 993804 [details]
File: backtrace

Comment 2 Mukundan Ragavan 2015-02-20 02:39:56 UTC
Created attachment 993805 [details]
File: dso_list

Comment 3 Mukundan Ragavan 2015-02-20 02:39:57 UTC
Created attachment 993806 [details]
File: environ

Comment 4 Jakub Kadlčík 2015-06-15 13:57:53 UTC
Hello, thank you for the feedback.
We should definitely print more user-friendly message.

Modified in 845cdb8

Comment 5 Jakub Kadlčík 2015-07-01 16:39:13 UTC
*** Bug 1236379 has been marked as a duplicate of this bug. ***

Comment 6 Fedora Update System 2015-07-02 14:02:39 UTC
python-copr-1.57-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/python-copr-1.57-1.fc22

Comment 7 Fedora Update System 2015-07-02 14:03:54 UTC
python-copr-1.57-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/python-copr-1.57-1.fc21

Comment 8 Fedora Update System 2015-07-02 14:04:51 UTC
python-copr-1.57-1.el7 has been submitted as an update for Fedora EPEL 7.
https://admin.fedoraproject.org/updates/python-copr-1.57-1.el7

Comment 9 Fedora Update System 2015-07-03 18:36:32 UTC
Package python-copr-1.57-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-copr-1.57-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-11043/python-copr-1.57-1.fc22
then log in and leave karma (feedback).

Comment 10 Fedora Update System 2015-07-21 08:22:29 UTC
python-copr-1.57-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2015-07-21 08:23:09 UTC
python-copr-1.57-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2015-07-27 23:10:20 UTC
python-copr-1.57-1.el7 has been pushed to the Fedora EPEL 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.