Bug 1194586 - recurring qpid errors in candlepin logs: org.candlepin.audit.AMQPBusPublisher - Unable to send event
Summary: recurring qpid errors in candlepin logs: org.candlepin.audit.AMQPBusPublisher...
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Candlepin
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Tom McKay
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-20 09:38 UTC by Jan Hutař
Modified: 2019-10-10 09:37 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-11 03:44:46 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jan Hutař 2015-02-20 09:38:58 UTC
Description of problem:
There are recurring qpid errors in candlepin logs: org.candlepin.audit.AMQPBusPublisher - Unable to send event


Version-Release number of selected component (if applicable):
Satellite-6.1.0-RHEL-6-20150217.0-Satellite-x86_64


How reproducible:
always


Steps to Reproduce:
1. Install standalone Satellite
2. Watch Candlepin logs and import or refresh manifest


Actual results:
==> /var/log/candlepin/candlepin.log <==
2015-02-20 10:23:53,845 [=, org=] ERROR org.candlepin.audit.AMQPBusPublisher - Unable to send event: Event [id=null, target=SUBSCRIPTION, type=MODIFIED, time=Fri Feb 20 10:19:58 CET 2015, entity=8aa2a3e44ba4ec4e014ba61b02b60825]
javax.jms.JMSException: Exception when sending message:timed out waiting for completion
	at org.apache.qpid.client.BasicMessageProducer_0_10.sendMessage(BasicMessageProducer_0_10.java:260) ~[qpid-client-0.30.redhat-1.jar:0.30.redhat-1]
	at org.apache.qpid.client.BasicMessageProducer.sendImpl(BasicMessageProducer.java:528) ~[qpid-client-0.30.redhat-1.jar:0.30.redhat-1]
	at org.apache.qpid.client.BasicMessageProducer.send(BasicMessageProducer.java:326) ~[qpid-client-0.30.redhat-1.jar:0.30.redhat-1]
	at org.apache.qpid.client.TopicPublisherAdapter.send(TopicPublisherAdapter.java:120) ~[qpid-client-0.30.redhat-1.jar:0.30.redhat-1]
	at org.candlepin.audit.AMQPBusPublisher.onEvent(AMQPBusPublisher.java:60) ~[AMQPBusPublisher.class:na]
	at org.candlepin.audit.ListenerWrapper.onMessage(ListenerWrapper.java:52) [ListenerWrapper.class:na]
	at org.hornetq.core.client.impl.ClientConsumerImpl.callOnMessage(ClientConsumerImpl.java:1114) [hornetq-core-client-2.3.5.Final-redhat-2.jar:2.3.5.Final-redhat-2]
	at org.hornetq.core.client.impl.ClientConsumerImpl.access$500(ClientConsumerImpl.java:57) [hornetq-core-client-2.3.5.Final-redhat-2.jar:2.3.5.Final-redhat-2]
	at org.hornetq.core.client.impl.ClientConsumerImpl$Runner.run(ClientConsumerImpl.java:1249) [hornetq-core-client-2.3.5.Final-redhat-2.jar:2.3.5.Final-redhat-2]
	at org.hornetq.utils.OrderedExecutorFactory$OrderedExecutor$1.run(OrderedExecutorFactory.java:106) [hornetq-core-client-2.3.5.Final-redhat-2.jar:2.3.5.Final-redhat-2]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) [na:1.7.0_75]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [na:1.7.0_75]
	at java.lang.Thread.run(Thread.java:745) [na:1.7.0_75]
Caused by: org.apache.qpid.transport.SessionException: timed out waiting for completion
	at org.apache.qpid.transport.Session.invoke(Session.java:747) ~[qpid-common-0.30.redhat-1.jar:0.30.redhat-1]
	at org.apache.qpid.transport.Session.invoke(Session.java:627) ~[qpid-common-0.30.redhat-1.jar:0.30.redhat-1]
	at org.apache.qpid.transport.SessionInvoker.messageTransfer(SessionInvoker.java:93) ~[qpid-common-0.30.redhat-1.jar:0.30.redhat-1]
	at org.apache.qpid.client.BasicMessageProducer_0_10.sendMessage(BasicMessageProducer_0_10.java:246) ~[qpid-client-0.30.redhat-1.jar:0.30.redhat-1]
	... 12 common frames omitted

==> /var/log/candlepin/error.log <==
2015-02-20 10:23:53,845 [=, org=] ERROR org.candlepin.audit.AMQPBusPublisher - Unable to send event: Event [id=null, target=SUBSCRIPTION, type=MODIFIED, time=Fri Feb 20 10:19:58 CET 2015, entity=8aa2a3e44ba4ec4e014ba61b02b60825]
javax.jms.JMSException: Exception when sending message:timed out waiting for completion
	at org.apache.qpid.client.BasicMessageProducer_0_10.sendMessage(BasicMessageProducer_0_10.java:260) ~[qpid-client-0.30.redhat-1.jar:0.30.redhat-1]
	at org.apache.qpid.client.BasicMessageProducer.sendImpl(BasicMessageProducer.java:528) ~[qpid-client-0.30.redhat-1.jar:0.30.redhat-1]
	at org.apache.qpid.client.BasicMessageProducer.send(BasicMessageProducer.java:326) ~[qpid-client-0.30.redhat-1.jar:0.30.redhat-1]
	at org.apache.qpid.client.TopicPublisherAdapter.send(TopicPublisherAdapter.java:120) ~[qpid-client-0.30.redhat-1.jar:0.30.redhat-1]
	at org.candlepin.audit.AMQPBusPublisher.onEvent(AMQPBusPublisher.java:60) ~[AMQPBusPublisher.class:na]
	at org.candlepin.audit.ListenerWrapper.onMessage(ListenerWrapper.java:52) [ListenerWrapper.class:na]
	at org.hornetq.core.client.impl.ClientConsumerImpl.callOnMessage(ClientConsumerImpl.java:1114) [hornetq-core-client-2.3.5.Final-redhat-2.jar:2.3.5.Final-redhat-2]
	at org.hornetq.core.client.impl.ClientConsumerImpl.access$500(ClientConsumerImpl.java:57) [hornetq-core-client-2.3.5.Final-redhat-2.jar:2.3.5.Final-redhat-2]
	at org.hornetq.core.client.impl.ClientConsumerImpl$Runner.run(ClientConsumerImpl.java:1249) [hornetq-core-client-2.3.5.Final-redhat-2.jar:2.3.5.Final-redhat-2]
	at org.hornetq.utils.OrderedExecutorFactory$OrderedExecutor$1.run(OrderedExecutorFactory.java:106) [hornetq-core-client-2.3.5.Final-redhat-2.jar:2.3.5.Final-redhat-2]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) [na:1.7.0_75]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [na:1.7.0_75]
	at java.lang.Thread.run(Thread.java:745) [na:1.7.0_75]
Caused by: org.apache.qpid.transport.SessionException: timed out waiting for completion
	at org.apache.qpid.transport.Session.invoke(Session.java:747) ~[qpid-common-0.30.redhat-1.jar:0.30.redhat-1]
	at org.apache.qpid.transport.Session.invoke(Session.java:627) ~[qpid-common-0.30.redhat-1.jar:0.30.redhat-1]
	at org.apache.qpid.transport.SessionInvoker.messageTransfer(SessionInvoker.java:93) ~[qpid-common-0.30.redhat-1.jar:0.30.redhat-1]
	at org.apache.qpid.client.BasicMessageProducer_0_10.sendMessage(BasicMessageProducer_0_10.java:246) ~[qpid-client-0.30.redhat-1.jar:0.30.redhat-1]
	... 12 common frames omitted

==> /var/log/tomcat6/catalina.out <==
ERROR [client] - HQ214000: Failed to call onMessage 
java.lang.RuntimeException: Error sending event to message bus
	at org.candlepin.audit.AMQPBusPublisher.onEvent(AMQPBusPublisher.java:69)
	at org.candlepin.audit.ListenerWrapper.onMessage(ListenerWrapper.java:52)
	at org.hornetq.core.client.impl.ClientConsumerImpl.callOnMessage(ClientConsumerImpl.java:1114)
	at org.hornetq.core.client.impl.ClientConsumerImpl.access$500(ClientConsumerImpl.java:57)
	at org.hornetq.core.client.impl.ClientConsumerImpl$Runner.run(ClientConsumerImpl.java:1249)
	at org.hornetq.utils.OrderedExecutorFactory$OrderedExecutor$1.run(OrderedExecutorFactory.java:106)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
	at java.lang.Thread.run(Thread.java:745)
Caused by: javax.jms.JMSException: Exception when sending message:timed out waiting for completion
	at org.apache.qpid.client.BasicMessageProducer_0_10.sendMessage(BasicMessageProducer_0_10.java:260)
	at org.apache.qpid.client.BasicMessageProducer.sendImpl(BasicMessageProducer.java:528)
	at org.apache.qpid.client.BasicMessageProducer.send(BasicMessageProducer.java:326)
	at org.apache.qpid.client.TopicPublisherAdapter.send(TopicPublisherAdapter.java:120)
	at org.candlepin.audit.AMQPBusPublisher.onEvent(AMQPBusPublisher.java:60)
	... 8 more
Caused by: org.apache.qpid.transport.SessionException: timed out waiting for completion
	at org.apache.qpid.transport.Session.invoke(Session.java:747)
	at org.apache.qpid.transport.Session.invoke(Session.java:627)
	at org.apache.qpid.transport.SessionInvoker.messageTransfer(SessionInvoker.java:93)
	at org.apache.qpid.client.BasicMessageProducer_0_10.sendMessage(BasicMessageProducer_0_10.java:246)
	... 12 more

==> /var/log/candlepin/audit.log <==
2015-02-20 10:20:01+0100 principalType=trusteduser principal=admin target=IMPORT entityId=8aa2a3e44ba4ec4e014ba4ef6c190001 type=CREATED owner=8aa2a3e44ba4ec4e014ba4ef6c190001


Expected results:
There should be no errors in the logs

Comment 2 RHEL Program Management 2015-02-20 15:42:13 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 4 mertensb.mazda 2015-10-21 14:51:32 UTC
I notice these same errors since the upgrade I performed today.

Packages Altered:
    Updated candlepin-0.9.49.3-1.el7.noarch                               @rhel-server-7-satellite-6-beta-rpms
    Update            0.9.49.8-1.el7.noarch                               @rhel-7-server-satellite-6.1-rpms
    Updated candlepin-selinux-0.9.49.3-1.el7.noarch                       @rhel-server-7-satellite-6-beta-rpms
    Update                    0.9.49.8-1.el7.noarch                       @rhel-7-server-satellite-6.1-rpms
    Updated candlepin-tomcat-0.9.49.3-1.el7.noarch                        @rhel-server-7-satellite-6-beta-rpms
    Update                   0.9.49.8-1.el7.noarch                        @rhel-7-server-satellite-6.1-rpms
    Updated foreman-1.7.2.33-1.el7sat.noarch                              @rhel-7-server-satellite-6.1-rpms
    Update          1.7.2.43-1.el7sat.noarch                              @rhel-7-server-satellite-6.1-rpms
    Updated foreman-compute-1.7.2.33-1.el7sat.noarch                      @rhel-7-server-satellite-6.1-rpms
    Update                  1.7.2.43-1.el7sat.noarch                      @rhel-7-server-satellite-6.1-rpms
    Updated foreman-debug-1.7.2.33-1.el7sat.noarch                        @rhel-7-server-satellite-6.1-rpms
    Update                1.7.2.43-1.el7sat.noarch                        @rhel-7-server-satellite-6.1-rpms
    Updated foreman-gce-1.7.2.33-1.el7sat.noarch                          @rhel-7-server-satellite-6.1-rpms
    Update              1.7.2.43-1.el7sat.noarch                          @rhel-7-server-satellite-6.1-rpms
    Updated foreman-libvirt-1.7.2.33-1.el7sat.noarch                      @rhel-7-server-satellite-6.1-rpms
    Update                  1.7.2.43-1.el7sat.noarch                      @rhel-7-server-satellite-6.1-rpms
    Updated foreman-ovirt-1.7.2.33-1.el7sat.noarch                        @rhel-7-server-satellite-6.1-rpms
    Update                1.7.2.43-1.el7sat.noarch                        @rhel-7-server-satellite-6.1-rpms
    Updated foreman-postgresql-1.7.2.33-1.el7sat.noarch                   @rhel-7-server-satellite-6.1-rpms
    Update                     1.7.2.43-1.el7sat.noarch                   @rhel-7-server-satellite-6.1-rpms
    Updated foreman-proxy-1.7.2.5-1.el7sat.noarch                         @rhel-server-7-satellite-6-beta-rpms
    Update                1.7.2.6-1.el7sat.noarch                         @rhel-7-server-satellite-6.1-rpms
    Updated foreman-selinux-1.7.2.13-1.el7sat.noarch                      @rhel-server-7-satellite-6-beta-rpms
    Update                  1.7.2.14-1.el7sat.noarch                      @rhel-7-server-satellite-6.1-rpms
    Updated foreman-vmware-1.7.2.33-1.el7sat.noarch                       @rhel-7-server-satellite-6.1-rpms
    Update                 1.7.2.43-1.el7sat.noarch                       @rhel-7-server-satellite-6.1-rpms
    Updated gofer-2.6.2-2.el7sat.noarch                                   @rhel-7-server-satellite-6.1-rpms
    Update        2.6.6-2.el7sat.noarch                                   @rhel-7-server-satellite-6.1-rpms
    Updated katello-2.2.0.14-1.el7sat.noarch                              @rhel-7-server-satellite-6.1-rpms
    Update          2.2.0.16-1.el7sat.noarch                              @rhel-7-server-satellite-6.1-rpms
    Updated katello-common-2.2.0.14-1.el7sat.noarch                       @rhel-7-server-satellite-6.1-rpms
    Update                 2.2.0.16-1.el7sat.noarch                       @rhel-7-server-satellite-6.1-rpms
    Updated katello-debug-2.2.0.14-1.el7sat.noarch                        @rhel-7-server-satellite-6.1-rpms
    Update                2.2.0.16-1.el7sat.noarch                        @rhel-7-server-satellite-6.1-rpms
    Updated katello-installer-2.3.17-1.el7sat.noarch                      @rhel-7-server-satellite-6.1-rpms
    Update                    2.3.20-1.el7sat.noarch                      @rhel-7-server-satellite-6.1-rpms
    Updated katello-installer-base-2.3.17-1.el7sat.noarch                 @rhel-7-server-satellite-6.1-rpms
    Update                         2.3.20-1.el7sat.noarch                 @rhel-7-server-satellite-6.1-rpms
    Updated katello-service-2.2.0.14-1.el7sat.noarch                      @rhel-7-server-satellite-6.1-rpms
    Update                  2.2.0.16-1.el7sat.noarch                      @rhel-7-server-satellite-6.1-rpms
    Updated libqpid-dispatch-0.4-7.el7.x86_64                             @rhel-server-7-satellite-6-beta-rpms
    Update                   0.4-10.el7.x86_64                            @rhel-7-server-satellite-6.1-rpms
    Updated mod_passenger-4.0.18-19.el7sat.x86_64                         @rhel-server-7-satellite-6-beta-rpms
    Update                4.0.18-21.el7sat.x86_64                         @rhel-7-server-satellite-6.1-rpms
    Updated pulp-nodes-common-2.6.0.15-1.el7sat.noarch                    @rhel-7-server-satellite-6.1-rpms
    Update                    2.6.0.16-1.el7sat.noarch                    @rhel-7-server-satellite-6.1-rpms
    Updated pulp-nodes-parent-2.6.0.15-1.el7sat.noarch                    @rhel-7-server-satellite-6.1-rpms
    Update                    2.6.0.16-1.el7sat.noarch                    @rhel-7-server-satellite-6.1-rpms
    Updated pulp-puppet-plugins-2.6.0.15-1.el7sat.noarch                  @rhel-7-server-satellite-6.1-rpms
    Update                      2.6.0.16-1.el7sat.noarch                  @rhel-7-server-satellite-6.1-rpms
    Updated pulp-puppet-tools-2.6.0.15-1.el7sat.noarch                    @rhel-7-server-satellite-6.1-rpms
    Update                    2.6.0.16-1.el7sat.noarch                    @rhel-7-server-satellite-6.1-rpms
    Updated pulp-rpm-handlers-2.6.0.15-1.el7sat.noarch                    @rhel-7-server-satellite-6.1-rpms
    Update                    2.6.0.16-1.el7sat.noarch                    @rhel-7-server-satellite-6.1-rpms
    Updated pulp-rpm-plugins-2.6.0.15-1.el7sat.noarch                     @rhel-7-server-satellite-6.1-rpms
    Update                   2.6.0.16-1.el7sat.noarch                     @rhel-7-server-satellite-6.1-rpms
    Updated pulp-selinux-2.6.0.15-1.el7sat.noarch                         @rhel-7-server-satellite-6.1-rpms
    Update               2.6.0.16-1.el7sat.noarch                         @rhel-7-server-satellite-6.1-rpms
    Updated pulp-server-2.6.0.15-1.el7sat.noarch                          @rhel-7-server-satellite-6.1-rpms
    Update              2.6.0.16-1.el7sat.noarch                          @rhel-7-server-satellite-6.1-rpms
    Updated python-gofer-2.6.2-2.el7sat.noarch                            @rhel-server-7-satellite-6-beta-rpms
    Update               2.6.6-2.el7sat.noarch                            @rhel-7-server-satellite-6.1-rpms
    Updated python-gofer-proton-2.6.2-2.el7sat.noarch                     @rhel-7-server-satellite-6.1-rpms
    Update                      2.6.6-2.el7sat.noarch                     @rhel-7-server-satellite-6.1-rpms
    Updated python-gofer-qpid-2.6.2-2.el7sat.noarch                       @rhel-server-7-satellite-6-beta-rpms
    Update                    2.6.6-2.el7sat.noarch                       @rhel-7-server-satellite-6.1-rpms
    Updated python-nectar-1.3.1-2.el7sat.noarch                           @rhel-server-7-satellite-6-beta-rpms
    Update                1.3.3-2.el7sat.noarch                           @rhel-7-server-satellite-6.1-rpms
    Updated python-pulp-agent-lib-2.6.0.15-1.el7sat.noarch                @rhel-7-server-satellite-6.1-rpms
    Update                        2.6.0.16-1.el7sat.noarch                @rhel-7-server-satellite-6.1-rpms
    Updated python-pulp-bindings-2.6.0.15-1.el7sat.noarch                 @rhel-7-server-satellite-6.1-rpms
    Update                       2.6.0.16-1.el7sat.noarch                 @rhel-7-server-satellite-6.1-rpms
    Updated python-pulp-common-2.6.0.15-1.el7sat.noarch                   @rhel-7-server-satellite-6.1-rpms
    Update                     2.6.0.16-1.el7sat.noarch                   @rhel-7-server-satellite-6.1-rpms
    Updated python-pulp-puppet-common-2.6.0.15-1.el7sat.noarch            @rhel-7-server-satellite-6.1-rpms
    Update                            2.6.0.16-1.el7sat.noarch            @rhel-7-server-satellite-6.1-rpms
    Updated python-pulp-rpm-common-2.6.0.15-1.el7sat.noarch               @rhel-7-server-satellite-6.1-rpms
    Update                         2.6.0.16-1.el7sat.noarch               @rhel-7-server-satellite-6.1-rpms
    Updated python-qpid-proton-0.9-4.el7.x86_64                           @rhel-7-server-satellite-6.1-rpms
    Update                     0.9-7.el7.x86_64                           @rhel-7-server-satellite-6.1-rpms
    Updated qpid-dispatch-router-0.4-7.el7.x86_64                         @rhel-server-7-satellite-6-beta-rpms
    Update                       0.4-10.el7.x86_64                        @rhel-7-server-satellite-6.1-rpms
    Updated qpid-proton-c-0.9-4.el7.x86_64                                @rhel-server-7-satellite-6-beta-rpms
    Update                0.9-7.el7.x86_64                                @rhel-7-server-satellite-6.1-rpms
    Updated ruby193-ruby-1.9.3.484-50.el7.x86_64                          @rhel-server-rhscl-7-rpms
    Update               1.9.3.484-51.el7.x86_64                          @rhel-server-rhscl-7-rpms
    Updated ruby193-ruby-irb-1.9.3.484-50.el7.noarch                      @rhel-server-rhscl-7-rpms
    Update                   1.9.3.484-51.el7.noarch                      @rhel-server-rhscl-7-rpms
    Updated ruby193-ruby-libs-1.9.3.484-50.el7.x86_64                     @rhel-server-rhscl-7-rpms
    Update                    1.9.3.484-51.el7.x86_64                     @rhel-server-rhscl-7-rpms
    Updated ruby193-rubygem-bigdecimal-1.1.0-50.el7.x86_64                @rhel-server-rhscl-7-rpms
    Update                             1.1.0-51.el7.x86_64                @rhel-server-rhscl-7-rpms
    Updated ruby193-rubygem-foreman-redhat_access-0.2.2-1.el7sat.noarch   @/ruby193-rubygem-foreman-redhat_access-0.2.2-1.el7sat.noarch
    Update                                        0.2.3-1.el7sat.noarch   @rhel-7-server-satellite-6.1-rpms
    Updated ruby193-rubygem-foreman-tasks-0.6.15.4-1.el7sat.noarch        @rhel-7-server-satellite-6.1-rpms
    Update                                0.6.15.7-1.el7sat.noarch        @rhel-7-server-satellite-6.1-rpms
    Updated ruby193-rubygem-foreman_docker-1.2.0.18-1.el7sat.noarch       @rhel-7-server-satellite-6.1-rpms
    Update                                 1.2.0.22-1.el7sat.noarch       @rhel-7-server-satellite-6.1-rpms
    Updated ruby193-rubygem-io-console-0.3-50.el7.x86_64                  @rhel-server-rhscl-7-rpms
    Update                             0.3-51.el7.x86_64                  @rhel-server-rhscl-7-rpms
    Updated ruby193-rubygem-json-1.5.5-50.el7.x86_64                      @rhel-server-rhscl-7-rpms
    Update                       1.5.5-51.el7.x86_64                      @rhel-server-rhscl-7-rpms
    Updated ruby193-rubygem-katello-2.2.0.66-1.el7sat.noarch              @/ruby193-rubygem-katello-2.2.0.66-1.el7sat.noarch
    Update                          2.2.0.73-1.el7sat.noarch              @rhel-7-server-satellite-6.1-rpms
    Updated ruby193-rubygem-minitest-2.5.1-50.el7.noarch                  @rhel-server-rhscl-7-rpms
    Update                           2.5.1-51.el7.noarch                  @rhel-server-rhscl-7-rpms
    Updated ruby193-rubygem-passenger-4.0.18-19.el7sat.x86_64             @rhel-server-7-satellite-6-beta-rpms
    Update                            4.0.18-21.el7sat.x86_64             @rhel-7-server-satellite-6.1-rpms
    Updated ruby193-rubygem-passenger-native-4.0.18-19.el7sat.x86_64      @rhel-server-7-satellite-6-beta-rpms
    Update                                   4.0.18-21.el7sat.x86_64      @rhel-7-server-satellite-6.1-rpms
    Updated ruby193-rubygem-passenger-native-libs-4.0.18-19.el7sat.x86_64 @rhel-server-7-satellite-6-beta-rpms
    Update                                        4.0.18-21.el7sat.x86_64 @rhel-7-server-satellite-6.1-rpms
    Updated ruby193-rubygem-rake-0.9.2.2-50.el7.noarch                    @rhel-server-rhscl-7-rpms
    Update                       0.9.2.2-51.el7.noarch                    @rhel-server-rhscl-7-rpms
    Updated ruby193-rubygem-rdoc-3.9.5-50.el7.x86_64                      @rhel-server-rhscl-7-rpms
    Update                       3.9.5-51.el7.x86_64                      @rhel-server-rhscl-7-rpms
    Updated ruby193-rubygems-1.8.23-50.el7.noarch                         @rhel-server-rhscl-7-rpms
    Update                   1.8.23-51.el7.noarch                         @rhel-server-rhscl-7-rpms
    Updated rubygem-hammer_cli-0.1.4.11-1.el7sat.noarch                   @rhel-server-7-satellite-6-beta-rpms
    Update                     0.1.4.13-1.el7sat.noarch                   @rhel-7-server-satellite-6.1-rpms
    Updated rubygem-hammer_cli_import-0.10.19-1.el7sat.noarch             @rhel-7-server-satellite-6.1-rpms
    Update                            0.10.20-1.el7sat.noarch             @rhel-7-server-satellite-6.1-rpms
    Updated rubygem-hammer_cli_katello-0.0.7.17-1.el7sat.noarch           @rhel-7-server-satellite-6.1-rpms
    Update                             0.0.7.18-1.el7sat.noarch           @rhel-7-server-satellite-6.1-rpms
    Updated rubygem-passenger-4.0.18-19.el7sat.x86_64                     @rhel-server-7-satellite-6-beta-rpms
    Update                    4.0.18-21.el7sat.x86_64                     @rhel-7-server-satellite-6.1-rpms
    Updated rubygem-passenger-native-4.0.18-19.el7sat.x86_64              @rhel-server-7-satellite-6-beta-rpms
    Update                           4.0.18-21.el7sat.x86_64              @rhel-7-server-satellite-6.1-rpms
    Updated rubygem-passenger-native-libs-4.0.18-19.el7sat.x86_64         @rhel-server-7-satellite-6-beta-rpms
    Update                                4.0.18-21.el7sat.x86_64         @rhel-7-server-satellite-6.1-rpms
Scriptlet output:
   1 warning: /etc/foreman-proxy/settings.d/dhcp.yml created as /etc/foreman-proxy/settings.d/dhcp.yml.rpmnew


Qpid/candlepin packages installed:
python-qpid-qmf-0.30-5.el7.x86_64
libqpid-dispatch-0.4-10.el7.x86_64
candlepin-scl-1-5.el7.noarch
apvlsat01.mle.mazdaeur.com-qpid-broker-1.0-3.noarch
candlepin-selinux-0.9.49.8-1.el7.noarch
python-qpid-proton-0.9-7.el7.x86_64
qpid-java-client-0.30-3.el7.noarch
qpid-cpp-client-devel-0.30-9.el7.x86_64
candlepin-scl-quartz-2.1.5-6.el7.noarch
qpid-tools-0.30-4.el7.noarch
apvlsat01.mle.mazdaeur.com-qpid-router-server-1.0-3.noarch
qpid-proton-c-0.9-7.el7.x86_64
candlepin-0.9.49.8-1.el7.noarch
candlepin-guice-3.0-2_redhat_1.el7.noarch
qpid-java-common-0.30-3.el7.noarch
candlepin-scl-runtime-1-5.el7.noarch
qpid-cpp-server-0.30-9.el7.x86_64
qpid-qmf-0.30-5.el7.x86_64
candlepin-scl-rhino-1.7R3-3.el7.noarch
ruby193-rubygem-qpid_messaging-0.30.0-1.el7sat.x86_64
qpid-dispatch-router-0.4-10.el7.x86_64
candlepin-common-1.0.22-1.el7.noarch
qpid-cpp-client-0.30-9.el7.x86_64
qpid-cpp-server-linearstore-0.30-9.el7.x86_64
python-qpid-0.30-6.el7.noarch
apvlsat01.mle.mazdaeur.com-qpid-router-client-1.0-3.noarch
apvlsat01.mle.mazdaeur.com-qpid-client-cert-1.0-3.noarch
candlepin-tomcat-0.9.49.8-1.el7.noarch
python-gofer-qpid-2.6.6-2.el7sat.noarch

Comment 5 Pavel Moravec 2015-11-20 22:05:13 UTC
"timed out waiting for completion" usually means that qpid broker applies producer flow control to the queue where candlepin sends messages to (I think named "$(hostname -f):event" ). Gutterball is supposed to consume messages from that queue, so probably gutterball was down.

Everytime I noticed this queue being populated due to gutterball, it ended up in bz1274669, esp. https://bugzilla.redhat.com/show_bug.cgi?id=1274669#c2 . Though that should occur on fresh install..

Comment 7 Tom McKay 2016-04-22 21:01:39 UTC
gutterball will be removed in Sat-6.2; it was the source of many of these qpid issues. Please file a bugzilla if qpid issues persist with Sat-6.2.


Note You need to log in before you can comment on or make changes to this bug.