Bug 11946 - anaconda fails during installation
anaconda fails during installation
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
6.2
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Brock Organ
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-07 09:49 EDT by Nick Sabine
Modified: 2007-03-26 23:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-17 17:33:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nick Sabine 2000-06-07 09:49:03 EDT
When the "Reading Packages" screen is up during installation, I get an
error from anaconda.  This looks very similar to bug #10849, but with a
slightly different error message.

Traceback (innermost last):
  File "/usr/bin/anaconda.real", line
342, in ?
     intf.run(todo, test = test)
  File "usr/lib/anaconda/text.py", line
1165, in run
     rc= apply(step[1](), step[2])
  File "/usr/lib/anaconda/text.py", line
584, in __call__
     todo.getCompsList()
  File "/usr/lib/anaconda/todo.py", line
469, in getCompsList
     self.comps =
self.method.readComps(self.hdList)
  File "/usr/lib/anaconda/harddrive.py",
line 44, in readComps
     "/RedHat/base/comps", hdlist)
  File "/usr/lib/anaconda/comps.py", line
326, in __init__
     self.readCompsFile(file,
self.packages)
  File "/usr/lib/anaconda/comps.py", line
299, in readCompsFile
     Comp.addPackage(packages[l])
  File "/usr/lib/anaconda/comps.py", line
46, in __getitem__
     return self.packages[item]
  KeyError: basesystem


I get the error using the anaconda updates also.  The only difference is a
couple of line numbers.  These line numbers are from using the updates.
In bug #10849, the technician requested to do "p self.instPath" in the
debugger when the problem arises.  I assumed this problem to be similar, so
typed that in the debugger and got:

*** AttributeError: <exceptions.AttributeError instance at 8e57c68>

I hope that is helpful.

Thanks,
-Nick Sabine
Comment 1 Brock Organ 2000-06-09 22:47:54 EDT
Thank you for your report. Were you trying to install in graphical mode (GUI) or
text mode (TUI)?  Was your install a Workstation, Server or Custom install
type?  If Custom install type, do you recall which groups/packages you
selected?  I am hoping that information can help track down the source of your
problem, as we have been unable to reproduce it here ...
Comment 2 Nick Sabine 2000-06-10 01:14:09 EDT
That message came up with GUI installation mode.  I selected KDE workstation 
that particular time, but it happens when I choose Gnome workstation or custom 
also.
-Nick Sabine
Comment 3 Brock Organ 2000-06-23 13:49:57 EDT
hmmm ... are you installing from a mirror site or a downloaded version of RedHat
...? If so, does a re-copy of the install image help this situation ...?

Both this and the #10849 bug sound similar to problems noticed in testing when
having flaky network connections between the install server and the client ...
Comment 4 Need Real Name 2000-07-19 15:26:51 EDT
I have the same problem! I tried with a workstation installation, using Gnome and I tried with a custom Installation using Gnome, withou success.
My computer is a Dell OptiPlex GX110 with 128Ram, 6Gb HD, 3C905 Network adapter.
I downloaded the ISO file from the RED HAT ftp site.
Comment 5 Need Real Name 2000-08-03 10:33:48 EDT
I tried with the same CD on a Dell Optiplex GX1 with success. I don't know why I can't install Red Hat on my GX110
Comment 6 Michael Fulbright 2000-08-17 17:33:05 EDT
We have tested this on our GX110 with no issues.
Comment 7 Frank 2003-12-11 22:07:30 EST
I have the same problem! in a Dell OptiPlex GX110 with 128Ram, 6Gb 
HD, 3C905 Network adapter.
I downloaded the ISO file from the RED HAT ftp site too
X10 fatal 10 error 104 connection reset by peer
Comment 8 Frank 2003-12-11 22:24:02 EST
ok in main choose F3 
then type
linux resolution=1024x768 and enter
start the graphic mode with no problems

Note You need to log in before you can comment on or make changes to this bug.