Bug 11946 - anaconda fails during installation
Summary: anaconda fails during installation
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
Target Milestone: ---
Assignee: Brock Organ
QA Contact: Brock Organ
Depends On:
TreeView+ depends on / blocked
Reported: 2000-06-07 13:49 UTC by Nick Sabine
Modified: 2016-12-17 03:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2000-08-17 21:33:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

Description Nick Sabine 2000-06-07 13:49:03 UTC
When the "Reading Packages" screen is up during installation, I get an
error from anaconda.  This looks very similar to bug #10849, but with a
slightly different error message.

Traceback (innermost last):
  File "/usr/bin/anaconda.real", line
342, in ?
     intf.run(todo, test = test)
  File "usr/lib/anaconda/text.py", line
1165, in run
     rc= apply(step[1](), step[2])
  File "/usr/lib/anaconda/text.py", line
584, in __call__
  File "/usr/lib/anaconda/todo.py", line
469, in getCompsList
     self.comps =
  File "/usr/lib/anaconda/harddrive.py",
line 44, in readComps
     "/RedHat/base/comps", hdlist)
  File "/usr/lib/anaconda/comps.py", line
326, in __init__
  File "/usr/lib/anaconda/comps.py", line
299, in readCompsFile
  File "/usr/lib/anaconda/comps.py", line
46, in __getitem__
     return self.packages[item]
  KeyError: basesystem

I get the error using the anaconda updates also.  The only difference is a
couple of line numbers.  These line numbers are from using the updates.
In bug #10849, the technician requested to do "p self.instPath" in the
debugger when the problem arises.  I assumed this problem to be similar, so
typed that in the debugger and got:

*** AttributeError: <exceptions.AttributeError instance at 8e57c68>

I hope that is helpful.

-Nick Sabine

Comment 1 Brock Organ 2000-06-10 02:47:54 UTC
Thank you for your report. Were you trying to install in graphical mode (GUI) or
text mode (TUI)?  Was your install a Workstation, Server or Custom install
type?  If Custom install type, do you recall which groups/packages you
selected?  I am hoping that information can help track down the source of your
problem, as we have been unable to reproduce it here ...

Comment 2 Nick Sabine 2000-06-10 05:14:09 UTC
That message came up with GUI installation mode.  I selected KDE workstation 
that particular time, but it happens when I choose Gnome workstation or custom 
-Nick Sabine

Comment 3 Brock Organ 2000-06-23 17:49:57 UTC
hmmm ... are you installing from a mirror site or a downloaded version of RedHat
...? If so, does a re-copy of the install image help this situation ...?

Both this and the #10849 bug sound similar to problems noticed in testing when
having flaky network connections between the install server and the client ...

Comment 4 Need Real Name 2000-07-19 19:26:51 UTC
I have the same problem! I tried with a workstation installation, using Gnome and I tried with a custom Installation using Gnome, withou success.
My computer is a Dell OptiPlex GX110 with 128Ram, 6Gb HD, 3C905 Network adapter.
I downloaded the ISO file from the RED HAT ftp site.

Comment 5 Need Real Name 2000-08-03 14:33:48 UTC
I tried with the same CD on a Dell Optiplex GX1 with success. I don't know why I can't install Red Hat on my GX110

Comment 6 Michael Fulbright 2000-08-17 21:33:05 UTC
We have tested this on our GX110 with no issues.

Comment 7 Frank 2003-12-12 03:07:30 UTC
I have the same problem! in a Dell OptiPlex GX110 with 128Ram, 6Gb 
HD, 3C905 Network adapter.
I downloaded the ISO file from the RED HAT ftp site too
X10 fatal 10 error 104 connection reset by peer

Comment 8 Frank 2003-12-12 03:24:02 UTC
ok in main choose F3 
then type
linux resolution=1024x768 and enter
start the graphic mode with no problems

Comment 9 openshift-github-bot 2016-12-17 03:37:01 UTC
Commit pushed to master at https://github.com/openshift/origin

Updating usage of the --metrics flag to create a job

Updated the --metrics flag of the oc cluster up command to create a job
so that it will automatically retry if it fails due to the service account
token not being created yet.

Fixes issue #11946

Note You need to log in before you can comment on or make changes to this bug.