Bug 119463 - mrtg cronjob email contain lots of perl errors
Summary: mrtg cronjob email contain lots of perl errors
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: mrtg (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Miloslav Trmač
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 122683
TreeView+ depends on / blocked
 
Reported: 2004-03-30 18:57 UTC by Bernd Bartmann
Modified: 2007-11-30 22:10 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-29 22:12:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bernd Bartmann 2004-03-30 18:57:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
The default mrtg cronjob sends these error messages each time it is run:

Use of uninitialized value in string at /usr/bin/mrtg line 72.
Empty compile time value given to use lib at /usr/bin/mrtg line 72
Use of uninitialized value in concatenation (.) or string at
/usr/bin/mrtg line 73.
Can't locate MRTG_lib.pm in @INC (@INC contains: /../lib/mrtg2 
/usr/lib/perl5/5.8.3/i386-linux-thread-multi /usr/lib/perl5/5.8.3
+/usr/lib/perl5/site_perl/5.8.3/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.2/i386-linux-thread-multi
+/usr/lib/perl5/site_perl/5.8.1/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi
+/usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.8.2
/usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.8.0
+/usr/lib/perl5/site_perl
/usr/lib/perl5/vendor_perl/5.8.3/i386-linux-thread-multi
+/usr/lib/perl5/vendor_perl/5.8.2/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.1/i386-linux-thread-multi
+/usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.3 /usr/lib/perl5/vendor_perl/5.8.2
+/usr/lib/perl5/vendor_perl/5.8.1 /usr/lib/perl5/vendor_perl/5.8.0
/usr/lib/perl5/vendor_perl .) at /usr/bin/mrtg line 78.
BEGIN failed--compilation aborted at /usr/bin/mrtg line 78.


Version-Release number of selected component (if applicable):
mrtg-2.10.5-2.1

How reproducible:
Always

Steps to Reproduce:
1. FC2Test2 everything install
2. wait for mrtg cronjob emails
3.
    

Additional info:

Comment 1 Need Real Name 2004-04-02 18:09:09 UTC
Same for me.

Comment 2 Bernd Bartmann 2004-04-04 17:00:34 UTC
The problem seems to be SELinux related. After reinstalling the system
with SELinux disabled the problem does not appear again.

Comment 3 Warren Togami 2004-05-07 04:16:45 UTC
Any update on this with FC2 latest?

Comment 4 Bernd Bartmann 2004-05-07 07:50:15 UTC
I haven't seen this problem on a default full FC2T3 install anymore.

Comment 5 Miloslav Trmač 2004-09-29 22:12:48 UTC
I haven't seen this with FC3t2 either (even with strict policy).


Note You need to log in before you can comment on or make changes to this bug.