Bug 1194682 - Qt plugins fail to load or crash when built with gcc5
Summary: Qt plugins fail to load or crash when built with gcc5
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedBlocker AcceptedFreezeException
: 1195237 (view as bug list)
Depends On:
Blocks: F22AlphaFreezeException F22Blocker-kde
TreeView+ depends on / blocked
 
Reported: 2015-02-20 14:25 UTC by Martin Kho
Modified: 2015-03-09 16:29 UTC (History)
17 users (show)

Fixed In Version: gcc-5.0.0-0.17.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-09 14:14:59 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNU Compiler Collection 65209 None None None Never

Description Martin Kho 2015-02-20 14:25:16 UTC
Description of problem:
Downgrading to version 5.6.0-1 'solves' it.

e.g kmix.:

Application: KMixCtrl (kmixctrl), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[KCrash Handler]
#5  ~QHash (this=0x10000002f, __in_chrg=<optimized out>) at ../../src/corelib/tools/qhash.h:302
#6  ~QReadWriteLockPrivate (this=0xffffffff, __in_chrg=<optimized out>) at thread/qreadwritelock_p.h:55
#7  QReadWriteLock::~QReadWriteLock (this=0x7f9a6b013d48, __in_chrg=<optimized out>) at thread/qreadwritelock.cpp:123
#8  0x00007f9a6ac5833d in KMimeTypeRepository::~KMimeTypeRepository() () from /lib64/libKF5KDELibs4Support.so.5
#9  0x00007f9a6ac59d19 in (anonymous namespace)::Q_QGS_s_self::innerFunction()::Holder::~Holder() () from /lib64/libKF5KDELibs4Support.so.5
#10 0x00007f9a62d9e5e8 in __run_exit_handlers () from /lib64/libc.so.6
#11 0x00007f9a62d9e635 in exit () from /lib64/libc.so.6
#12 0x00007f9a62d85787 in __libc_start_main () from /lib64/libc.so.6
#13 0x0000000000400ac9 in _start ()


Version-Release number of selected component (if applicable):
kf5-kdelibs4support-5.7.0-1.fc22.x86_64.rpm

How reproducible:
always

Steps to Reproduce:
1. login (kmixctl, kaccess are crashed)
2.
3.

Actual results:
many applications crash

Expected results:
no application crashes

Additional info:

Comment 1 Rex Dieter 2015-02-22 14:17:48 UTC
Fwiw, I cannot reproduce any such problem on my f21 box + kf5-5.7 + plasma5

Could be another gcc5-ism, awaiting more tester feedback.

Comment 2 Martin Kho 2015-02-22 16:00:14 UTC
Hi,

After building and install installing plasma-workspace-5.2.0-8 and updating to kf5-5.7 on F20 everything works ok for me. So, yes - to me - it looks like an gcc5 issue.

Martin Kho

Note: plasma-workspace 5.2.0-8 needs to be build for F20. I had an issue with kf5-kscreen/kscreen/libkscreen (obsolate?/replaced by kscreen/libkscreen-qt5). libscreen is still installed, because okular needs it. Thist is fine.

Comment 3 Daniel Vrátil 2015-02-24 09:58:12 UTC
I'll be updating Plasma 5 in rawhide to 5.2.1 today, so we will get gcc5 rebuild "for free" :-)

Comment 4 Sandro Mani 2015-02-25 00:27:26 UTC
A simple gcc5 rebuild probably will not be sufficient - I'm trying to narrow down the issue and with the latest gcc-5.0.0-0.15.fc23.x86_64 the crash still occurs. Hopefully I'll have a testcase suitable for a gcc bug report by tomorrow.

Comment 5 Rex Dieter 2015-02-27 15:22:54 UTC
Re-assigning to gcc, and upstream fix committed it seems.

Comment 6 Fedora Blocker Bugs Application 2015-02-27 15:25:06 UTC
Proposed as a Blocker for 22-alpha by Fedora user rdieter using the blocker tracking app because:

 Lots of Qt5/Plasma5 crashiness, hits hard loading some (important) plugins.  Looks like upstream gcc fix is committed already.

Comment 7 Jakub Jelinek 2015-02-27 15:26:45 UTC
Then please try https://admin.fedoraproject.org/updates/gcc-5.0.0-0.17.fc22
and if it works, provide karma.

Comment 8 Rex Dieter 2015-02-27 22:48:03 UTC
OK, kde-sig is building a whole stack of things using that build.  Will give feedback when testing is underway.

Comment 9 Fedora Update System 2015-03-01 18:03:47 UTC
qt5-qtdoc-5.4.1-1.fc22, qt5-qttranslations-5.4.1-1.fc22, qt5-qtimageformats-5.4.1-2.fc22, qt5-qtx11extras-5.4.1-2.fc22, qt5-qtdeclarative-5.4.1-2.fc22, qt5-qtlocation-5.4.1-2.fc22, qt5-qtsensors-5.4.1-2.fc22, qt5-qtwebkit-5.4.1-2.fc22, qt5-qtserialport-5.4.1-1.fc22, qt5-qtbase-5.4.1-3.fc22, qt5-qtsvg-5.4.1-2.fc22, qt5-qtxmlpatterns-5.4.1-2.fc22, qt5-qtquickcontrols-5.4.1-2.fc22, qt5-qtconnectivity-5.4.1-2.fc22, qt5-qtmultimedia-5.4.1-2.fc22, qt5-qtgraphicaleffects-5.4.1-2.fc22, qt5-qttools-5.4.1-2.fc22, qt5-qtscript-5.4.1-2.fc22, qt5-qtwayland-5.4.1-1.fc22, qt5-qtquick1-5.4.1-2.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/FEDORA-2015-2639/qt5-qtserialport-5.4.1-1.fc22,qt5-qtwayland-5.4.1-1.fc22,qt5-qtbase-5.4.1-3.fc22,qt5-qtimageformats-5.4.1-2.fc22,qt5-qtsvg-5.4.1-2.fc22,qt5-qtx11extras-5.4.1-2.fc22,qt5-qtxmlpatterns-5.4.1-2.fc22,qt5-qtdeclarative-5.4.1-2.fc22,qt5-qtquickcontrols-5.4.1-2.fc22,qt5-qtdoc-5.4.1-1.fc22,qt5-qtconnectivity-5.4.1-2.fc22,qt5-qtlocation-5.4.1-2.fc22,qt5-qtmultimedia-5.4.1-2.fc22,qt5-qtsensors-5.4.1-2.fc22,qt5-qtgraphicaleffects-5.4.1-2.fc22,qt5-qtwebkit-5.4.1-2.fc22,qt5-qttools-5.4.1-2.fc22,qt5-qttranslations-5.4.1-1.fc22,qt5-qtscript-5.4.1-2.fc22,qt5-qtquick1-5.4.1-2.fc22

Comment 10 Martin Kho 2015-03-02 12:57:24 UTC
Hi,

The rebuild of these package are supposed to stop the crashes? Did I miss something or...? At least for me, I still see the crashes (kmixctl, kaccess).

Martin Kho

Comment 11 Sandro Mani 2015-03-02 12:58:42 UTC
Are you using kf5-kdelibs4support-5.7.0-2.fc23?

$ rpm -qa kf5-kdelibs4support

Comment 12 Sandro Mani 2015-03-02 12:59:30 UTC
(the fc23 part is not important, the 5.7.0-2 part is)

Comment 13 Martin Kho 2015-03-02 13:06:50 UTC
Hi Sandro,

No, my version is kf5-kdelibs4support-5.7.0-1.fc22.x86_64. I'll see what happens when I update to -2.

Thanks for now, you'll here what I find.

Martin Kho

Comment 14 Martin Kho 2015-03-02 13:15:14 UTC
Well very nice! That seems to work. The crashes are over.

Congratulations!

Thanks,

Martin Kho

Comment 15 Rex Dieter 2015-03-02 13:49:47 UTC
FYI, the rebuilt qt5 packages are just one part of fixing this.  We are planning on rebuilding kf5/plasma5 stack against the fixed gcc as well, to ensure proper loading of all plugins.

Comment 16 Petr Schindler 2015-03-02 20:37:14 UTC
Discussed at today's blocker review meeting [1].

This bug was rejected as Alpha blocker but will be considered as Freeze Exception - This bug doesn't break enough of the KDE environment to be considered blocker for Alpha, but it does lead to many KDE/Qt components crashing and so we accept that it's a reasonable risk/benefit tradeoff to rebuild the core components with fixed GCC. Accepted as a Freeze Exception. Less vital rebuilds can be done as updates.

http://meetbot.fedoraproject.org/fedora-blocker-review/2015-03-02/

Comment 17 Petr Schindler 2015-03-02 21:00:15 UTC
Also please try to be conservative and keep rebuilds to the minimum so the chance of some side effect is minimal. Thank you.

Comment 18 Fedora Update System 2015-03-02 23:16:44 UTC
kf5-attica-5.7.0-2.fc22,kf5-baloo-5.6.1-2.fc22,kf5-frameworkintegration-5.7.0-2.fc22,kf5-kactivities-5.7.0-2.fc22,kf5-kapidox-5.7.0-2.fc22,kf5-karchive-5.7.0-2.fc22,kf5-kauth-5.7.0-2.fc22,kf5-kbookmarks-5.7.0-2.fc22,kf5-kcmutils-5.7.0-2.fc22,kf5-kcodecs-5.7.0-2.fc22,kf5-kcompletion-5.7.0-2.fc22,kf5-kconfig-5.7.0-2.fc22,kf5-kconfigwidgets-5.7.0-2.fc22,kf5-kcoreaddons-5.7.0-2.fc22,kf5-kcrash-5.7.0-2.fc22,kf5-kdbusaddons-5.7.0-2.fc22,kf5-kdeclarative-5.7.0-2.fc22,kf5-kded-5.7.0-2.fc22,kf5-kdelibs4support-5.7.0-2.fc22,kf5-kdesignerplugin-5.7.0-2.fc22,kf5-kdesu-5.7.0-2.fc22,kf5-kdewebkit-5.7.0-2.fc22,kf5-kdnssd-5.7.0-2.fc22,kf5-kdoctools-5.7.0-2.fc22,kf5-kemoticons-5.7.0-2.fc22,kf5-kfilemetadata-5.6.1-2.fc22,kf5-kguiaddons-5.7.0-2.fc22,kf5-khtml-5.7.0-2.fc22,kf5-ki18n-5.7.0-2.fc22,kf5-kiconthemes-5.7.0-2.fc22,kf5-kidletime-5.7.0-2.fc22,kf5-kimageformats-5.7.0-2.fc22,kf5-kinit-5.7.0-2.fc22,kf5-kio-5.7.0-2.fc22,kf5-kitemmodels-5.7.0-2.fc22,kf5-kitemviews-5.7.0-2.fc22,kf5-kjobwidgets-5.7.0-2.fc22,kf5-kjs-5.7.0-2.fc22,kf5-kjsembed-5.7.0-2.fc22,kf5-kmediaplayer-5.7.0-2.fc22,kf5-knewstuff-5.7.0-2.fc22,kf5-knotifications-5.7.0-2.fc22,kf5-knotifyconfig-5.7.0-2.fc22,kf5-kpackage-5.7.0-2.fc22,kf5-kparts-5.7.0-2.fc22,kf5-kplotting-5.7.0-2.fc22,kf5-kpty-5.7.0-2.fc22,kf5-kross-5.7.0-2.fc22,kf5-krunner-5.7.0-2.fc22,kf5-kservice-5.7.0-2.fc22,kf5-ktexteditor-5.7.0-2.fc22,kf5-ktextwidgets-5.7.0-2.fc22,kf5-kunitconversion-5.7.0-2.fc22,kf5-kwallet-5.7.0-2.fc22,kf5-kwayland-5.2.1-2.fc22,kf5-kwidgetsaddons-5.7.0-2.fc22,kf5-kwindowsystem-5.7.0-2.fc22,kf5-kxmlgui-5.7.0-2.fc22,kf5-modemmanager-qt-5.2.1-2.fc22,kf5-plasma-5.7.0-2.fc22,kf5-solid-5.7.0-2.fc22,kf5-sonnet-5.7.0-2.fc22,kf5-threadweaver-5.7.0-2.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/kf5-attica-5.7.0-2.fc22,kf5-baloo-5.6.1-2.fc22,kf5-frameworkintegration-5.7.0-2.fc22,kf5-kactivities-5.7.0-2.fc22,kf5-kapidox-5.7.0-2.fc22,kf5-karchive-5.7.0-2.fc22,kf5-kauth-5.7.0-2.fc22,kf5-kbookmarks-5.7.0-2.fc22,kf5-kcmutils-5.7.0-2.fc22,kf5-kcodecs-5.7.0-2.fc22,kf5-kcompletion-5.7.0-2.fc22,kf5-kconfig-5.7.0-2.fc22,kf5-kconfigwidgets-5.7.0-2.fc22,kf5-kcoreaddons-5.7.0-2.fc22,kf5-kcrash-5.7.0-2.fc22,kf5-kdbusaddons-5.7.0-2.fc22,kf5-kdeclarative-5.7.0-2.fc22,kf5-kded-5.7.0-2.fc22,kf5-kdelibs4support-5.7.0-2.fc22,kf5-kdesignerplugin-5.7.0-2.fc22,kf5-kdesu-5.7.0-2.fc22,kf5-kdewebkit-5.7.0-2.fc22,kf5-kdnssd-5.7.0-2.fc22,kf5-kdoctools-5.7.0-2.fc22,kf5-kemoticons-5.7.0-2.fc22,kf5-kfilemetadata-5.6.1-2.fc22,kf5-kguiaddons-5.7.0-2.fc22,kf5-khtml-5.7.0-2.fc22,kf5-ki18n-5.7.0-2.fc22,kf5-kiconthemes-5.7.0-2.fc22,kf5-kidletime-5.7.0-2.fc22,kf5-kimageformats-5.7.0-2.fc22,kf5-kinit-5.7.0-2.fc22,kf5-kio-5.7.0-2.fc22,kf5-kitemmodels-5.7.0-2.fc22,kf5-kitemviews-5.7.0-2.fc22,kf5-kjobwidgets-5.7.0-2.fc22,kf5-kjs-5.7.0-2.fc22,kf5-kjsembed-5.7.0-2.fc22,kf5-kmediaplayer-5.7.0-2.fc22,kf5-knewstuff-5.7.0-2.fc22,kf5-knotifications-5.7.0-2.fc22,kf5-knotifyconfig-5.7.0-2.fc22,kf5-kpackage-5.7.0-2.fc22,kf5-kparts-5.7.0-2.fc22,kf5-kplotting-5.7.0-2.fc22,kf5-kpty-5.7.0-2.fc22,kf5-kross-5.7.0-2.fc22,kf5-krunner-5.7.0-2.fc22,kf5-kservice-5.7.0-2.fc22,kf5-ktexteditor-5.7.0-2.fc22,kf5-ktextwidgets-5.7.0-2.fc22,kf5-kunitconversion-5.7.0-2.fc22,kf5-kwallet-5.7.0-2.fc22,kf5-kwayland-5.2.1-2.fc22,kf5-kwidgetsaddons-5.7.0-2.fc22,kf5-kwindowsystem-5.7.0-2.fc22,kf5-kxmlgui-5.7.0-2.fc22,kf5-modemmanager-qt-5.2.1-2.fc22,kf5-plasma-5.7.0-2.fc22,kf5-solid-5.7.0-2.fc22,kf5-sonnet-5.7.0-2.fc22,kf5-threadweaver-5.7.0-2.fc22

Comment 19 Adam Williamson 2015-03-03 16:26:17 UTC
We've been discussing it on IRC, but for the BZ record, it seems we still have issues here :(

I built a test live image with all three updates listed so far:

https://admin.fedoraproject.org/updates/FEDORA-2015-2759/gcc-5.0.0-0.17.fc22
https://admin.fedoraproject.org/updates/FEDORA-2015-2639/qt5-qtserialport-5.4.1-1.fc22
https://admin.fedoraproject.org/updates/kf5-attica-5.7.0-2.fc22

it does not work well. There is significant visual corruption in the desktop: odd black bars all over the place, categories not visible in the Kicker menu, the initial short cuts in the Kicker menu do not work when clicked, searching in Kicker works but it turns black as soon as you run a search, and so on - it's really not a usable desktop.

jreznik confirmed the same with an installed system updated with the qt5 update.

I downloaded the last update before kf5-wayland and kf5-modemmanager-qt were removed from it, for whatever difference that makes.

Comment 20 Sandro Mani 2015-03-03 16:33:41 UTC
Just an idea, is this on a physical system with an intel chip? I noticed all sorts of corruption with xorg-x11-drv-intel > 2.99.917-3.20150211. Didn't have time to investigate further though.

Comment 21 Adam Williamson 2015-03-03 16:42:59 UTC
No, it's in a KVM with qxl/SPICE.

Comment 22 Jaroslav Reznik 2015-03-04 15:38:29 UTC
So it looks more like some regression between 5.4.0 and 5.4.1 as I could reproduce the same breakage on clean F21 install with all updates and Plasma 5 from dvratil's Copr... And it only affects KVM/QXL/SPICE as I'm running the same package set on my laptop without any issues and rdieter did not see it on HW neither.

Comment 23 Rex Dieter 2015-03-04 15:43:52 UTC
kkofler/jgrulich whipped up a set of qt-5.4.0 gcc rebuilds for specific testing:

qt5-qtbase-5.4.0-14.fc22
qt5-qtdeclarative-5.4.0-3.fc22

(and others, but I think these are 2 most important ones)

Can someone test these on top of stock f22-alpha images to see if this is better than the proposed qt-5.4.1 ones?

Comment 24 Adam Williamson 2015-03-04 17:40:04 UTC
it's not *only* qxl/SPICE for me; it also affects KVM/vga/VNC. But not my bare metal systems either.

I ran a test build which was basically TC8 with the qt5 rebuilds from #c23 but no other packages (no kf5 rebuilds) and it works much like TC8 - no corruption, but crashes.

I'm now testing a spin with the qt5 packages from #c23 plus the kf5 rebuilds from yesterday.

Comment 25 Adam Williamson 2015-03-04 18:29:31 UTC
OK, that test looks very good. I built an image using:

qt5-qtbase-5.4.0-14.fc22
qt5-qtdeclarative-5.4.0-3.fc22
https://admin.fedoraproject.org/updates/kf5-attica-5.7.0-2.fc22
https://admin.fedoraproject.org/updates/FEDORA-2015-2759/gcc-5.0.0-0.17.fc22

and I get no corruption in a KVM, no crashes of any component, and anaconda appearance is much better (it looks just like it does in GNOME; I'm guessing the fact that kcminit no longer crashes is responsible for that). Install works, Konsole and Konqueror work, and Apper works. This looks like the best package set to go with for TC9/RC1, from my testing. Can we get an update for qt5 5.4.0?

Comment 26 Fedora Update System 2015-03-04 18:35:19 UTC
qt5-qtdeclarative-5.4.0-3.fc22,qt5-qtbase-5.4.0-14.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/qt5-qtdeclarative-5.4.0-3.fc22,qt5-qtbase-5.4.0-14.fc22

Comment 27 Fedora Update System 2015-03-07 00:06:24 UTC
kf5-attica-5.7.0-2.fc22, kf5-baloo-5.6.1-2.fc22, kf5-frameworkintegration-5.7.0-2.fc22, kf5-kactivities-5.7.0-2.fc22, kf5-kapidox-5.7.0-2.fc22, kf5-karchive-5.7.0-2.fc22, kf5-kauth-5.7.0-2.fc22, kf5-kbookmarks-5.7.0-2.fc22, kf5-kcmutils-5.7.0-2.fc22, kf5-kcodecs-5.7.0-2.fc22, kf5-kcompletion-5.7.0-2.fc22, kf5-kconfig-5.7.0-2.fc22, kf5-kconfigwidgets-5.7.0-2.fc22, kf5-kcoreaddons-5.7.0-2.fc22, kf5-kcrash-5.7.0-2.fc22, kf5-kdbusaddons-5.7.0-2.fc22, kf5-kdeclarative-5.7.0-2.fc22, kf5-kded-5.7.0-2.fc22, kf5-kdelibs4support-5.7.0-2.fc22, kf5-kdesignerplugin-5.7.0-2.fc22, kf5-kdesu-5.7.0-2.fc22, kf5-kdewebkit-5.7.0-2.fc22, kf5-kdnssd-5.7.0-2.fc22, kf5-kdoctools-5.7.0-2.fc22, kf5-kemoticons-5.7.0-2.fc22, kf5-kfilemetadata-5.6.1-2.fc22, kf5-kguiaddons-5.7.0-2.fc22, kf5-khtml-5.7.0-2.fc22, kf5-ki18n-5.7.0-2.fc22, kf5-kiconthemes-5.7.0-2.fc22, kf5-kidletime-5.7.0-2.fc22, kf5-kimageformats-5.7.0-2.fc22, kf5-kinit-5.7.0-2.fc22, kf5-kio-5.7.0-2.fc22, kf5-kitemmodels-5.7.0-2.fc22, kf5-kitemviews-5.7.0-2.fc22, kf5-kjobwidgets-5.7.0-2.fc22, kf5-kjs-5.7.0-2.fc22, kf5-kjsembed-5.7.0-2.fc22, kf5-kmediaplayer-5.7.0-2.fc22, kf5-knewstuff-5.7.0-2.fc22, kf5-knotifications-5.7.0-2.fc22, kf5-knotifyconfig-5.7.0-2.fc22, kf5-kpackage-5.7.0-2.fc22, kf5-kparts-5.7.0-2.fc22, kf5-kplotting-5.7.0-2.fc22, kf5-kpty-5.7.0-2.fc22, kf5-kross-5.7.0-2.fc22, kf5-krunner-5.7.0-2.fc22, kf5-kservice-5.7.0-2.fc22, kf5-ktexteditor-5.7.0-2.fc22, kf5-ktextwidgets-5.7.0-2.fc22, kf5-kunitconversion-5.7.0-2.fc22, kf5-kwallet-5.7.0-2.fc22, kf5-kwidgetsaddons-5.7.0-2.fc22, kf5-kwindowsystem-5.7.0-2.fc22, kf5-kxmlgui-5.7.0-2.fc22, kf5-plasma-5.7.0-2.fc22, kf5-solid-5.7.0-2.fc22, kf5-sonnet-5.7.0-2.fc22, kf5-threadweaver-5.7.0-2.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 28 Fedora Update System 2015-03-07 00:08:54 UTC
qt5-qtdeclarative-5.4.0-3.fc22, qt5-qtbase-5.4.0-14.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 29 Martin Kho 2015-03-09 13:04:05 UTC
Hi,

Everything seems fine for me, no crashes seen. I tried fedora 22 Alpha 3 and all was good. So after a really stressfull periode, I'm sure we will have - as we are used to - a very nice kde spin.

Congratulations and thanks,

Martin Kho

Comment 30 Rex Dieter 2015-03-09 14:14:59 UTC
Closing per all positive feedback/testing

Comment 31 Rex Dieter 2015-03-09 16:29:46 UTC
*** Bug 1195237 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.