Bug 1194684 - Organization, location or owner containing non ascii characters makes will result in ERROR 400 from server when puppet runs
Summary: Organization, location or owner containing non ascii characters makes will re...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Organizations and Locations
Version: 6.1.0
Hardware: All
OS: All
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Ohad Levy
QA Contact: jcallaha
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-20 14:32 UTC by Tomas Åberg
Modified: 2019-09-25 21:15 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:48:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 12541 None None None 2016-04-22 16:20:39 UTC
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Tomas Åberg 2015-02-20 14:32:33 UTC
Description of problem:

--- LDAP ---
I've setup authentication against a ActiveDirectory with the following attribute mappings:
* Login Name attribute: sAMAccountName
* First name attribute: givenName
* Surname attribute: sn
* Email address attribute: mail

When a user, organization or location have name containing characters with non ASCII charachters such as å,ä,ö and its assigned to a system which is puppet controlled you'll receive error:

Warning: Unable to fetch my node definition, but the agent run will continue:
Warning: Error 400 on SERVER: invalid byte sequence in US-ASCII

Error: Could not retrieve catalog from remote server: Error 400 on SERVER: Failed when searching for node node01.example.com: invalid byte sequence in US-ASCII
Warning: Not using cache on failed catalog
Error: Could not retrieve catalog; skipping run

Version-Release number of selected component (if applicable):
Red Hat Satellite
Version 6.0.7 © 2014 Red Hat Inc.

How reproducible:
1. Add user, location or organization containing non ascii characters
2. Assign either of them to a puppet controlled system
3. Wait for or kick a puppet run

Actual results:
Warning: Unable to fetch my node definition, but the agent run will continue:
Warning: Error 400 on SERVER: invalid byte sequence in US-ASCII

Error: Could not retrieve catalog from remote server: Error 400 on SERVER: Failed when searching for node node01.example.com: invalid byte sequence in US-ASCII
Warning: Not using cache on failed catalog
Error: Could not retrieve catalog; skipping run


Expected results:
Successful puppet run

Comment 1 RHEL Program Management 2015-02-20 15:42:08 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 5 Brad Buckingham 2015-11-19 23:05:31 UTC
Created redmine issue http://projects.theforeman.org/issues/12541 from this bug

Comment 6 Bryan Kearney 2015-11-20 01:02:24 UTC
Upstream bug component is Provisioning

Comment 7 Tomas Åberg 2016-02-11 14:26:44 UTC
I've a server running Red Hat Satellite 6.1.6. This issue does not seem to reproduce there. I can use å,ä or ö as surname attribute. This caused the server to crash before.

Comment 8 Tomer Brisker 2016-02-29 15:07:02 UTC
Seems this was solved in 6.1.6 per comment #7. Moving to ON_QA for verification.

Comment 10 jcallaha 2016-05-05 18:29:09 UTC
Verified in Satellite 6.2 Beta RC. Organization, Location, and User names all contained non-ascii characters. Everything functioning properly.
As a side not, you can no longer create an Organization with non-ascii characters in the label.

Comment 12 errata-xmlrpc 2016-07-27 08:48:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.