Bug 119470 - XFree86/Anaconda does not configure correctly NetVista 6643 11u X40
XFree86/Anaconda does not configure correctly NetVista 6643 11u X40
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-30 14:44 EST by Douglas Baggett
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-22 15:10:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Technical Information Manual For Netvista X40 type 6643 (264.68 KB, application/pdf)
2004-03-30 14:46 EST, Douglas Baggett
no flags Details

  None (edit)
Description Douglas Baggett 2004-03-30 14:44:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040213

Description of problem:
I doubt if anybody will ever fix this or even care...but who am I to
say it shouldn't be recorded SOMEWHERE...

The Netvista 6643 11U X40 is an "All on one" Celeron system that IBM
manufactured back in 2000. It has an SiS 630 chipset used for video.
Typically, in order to use X on this system VESA needs to be used.
Hand configuring the Xfree86 Configuration file works, but upon first
installation when Anaconda/Xfree86 tries to autoprobe the video type
and Monitor (LCD) it correctly identifies the SiS 630...but not the
monitor (unknown). I can't be sure, but it looks like it tries to
start Xfree86...the screen is somewhat garbled or nonexistent...but
the installer continues anyhow (even though you cannot see the screen
or make it out). The solution is to run the installer in text mode.
I'm thinking that maybe X in Anaconda is starting VESA but has got the
horizontal and vertical frequencies wrong.

Not sure if there is a fix even possible for this...but in case
anybody else needs to install Fedora on this little system the bug
will be here!

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Try to install Fedora core 2 in default graphical mode
2.
3.
    

Actual Results:  The installer actually thinks it's successfully
started X, but the display is unreadable

Expected Results:  I should be able to see the screen

Additional info:

Workaround - run X in text mode....then hand hack the XFree86 Config
file after the fact to use Vesa with a conservative set of values for
Horizontal and Vertical Frequencies
Comment 1 Douglas Baggett 2004-03-30 14:46:10 EST
Created attachment 98978 [details]
Technical Information Manual For Netvista X40 type 6643

This will probably dissapear someday off of the IBM website...but here is the
manual for this system incase anybody needs to see the specs for this system to
fix the bug
Comment 2 Douglas Baggett 2004-03-30 14:49:12 EST
Ooops...the Workaround should say Run the installer in text
mode....not run "X" in text mode :)

Note You need to log in before you can comment on or make changes to this bug.