Bug 119480 - Fail to initialize usb-storage
Fail to initialize usb-storage
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Depends On:
Blocks: FC2Target FC3Target FC4Target
  Show dependency treegraph
Reported: 2004-03-30 15:53 EST by Frederic Soulier
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-12-08 01:58:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Frederic Soulier 2004-03-30 15:53:20 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6)
Gecko/20040206 Firefox/0.8

Description of problem:
Trying to install FC2 T2 from CDs. Booting from CD1 with "linux xfs".
Starts loading modules like firewire, SCSI, etc... then get stuck on
"loading usb-storage". In ALT-F4 I can see it's trying to initialize
the usb-storage.

I have a firewire enclosure and a USB2.0 card reader connected.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. USB2.0 card reader connected
2. Firewire enclosure (with 2 HDs in it) connected and switched on
3. Boot from CD1
4. Enter "linux xfs" at prompt


Actual Results:  You get "loading usb-storage" forever on your screen
because it fails to initialize the usb-storage

Expected Results:  Installation should move on to the next step

Additional info:

Note: if I disconnect the USB2.0 card reader the installation process
gets through.

It was fine with FC2 T1...
Comment 1 Arjan van de Ven 2004-03-31 01:10:13 EST
does that work without passing "xfs" ?
Comment 2 Frederic Soulier 2004-03-31 13:18:18 EST
No. Just hitting enter will give the same error. It's not related to xfs.
Comment 3 Frederic Soulier 2004-05-03 09:35:12 EDT
Same problem with FC2 Test3...
Comment 4 Chad Carr 2004-05-14 23:59:29 EDT
I have a slightly different problem: when I boot with my card reader
(empty) and hard drive (both usb 2.0) attached, the installer stops on
the blue screen.  vt3 shows "removing usb-storage" but the rmmod never
succeeds and the installer never proceeds.  When I unplug both
devices, the installer proceeds as normal.  Worked with both FC2 test1
and FC1.
Comment 5 Lars S. Jensen 2004-05-18 16:36:05 EDT
FC2 have that same problem (x86_86) My system is a Shuttle SN85G4
Athlon64 with build-in usb card reader/writter) "Loading usb-storage
Could not test it on FC2T3 because of the missing sata_sil driver. 
Any workaround except remove the connections  ? 
Comment 7 Pete Zaitcev 2004-08-18 01:06:20 EDT
This needs SysRq to diagnose, but on boot kernel it's no use
(no KALLSYMS). I don't have good ideas. A bad idea might be
to create a test kernel with usb-storage debugging compiled in,
then adding it into the iso. I just did that excercise on weekend,
it's pretty painful.

If anyone can make it hang while running an installed system,
it would be helpful. Installer environment is too limited.
Try to see if running kudzu makes this to happen while card
reader is empty (and when there's a card in it - it's a test
for START_STOP support).
Comment 8 Dave Jones 2004-10-29 23:37:44 EDT
Is this still a problem with current kernels ?
Comment 9 Frederic Soulier 2004-10-30 04:55:51 EDT
I don't get this pbm anymore with latest FC3T3. Although trying on a
different box than when I reported the pbm I still have a firewire
card and a USB card reader so the situation is pretty similar.
I'm using an Asus P4S800D-E Deluxe + internal USB card reader 7 in 1.
Comment 10 Pete Zaitcev 2004-11-03 15:05:10 EST
Frederic, this has to be closed. If bugs with common enough description
stay around other people cling to them instead of filing... Witness
Chad and Lars. If they still have problems, they need to file.

Note You need to log in before you can comment on or make changes to this bug.